E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Pure Turbos N55 Stage 2 (PS2) results, reviews, install tips and docs, pictures, etc



Reply
 
Thread Tools Search this Thread
      07-31-2017, 06:17 PM   #23
cranelec
Private
18
Rep
91
Posts

Drives: BMW
Join Date: Nov 2013
Location: NEPA

iTrader: (0)

Garage List
2011 335i xDrive  [0.00]
2007 BMW 328xi  [0.00]
Quote:
Originally Posted by JETmn View Post
Quote:
Originally Posted by houtan View Post
Going to add the keep the lines on the turbo method to my post.

So it's sounds like hit or miss on whether or not the lines will come off without being damaged. But it is definitely clear, they are a PITA to remove! haha
Just a note, X-drive the turbo won't come out with the lines on it I don't think. I barely got the turbo out the way it was.
Quote:
Originally Posted by JETmn View Post
Just a note, X-drive the turbo won't come out with the lines on it I don't think. I barely got the turbo out the way it was.
JETmn, if you remove the motor mount including the aluminum part which attaches the mount to the engine block and then raise the engine 1.5 inches, the entire turbofold drops out of the 335i xdrive easily.
Appreciate 1
JETmn241.00

      07-31-2017, 06:52 PM   #24
Turbod
Captain
Turbod's Avatar
United_States
200
Rep
808
Posts

Drives: 2011 E92 335i Auto
Join Date: Mar 2015
Location: Oregon

iTrader: (0)

Quote:
Originally Posted by cranelec View Post
JETmn, if you remove the motor mount including the aluminum part which attaches the mount to the engine block and then raise the engine 1.5 inches, the entire turbofold drops out of the 335i xdrive easily.
This is what I did but I am not AWD. The only issue I ran into was that the car almost wasn't high enough to allow me to pull it through before hitting the ground.
__________________
2011 E92 335i Auto 0-60 = 3.66 12.0 @ 125MPH JB4 / 11.7 @ 120MPH E30 MHD
Back to stock
2014 E84 X1 35i 0-60 = 5.56 13.9 @ 99MPH 293 AWHP 305 AWTW
ER Chargepipe | BMS Intake |
Appreciate 0
      08-02-2017, 07:52 PM   #25
cranelec
Private
18
Rep
91
Posts

Drives: BMW
Join Date: Nov 2013
Location: NEPA

iTrader: (0)

Garage List
2011 335i xDrive  [0.00]
2007 BMW 328xi  [0.00]
JETmn, Turbos, and other forum members

Quote:
Originally Posted by Turbod View Post
Quote:
Originally Posted by cranelec View Post
JETmn, if you remove the motor mount including the aluminum part which attaches the mount to the engine block and then raise the engine 1.5 inches, the entire turbofold drops out of the 335i xdrive easily.
This is what I did but I am not AWD. The only issue I ran into was that the car almost wasn't high enough to allow me to pull it through before hitting the ground.
As my "nightmare-on-jackstands" continues...I am both grateful & incensed that I read all of your posts till my eyes bled and I was still foolish enough to embark on this journey to 500 wHp?

Mike
Appreciate 0
      08-03-2017, 10:23 AM   #26
houtan
Colonel
houtan's Avatar
330
Rep
2,034
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (12)

Garage List
2011 135i  [5.00]
Quote:
Originally Posted by cranelec View Post
As my "nightmare-on-jackstands" continues...I am both grateful & incensed that I read all of your posts till my eyes bled and I was still foolish enough to embark on this journey to 500 wHp?

Mike
Haha. It's worth it Mike. Feel free to ask any questions if you hit a snag.
Appreciate 0
      08-03-2017, 11:51 AM   #27
Turbod
Captain
Turbod's Avatar
United_States
200
Rep
808
Posts

Drives: 2011 E92 335i Auto
Join Date: Mar 2015
Location: Oregon

iTrader: (0)

Quote:
Originally Posted by cranelec View Post
As my "nightmare-on-jackstands" continues...I am both grateful & incensed that I read all of your posts till my eyes bled and I was still foolish enough to embark on this journey to 500 wHp?

Mike
I'm not proud to say it took me 28 hours from start to finish to get mine in and running. It was down for a little over a week as I waited for parts.
__________________
2011 E92 335i Auto 0-60 = 3.66 12.0 @ 125MPH JB4 / 11.7 @ 120MPH E30 MHD
Back to stock
2014 E84 X1 35i 0-60 = 5.56 13.9 @ 99MPH 293 AWHP 305 AWTW
ER Chargepipe | BMS Intake |
Appreciate 0
      08-03-2017, 04:02 PM   #28
houtan
Colonel
houtan's Avatar
330
Rep
2,034
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (12)

Garage List
2011 135i  [5.00]
Quote:
Originally Posted by Turbod View Post
I'm not proud to say it took me 28 hours from start to finish to get mine in and running. It was down for a little over a week as I waited for parts.
Easily took me that long as well.
Appreciate 0
      08-03-2017, 07:49 PM   #29
bcaz808
Private
12
Rep
89
Posts

Drives: 2011 E90 335i
Join Date: Sep 2016
Location: TX

iTrader: (0)

Quote:
Originally Posted by houtan View Post
Easily took me that long as well.
Same here but after all the frustration it was definitely worth it.
Appreciate 0
      08-03-2017, 08:12 PM   #30
Turbod
Captain
Turbod's Avatar
United_States
200
Rep
808
Posts

Drives: 2011 E92 335i Auto
Join Date: Mar 2015
Location: Oregon

iTrader: (0)

Glad to hear I wasn't the only one. Next week I am going to do the install in reverse. I doubt it will take me as long.
__________________
2011 E92 335i Auto 0-60 = 3.66 12.0 @ 125MPH JB4 / 11.7 @ 120MPH E30 MHD
Back to stock
2014 E84 X1 35i 0-60 = 5.56 13.9 @ 99MPH 293 AWHP 305 AWTW
ER Chargepipe | BMS Intake |
Appreciate 0
      08-04-2017, 02:41 PM   #31
DrRobert
Normal Person
United_States
119
Rep
866
Posts

Drives: 2011 E90 335i
Join Date: May 2014
Location: paradise

iTrader: (0)

Garage List
2011 E90 335i  [0.00]
Wow, after reading this it makes me glad I paid someone else to do this for me. But I admire those of you who did it yourself. Definitely an awesome mod either way!
Appreciate 0
      10-25-2017, 03:33 PM   #32
houtan
Colonel
houtan's Avatar
330
Rep
2,034
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (12)

Garage List
2011 135i  [5.00]
Added race videos from No Fly Zone last weekend! Also a minor update on DV installation tips.
__________________
2011 LMB 135i DCT
Appreciate 0
      10-25-2017, 04:34 PM   #33
pipsindamix
New Member
2
Rep
29
Posts

Drives: 335
Join Date: May 2016
Location: CA

iTrader: (0)

Very nice. Are you using the supplied controller in the AEM meth kit? Do you have the ability to crank up the boost to 22-24 psi?
Appreciate 0
      10-25-2017, 05:31 PM   #34
houtan
Colonel
houtan's Avatar
330
Rep
2,034
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (12)

Garage List
2011 135i  [5.00]
Quote:
Originally Posted by pipsindamix View Post
Very nice. Are you using the supplied controller in the AEM meth kit? Do you have the ability to crank up the boost to 22-24 psi?
Yup, using the AEM controller.

I cannot up the boost for a few reasons. I do not have the M3/M4 flywheel installed, I am on stock clutchpacks (although this may or may not be required for 22psi. Newguy started seeing some slip around 23 psi on stock clutches), and I am not running port injection.

I am running 100% meth, so I may be getting some fueling from it. But I wouldn't run 22 psi spraying through the charge pipe. I would either get Meth PI or hopefully upgrade the HPFP if an upgrade is ever released.
__________________
2011 LMB 135i DCT
Appreciate 0
      10-25-2017, 06:41 PM   #35
pipsindamix
New Member
2
Rep
29
Posts

Drives: 335
Join Date: May 2016
Location: CA

iTrader: (0)

Quote:
Originally Posted by houtan View Post
Yup, using the AEM controller.

I cannot up the boost for a few reasons. I do not have the M3/M4 flywheel installed, I am on stock clutchpacks (although this may or may not be required for 22psi. Newguy started seeing some slip around 23 psi on stock clutches), and I am not running port injection.

I am running 100% meth, so I may be getting some fueling from it. But I wouldn't run 22 psi spraying through the charge pipe. I would either get Meth PI or hopefully upgrade the HPFP if an upgrade is ever released.
Awesome. How is newguy able to beat such high HP cars from a roll?

-575rwhp C6 Z06
-900 HP camaro
-C7 Z06
-Procharged C5 Z06
-Supercharged E92 M3

All those cars are highway monsters...very impressed that a PS2 is able to top them, even hung in close with the 700whp N54
Appreciate 0
      10-25-2017, 06:55 PM   #36
houtan
Colonel
houtan's Avatar
330
Rep
2,034
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (12)

Garage List
2011 135i  [5.00]
Quote:
Originally Posted by pipsindamix View Post
Awesome. How is newguy able to beat such high HP cars from a roll?

-575rwhp C6 Z06
-900 HP camaro
-C7 Z06
-Procharged C5 Z06
-Supercharged E92 M3

All those cars are highway monsters...very impressed that a PS2 is able to top them, even hung in close with the 700whp N54
IMO it's a combination of things. The turbo makes awesome power, and I think the DCT's fast shifting helps a lot too. It seems to always be the case that we hang with cars that make more HP.

I raced the same supercharged M3 earlier in the day and lost by 6 or 7 cars. But once I got the tune dialed in, I gained about 8 mph from when we ran. I believe I could have beaten him or been right next to him if we ran again. He said his car put down 590 to the wheels. I know my car isn't close to that and I am pretty sure newguys isn't making that much power as well. We need to get on the dyno at some point to see what sort of power we are making.

PS2 and DCT is just a great combo IMO. The results seem to back that as well.
__________________
2011 LMB 135i DCT
Appreciate 1
OTN5530.50

      04-25-2018, 12:48 PM   #37
houtan
Colonel
houtan's Avatar
330
Rep
2,034
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (12)

Garage List
2011 135i  [5.00]
Bump! Dyno results added to OP in 1addicts thread!! http://www.1addicts.com/forums/showt...5#post21975605
__________________
2011 LMB 135i DCT
Appreciate 0
      04-25-2018, 01:57 PM   #38
Ozzie335i
Captain
United_States
321
Rep
956
Posts

Drives: 2011 335i
Join Date: Aug 2014
Location: DFW

iTrader: (0)

houtan, what rpm did your car go into limp mode? I have been beating my head against the wall on a similar thing at around 5500 rpms. No codes, just a drop in power to limp, with DSC indication on my dash. Resolved by restarting the car. As I was previously getting misses, which seems to have now been cleared up with plugs, gap and coils, I originally attributed this oddity to the misses. I am running Pure Dos, PI, and all the necessary supporting hardware.
Appreciate 0
      04-25-2018, 02:31 PM   #39
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
2606
Rep
56,254
Posts


Drives: C6 Z06, 09 335i, 10 335xi
Join Date: Dec 2008
Location: www.TopGearSolutions.com

iTrader: (37)

Quote:
Originally Posted by houtan View Post
Bump! Dyno results added to OP in 1addicts thread!! http://www.1addicts.com/forums/showt...5#post21975605
Nice GL with it!
__________________
|Like us on Facebook||Evolution Racewerks| |Active Autowerke| |ETS| |Burger Tuning| |PURE Turbos| |Mishimoto||VRSF| |AWE| |Wagner|

|HPB 240W Angel Eyes & LED Fog Light Kits | |CTS| |KW| |Spec| |ST Coilovers| |Koni| |Bilstein| |Borla| |Magnaflow| |AFE| |Fabspeed| |Injen| Fall Sales Up to 10% OFF!
Appreciate 1
houtan330.00

      04-25-2018, 05:32 PM   #40
houtan
Colonel
houtan's Avatar
330
Rep
2,034
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (12)

Garage List
2011 135i  [5.00]
Quote:
Originally Posted by Ozzie335i View Post
houtan, what rpm did your car go into limp mode? I have been beating my head against the wall on a similar thing at around 5500 rpms. No codes, just a drop in power to limp, with DSC indication on my dash. Resolved by restarting the car. As I was previously getting misses, which seems to have now been cleared up with plugs, gap and coils, I originally attributed this oddity to the misses. I am running Pure Dos, PI, and all the necessary supporting hardware.
what are the codes when that happens? any logs where it happened? what tune and fuel?

My car is DCT so it's a little different I think, but when it would happen it was usually around 5900 rpm, log is perfect so I think there is a limiter that I am hitting that is telling the DME to throw a code. This happens above 21 psi though. Didn't you get your tune from twisted? Is that the tune you are hitting limp mode on?
__________________
2011 LMB 135i DCT
Appreciate 0
      04-25-2018, 09:29 PM   #41
Ozzie335i
Captain
United_States
321
Rep
956
Posts

Drives: 2011 335i
Join Date: Aug 2014
Location: DFW

iTrader: (0)

Quote:
Originally Posted by houtan View Post
what are the codes when that happens? any logs where it happened? what tune and fuel?

My car is DCT so it's a little different I think, but when it would happen it was usually around 5900 rpm, log is perfect so I think there is a limiter that I am hitting that is telling the DME to throw a code. This happens above 21 psi though. Didn't you get your tune from twisted? Is that the tune you are hitting limp mode on?
No codes houtan. That is the frustrating part. I have 6 MT, 3.42 LSD (ediff coded out). I am currently running 22 psi. Twisted is doing the tuning. When I really get on it it's like I hit a brick wall, as the power is suddenly cut off at around 5500 RPM. As it is cut off stuff flashes on the dash (have seen DSC), then power loss. I'll be looking into the voltage when it occurs. I have battery voltage checked for stuff to monitor, but it is not included in the logs.
Appreciate 0
      04-25-2018, 09:45 PM   #42
houtan
Colonel
houtan's Avatar
330
Rep
2,034
Posts

Drives: 2011 135i
Join Date: Jun 2013
Location: socal

iTrader: (12)

Garage List
2011 135i  [5.00]
Quote:
Originally Posted by Ozzie335i View Post
No codes houtan. That is the frustrating part. I have 6 MT, 3.42 LSD (ediff coded out). I am currently running 22 psi. Twisted is doing the tuning. When I really get on it it's like I hit a brick wall, as the power is suddenly cut off at around 5500 RPM. As it is cut off stuff flashes on the dash (have seen DSC), then power loss. I'll be looking into the voltage when it occurs. I have battery voltage checked for stuff to monitor, but it is not included in the logs.
That sucks. Twisted doesnít know why itís occurring? Can you post a link to some logs where it happens? Yeah I would add voltage just to see what itís doing.

Also, what intake are you running? If itís stock the stock rubber coupler could be collapsing when you get into boost. Happened on two cars I know of. If your running a spacer plate for pi and the stock intake pull that coupler one extra rib over. Itíll look funny but itíll stop it from collapsing once the engine bay gets warm.

Last edited by houtan; 04-25-2018 at 11:22 PM.
Appreciate 0
      04-25-2018, 09:50 PM   #43
weehe126
Lieutenant Colonel
370
Rep
1,724
Posts

Drives: 2011 335i
Join Date: Apr 2014
Location: San Antonio

iTrader: (1)

Quote:
Originally Posted by Ozzie335i View Post
No codes houtan. That is the frustrating part. I have 6 MT, 3.42 LSD (ediff coded out). I am currently running 22 psi. Twisted is doing the tuning. When I really get on it it's like I hit a brick wall, as the power is suddenly cut off at around 5500 RPM. As it is cut off stuff flashes on the dash (have seen DSC), then power loss. I'll be looking into the voltage when it occurs. I have battery voltage checked for stuff to monitor, but it is not included in the logs.
That sounds exactly like the issue I randomly had with a pump gas BEF. Anything above 5500 rpm at 18psi I would get trans limp mode and locked in 5th gear. Only way to fix it was to turn the car off. I thought Twisted fixed it for someone else by just starting a new tune from scratch. I could never figure it out, the E30 BEF had no issues. I see you are MT, but thought I'd share.
Appreciate 0
      04-25-2018, 09:51 PM   #44
weehe126
Lieutenant Colonel
370
Rep
1,724
Posts

Drives: 2011 335i
Join Date: Apr 2014
Location: San Antonio

iTrader: (1)

Quote:
Originally Posted by houtan View Post
Bump! Dyno results added to OP in 1addicts thread!! http://www.1addicts.com/forums/showt...5#post21975605
Thanks for posting. Would be interested if you installed MILVs and redynoed. That's the only difference between our mods.
Appreciate 0
Reply

Bookmarks

Tags
n55, ps2, pure turbos, wedge

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:16 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST