E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > P1624 P110D Limp Mode 2006 330i



Reply
 
Thread Tools Search this Thread
      06-02-2020, 07:48 PM   #1
blackedout330i
New Member
0
Rep
23
Posts

Drives: 2006 330i
Join Date: Oct 2019
Location: chicago

iTrader: (0)

Question P1624 P110D Limp Mode 2006 330i

After fixing some issues I am getting a P1624 error. It puts the car into limp mode and I cant accelerate much at all. If I shut the car down and restart it works just fine. The two codes is threw was

P110D
P1624

Any help on how to diagnose this issue? From what I've searched it could be either a thermostat issue or pedal controller?
Appreciate 0
      06-02-2020, 10:24 PM   #2
hassmaschine
Major General
United_States
3059
Rep
6,271
Posts

Drives: "NBO" 330i
Join Date: Jun 2014
Location: earth

iTrader: (0)

P-codes mean nothing to me. Got a BMW scanner?
Appreciate 0
      06-03-2020, 01:47 PM   #3
blackedout330i
New Member
0
Rep
23
Posts

Drives: 2006 330i
Join Date: Oct 2019
Location: chicago

iTrader: (0)

Quote:
Originally Posted by hassmaschine View Post
P-codes mean nothing to me. Got a BMW scanner?
hassmaschine I'm working on getting INPA to work but I cant get it to load yet/connect. Comes up with that error 18 code. Working more on it today just hot as balls sitting in a car in a garage in 90deg weather lol
Appreciate 0
      06-04-2020, 03:57 PM   #4
E92William
Second Lieutenant
E92William's Avatar
174
Rep
222
Posts

Drives: 2008 E92 328xi
Join Date: Nov 2019
Location: Miami

iTrader: (0)

Garage List
2008 BMW 328xi  [0.00]
You're gonna want to scan this with a proper scanner. As of now I'd be more inclined to say it's a pedal issue but who knows if it's a valvetronic issue and it's throwing a code for the throttle because that's what it's using as a backup. The valvetronic goes full lift and shuts down if it has a fault, so your engine speed will be controlled by the tb.
Appreciate 0
      06-04-2020, 08:34 PM   #5
PhaseP
Lieutenant Colonel
522
Rep
1,723
Posts

Drives: 325XI
Join Date: May 2010
Location: Earth

iTrader: (0)

Quote:
Originally Posted by blackedout330i View Post
After fixing some issues I am getting a P1624 error. It puts the car into limp mode and I cant accelerate much at all. If I shut the car down and restart it works just fine. The two codes is threw was

P110D
P1624

Any help on how to diagnose this issue? From what I've searched it could be either a thermostat issue or pedal controller?
What were the issues you fixed? Did they involve removing throttle body electrical connector under intake manifold, or anything to do with gas pedal wiring or harness?

First code says throttle body sensor, 2nd code says gas pedal sensor supply (electrical I suppose) From Bentley manual.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:09 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST