E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > E90 wipers not parking issue solved - sort of



Reply
 
Thread Tools Search this Thread
      08-08-2019, 04:28 AM   #1
Three_thirty_I
Lieutenant Colonel
Three_thirty_I's Avatar
South Africa
148
Rep
1,806
Posts

Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

iTrader: (0)

Garage List
E90 wipers not parking issue solved - sort of

So this time last year I became aware of my wipers not always returning to the normal parked position during and after operation, but in most cases it would appear to return to the "normal" parked position after a few wipes. But then one particular rainy evening, it was just not wanting to return the normal position, so I started reading up about it, and didn't take me long to find various threads and a DIY that shows some handy information and procedures. My first suspicion was the wiper relay for the simple reason that my E90 is an earlier model being a 2005 model, so it has the older part number blue wiper relay that was known to become faulty. Interestingly, when I go back and watch various GoPro vids that I took years ago when the car was still under motorplan, and being driven in the rain, even back then the wipers were not consistently parking correctly. They always parking within a certain height, but ever so slightly different as it was operating.

Anyway, so I first did the basic things, removed the relay to see if the contacts were corroded or maybe some grit in there, but that wasn't the case, I then phoned BMW to see what the upgraded green replacement relay costs and was told that they would have to order it. But then at the same time, my car was about to go in for the HVAC recall, so I thought I would ask them about it and order the part while I'm there. Didn't hear anything from them other than the car was ready to be collected. The service adviser then tells me that they looked at the wiper system and checked for error codes, and there were none stored, so they adjusted the wiper arms. Oh boy. So I explained to the service adviser that it is highly doubtful that an error code would be stored for a faulty relay, since there is nothing sensing if the relay is working properly or not. So now all they did was incorrectly adjust the wipers to compensate for the faulty relay and therefore the driver's side wiper was no longer going all the way up to its normal furthest position.

Okay, so I then had the wiper arms readjusted to their original setting and left it at that for the time being. But then yesterday I was driving in the rain quite a bit, and along with the already annoying shuddering wiper blades that are well overdue for replacement, the parking issue was back in full force! I decided to go to a local parts shop to get a set of Bosch AeroEco wipers which are supposed to have an attachment so that they can fit onto the E90, but that proved not to be the case - the appropriate attachment is too long and does not allow the wiper arm cover to fit properly, so luckily I had tried to fit this while still at this shop, so just returned it immediately. But, I figured while I was there, see if they have a generic Bosch replacement relay to replace the suspected faulty blue relay. They ended only finding another generic that is meant as a flasher relay for a Toyota Corolla/Camry/Yaris, and it was so cheap, I decided to just give it a try. Lo and behold, the wipers now park consistently where there are supposed to, and never did all through the years! However, although it works correctly, I will still get the genuine green OEM part, for the fact that I prefer keeping things like that OEM, but also because each time the wiper actuates, there is a barely audible tick sound from this relay, so not 100 percent ideal, but proves that the old blue relay is faulty.
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03

Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:28 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST