E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > No gps signal



Reply
 
Thread Tools Search this Thread
      08-10-2020, 05:17 AM   #1
HennessyLV
New Member
HennessyLV's Avatar
0
Rep
25
Posts

Drives: E92 320i
Join Date: Jun 2018
Location: UK

iTrader: (0)

No gps signal

Hi guys, I need your help again...
Long story short- I've completed the non idrive to cic retrofit few weeks ago and it's all coded updated and works as it should except now I'm having a nightmare with the gps antenna. Was working fine till 2 days ago where I went on a long trip where half way through it lost gps signal and the car though I'm still at my home address in UK even though i was in France. What's even worse is that while I'm in the car my samsung phone doesn't get any gps signal at all and also 3 other passengers with 2 iphones and another samsung had no gps. Looks like for some reason the cic/gps antenna is blocking any gps signal completely.
The cic did eventually recognise that I'm abroad and did show that I'm in France but still it's pretty unusable therfore I'm going to disconnect the antena for now so I can use the phone as otherwise we have no nav working at all.
The antena is off ebay but read that people have good luck with it.

Any input is highly appreciated as I'm confused and not sure where to start from with this one.

Thanks beforehand!
Appreciate 0
      08-10-2020, 09:56 AM   #2
opjose
Major
opjose's Avatar
199
Rep
1,224
Posts

Drives: 335xi
Join Date: May 2016
Location: Md

iTrader: (0)

Unlikely that the antenna itself is causing an issue.

At worst it would fail to pick up the satellite signals but it would not block other devices nor generate an interfering signal.

It sounds like that there is something in the car emitting interference.

Grab a gps satellite tracker app and while using it walk away from the car at various points in a circle.

You could use it to build a map of sorts to help you pinpoint where the interference is originating from... or a signal scanner could be used...
Appreciate 0
      05-24-2021, 03:22 AM   #3
simmonsshorovitz
Registered
0
Rep
4
Posts

Drives: BMW X6
Join Date: Nov 2020
Location: London

iTrader: (0)

I had a similar problem that was solved by buying a new GPS navigator. Garmin DriveSmart 51 NA LMT-S works perfectly and I do not have any problem with signal lose.
Appreciate 0
      05-24-2021, 07:08 AM   #4
DavesZed
Second Lieutenant
United Kingdom
59
Rep
275
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Quote:
Originally Posted by HennessyLV View Post
Hi guys, I need your help again...
Long story short- I've completed the non idrive to cic retrofit few weeks ago and it's all coded updated and works as it should except now I'm having a nightmare with the gps antenna. Was working fine till 2 days ago where I went on a long trip where half way through it lost gps signal and the car though I'm still at my home address in UK even though i was in France. What's even worse is that while I'm in the car my samsung phone doesn't get any gps signal at all and also 3 other passengers with 2 iphones and another samsung had no gps. Looks like for some reason the cic/gps antenna is blocking any gps signal completely.
The cic did eventually recognise that I'm abroad and did show that I'm in France but still it's pretty unusable therfore I'm going to disconnect the antena for now so I can use the phone as otherwise we have no nav working at all.
The antena is off ebay but read that people have good luck with it.

Any input is highly appreciated as I'm confused and not sure where to start from with this one.

Thanks beforehand!
Right, OK so where have you mounted the GPS antenna firstly? Stuck to the windscreen? On top of the dash? Underneath something? There is a good reason for asking, depending on your answer
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
Reply

Bookmarks

Tags
cic and idrive, gps error, idriv, no gps available

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:57 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST