E90Post
 


Coby Wheel
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > E Series NBT Evo Retrofit Development Thread



Reply
 
Thread Tools Search this Thread
      01-08-2019, 03:34 PM   #89
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
Switched to the PC software. I'm still seeing error messages come back every few frames that are sent, but the evo is staying powered up! this should be enough for me to connect ethernet
Time to build the ethernet cable, i guess. shielded cables are coming... thursday... so much waiting.
Appreciate 0
      01-08-2019, 04:08 PM   #90
Gray335i
Private First Class
21
Rep
109
Posts

Drives: 2008 335
Join Date: Oct 2011
Location: Rochester Hills, Michigan

iTrader: (0)

Hopefully you won't need zgw2 since you are not flashing only modifying .
Appreciate 0
      01-09-2019, 01:01 PM   #91
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
Visited the yard again today and picked up an ATM, idrive touch controller and handwriting recognition module, and a used battery because the battery in the 2010 is very weak. $100 for all. I really like my local yard

Shipping back the ATM-of-unknown-origin and dead CID tomorrow. Maybe tonight I can get the evo talking to e-sys so i can fix the resolution and actually see it function, order up an FSC repair pack with carplay to match the new ATM's vin, and then start plugging things in!
Appreciate 0
      01-09-2019, 05:20 PM   #92
Nickco43
Lieutenant Colonel
Nickco43's Avatar
1157
Rep
1,811
Posts

Drives: 13 BMW 335i xDrive
Join Date: Apr 2018
Location: Philadelphia, PA

iTrader: (0)

Garage List
Everything is ordered. I am shooting for a MLK weekend install.
Appreciate 0
      01-10-2019, 01:29 AM   #93
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
Resolution updated, and the screen works! I now have a functioning NBT evo!

Unfortunately, it is running ID5 software from February 2017, which did not support switching to ID6 and doesn't actually support touchscreens, so I don't actually know if this is a touchscreen or not.

I also don't think there is any way to flash an NBT evo without either an F car or a ZGW.
So... I guess I have to buy a ZGW... do I also need to buy a CAN filter, just to update this thing?
Appreciate 0
      01-10-2019, 07:57 AM   #94
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
A couple more bits of information I came across:
This thread talks about different CAN messages that the evo might need:
https://cartechnology.co.uk/showthread.php?tid=43512
specifically, ID 563 00 00 00 00 FF FF 00 63 in place of an idrive controller

another potentially useful one: 202 FD FF (202 is to control the lighting, but this one might also be to control the fan?)

for flashing if changing the VIN, the latest istep that allows the USB patch method to change FSC codes&certs is 07-2018, which appears to be 4.13.xx psdzdata. I have newer and older psdzdata, am trying to find a good source for 4.13.40 or at least 4.13.14.
Here's a torrent for 4.13.14, but i don't know if there is anyone seeding (and i don't have enough space on my laptop to test...):
https://cartechnology.co.uk/showthread.php?tid=38857
Appreciate 0
      01-10-2019, 08:13 AM   #95
YoMuS
New Member
0
Rep
18
Posts

Drives: 335i
Join Date: Jan 2018
Location: Valencia

iTrader: (0)

Vilord,

I know where you can find a link for 4.13.14.

Browse this BMW spanish forum, bmwfaq.com, and browse the BMW Coding subforum. Un the first page there is a thread for this version. Check the picture in the first post so you can see the actual link (rutracker....).
Hope it helps!

Edit: Didnít see it was a space problem. Anyway, is the same as the link you posted.
Appreciate 0
      01-10-2019, 09:44 AM   #96
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
Ah! finally got my USB CAN to work reliably with no transmit errors. I did need to add a 120 ohm resister across CAN L and CAN H. My viewtool can box thing has one built in, but it did not come with any instructions, took me a minute to figure out how to properly connect it.

Also, I'm glad that amazon accidentally sent me two of these usb-can adapters for the price of one. One of them is DOA.

Here's a couple pics of it working, and of my messy setup
It looks like this M4 driver crashed on the Garden State Parkway, heading from NYC to Atlantic City
Attached Images
   
Appreciate 0
      01-10-2019, 10:04 AM   #97
Gray335i
Private First Class
21
Rep
109
Posts

Drives: 2008 335
Join Date: Oct 2011
Location: Rochester Hills, Michigan

iTrader: (0)

Good deal vilord.
I Don't believe you can flash to ID 6 without ZGW2 4 or 8K.
Also VIN on zgv needs to be changed to your car. nbt vin prior to connecting zgw to evo so it doesn't lock your evo.
Some are saying that they can send nbt to flash mode and flash it to ID6 without zgw using a different can id but I would not take that chance.
If you do get ZGW there are instructions how to connect to nbt and screen. You don't need a can filter since you have working can wake device.

good luck.
Appreciate 0
      01-10-2019, 10:10 AM   #98
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
That does sound risky. Anything specific I should pull the ZGW from? I could grab the one from the '17 X3 F25 I got the ATM and idrive controller from (touch works btw, despite the controller sitting in the rain and the touch module being literally frozen in a block of ice in the back)
Or there's also a 2012 F30... I don't know what I'm looking for... I'd want ZGW and OBD port? or just ZGW and tie together the kcan and ethernet from the head unit, connect zgw ethernet to laptop directly?
-Jesse
Appreciate 0
      01-10-2019, 10:20 AM   #99
Gray335i
Private First Class
21
Rep
109
Posts

Drives: 2008 335
Join Date: Oct 2011
Location: Rochester Hills, Michigan

iTrader: (0)

use this for reference
Attached Images
File Type: pdf CAN_Bridge_Rev_6.pdf (1.02 MB, 704 views)
Appreciate 0
      01-10-2019, 10:22 AM   #100
Gray335i
Private First Class
21
Rep
109
Posts

Drives: 2008 335
Join Date: Oct 2011
Location: Rochester Hills, Michigan

iTrader: (0)

Quote:
Originally Posted by vilord View Post
That does sound risky. Anything specific I should pull the ZGW from? I could grab the one from the '17 X3 F25 I got the ATM and idrive controller from (touch works btw, despite the controller sitting in the rain and the touch module being literally frozen in a block of ice in the back)
Or there's also a 2012 F30... I don't know what I'm looking for... I'd want ZGW and OBD port? or just ZGW and tie together the kcan and ethernet from the head unit, connect zgw ethernet to laptop directly?
-Jesse

2017 should have zgw2 already. I think those were implemented in 2015 or so.
Appreciate 0
      01-10-2019, 11:19 AM   #101
gamesfrager
Banned
Canada
188
Rep
709
Posts

Drives: 2011 328i
Join Date: Feb 2018
Location: Calgary

iTrader: (0)

Can I just say HOLY MOLY.

Awesome work, guys.
Appreciate 0
      01-10-2019, 11:24 AM   #102
Nickco43
Lieutenant Colonel
Nickco43's Avatar
1157
Rep
1,811
Posts

Drives: 13 BMW 335i xDrive
Join Date: Apr 2018
Location: Philadelphia, PA

iTrader: (0)

Garage List
Quote:
Originally Posted by vilord View Post
Ah! finally got my USB CAN to work reliably with no transmit errors. I did need to add a 120 ohm resister across CAN L and CAN H. My viewtool can box thing has one built in, but it did not come with any instructions, took me a minute to figure out how to properly connect it.

Also, I'm glad that amazon accidentally sent me two of these usb-can adapters for the price of one. One of them is DOA.

Here's a couple pics of it working, and of my messy setup
It looks like this M4 driver crashed on the Garden State Parkway, heading from NYC to Atlantic City
Hopefully my nbt is ID6. It is from a 2018 model year built in 10/17.
Appreciate 0
      01-10-2019, 11:34 AM   #103
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
Total spend so far: $1499.06 (other people it will be more, unless you have the sort of parts yard hookup i have)

I'm hoping that selling off some of the old parts will offset this cost. Already got $275 for my old XD600/6, so that brings the project budget to 1224.06

Still to purchase:
- F-series radio antenna amplifier
- a second antenna wire to get diversity FM reception
- a bmw reverse camera and trunk handle
- HSD video cable to go from reverse camera to camera module
- FSC patch kit to change Evo VIN to match ATM

Untested stuff that I hope works:
- F25 ATM
- F30 reverse camera module
- F30 logic7 amplifier

Stuff to sell:
- E9x logic7 amplifier
- E9x hifi amplifier
- E9x mulf
- E9x tcu *2
- E9x professional radio *without any display issues*
- E46 professional radio with dying LCD

Last edited by vilord; 01-10-2019 at 11:40 AM..
Appreciate 0
      01-10-2019, 11:54 AM   #104
Nickco43
Lieutenant Colonel
Nickco43's Avatar
1157
Rep
1,811
Posts

Drives: 13 BMW 335i xDrive
Join Date: Apr 2018
Location: Philadelphia, PA

iTrader: (0)

Garage List
Quote:
Originally Posted by vilord View Post
Total spend so far: $1499.06 (other people it will be more, unless you have the sort of parts yard hookup i have)

I'm hoping that selling off some of the old parts will offset this cost. Already got $275 for my old XD600/6, so that brings the project budget to 1224.06

Still to purchase:
- F-series radio antenna amplifier
- a second antenna wire to get diversity FM reception
- a bmw reverse camera and trunk handle
- HSD video cable to go from reverse camera to camera module
- FSC patch kit to change Evo VIN to match ATM

Untested stuff that I hope works:
- F25 ATM
- F30 reverse camera module
- F30 logic7 amplifier

Stuff to sell:
- E9x logic7 amplifier
- E9x hifi amplifier
- E9x mulf
- E9x tcu *2
- E9x professional radio *without any display issues*
- E46 professional radio with dying LCD
$1500 is a great price for the Evo retrofit.
Appreciate 0
      01-10-2019, 10:18 PM   #105
Nickco43
Lieutenant Colonel
Nickco43's Avatar
1157
Rep
1,811
Posts

Drives: 13 BMW 335i xDrive
Join Date: Apr 2018
Location: Philadelphia, PA

iTrader: (0)

Garage List


I made it work.
Appreciate 0
      01-11-2019, 05:12 PM   #106
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
Picked up a ZGW from the F25 I got the ATM from ($40!) and a few L7 speakers ($15 per pair!) to replace some of the non-L7 crackly paper pieces of junk.
Still need a few more, and the underseat subs have different resistance, so they definitely need to be replaced... but... it is really hard to get the subs out if you can't move the seats. It was also about 15 degrees outside and my hands were going numb
Appreciate 0
      01-11-2019, 08:07 PM   #107
Nickco43
Lieutenant Colonel
Nickco43's Avatar
1157
Rep
1,811
Posts

Drives: 13 BMW 335i xDrive
Join Date: Apr 2018
Location: Philadelphia, PA

iTrader: (0)

Garage List


I can't get a good caf file. IDK what is wrong.

Last edited by Nickco43; 01-11-2019 at 10:02 PM..
Appreciate 0
      01-12-2019, 07:48 AM   #108
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
I flashed my ZGW to update the VIN to match my NBTevo.

To do this, I kept the evo disconnected so it would not go into software protection.
Next, I connected the ZGW to my laptop with the following pins:

All these connections are through the bigger 3-row connector.
I ran +12v power to pins 39 and 42, ground to 19, and ethernet to the following:
18: RX+, 36: RX-, 53: TX+, 54: TX-.

To enable ethernet, I connected pin 41 to +12v as well. You're supposed to go through a 1k ohm resistor, but I didn't have one so I just connected it directly. I don't recommend connecting it without a resistor, something inside might get damaged.

I then started up the tftpd DHCP server so that the modules would always get the same IP addresses even after resets.

Then I opened e-sys (that was a pain in itself, deserving of its own post...) and I followed the procedure here to connect to the ZGW: https://www.bimmerfest.com/forums/sh...12&postcount=1
In step 13, I typed in the NBT's VIN, and in step 15 I checked the 4 boxes only on the ZGW line.
I hit start, and it failed.
I then went to the Parameters tab and turned off the option for changing programming modes.
I hit start, and it succeeded, ZGW now matches NBT VIN!

Next I connected the ZGW to the NBT as follows:

54pin connector:
48 -> KCAN H on NBT
49 -> KCAN L on NBT

18pin connector:
9 -> OABR 18 (RX+)
11 -> OABR 17 (TX+)
12 -> OABR 19 (TX-)
13 -> Quadlock 29 (ETH-A)
18 -> OABR 20 (RX-)

Upon powering everything up and sending the KCAN wakeup signals from my Viewtool Ginkgo USB-CAN adapter, I can now see both the ZGW and NBT in ESYS.

Today, I'll flash the NBT!
Appreciate 0
      01-12-2019, 08:30 AM   #109
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
for coming back to later: it appears that most procedures for flashing recommend launching esys *without* the launcher. I'm going to do that when I flash the NBT.
E-Sys Launcher is used for managing the E-Sys token, and it also patches E-Sys to show CAFD text descriptions.
When flashing, we aren't touching CAFD, so better to run a clean / unpatched E-Sys.

Reference: https://www.bimmerfest.com/forums/sh...7&postcount=16
Appreciate 0
      01-12-2019, 12:37 PM   #110
vilord
Major
295
Rep
1,126
Posts

Drives: Too many
Join Date: Apr 2013
Location: boston

iTrader: (1)

Garage List
Okay, I hand-built an FA to match the car the NBT came from, guessed the 'shipping istep', prepped and kicked off a flash for the NBT, and immediately got an error: FA must not be null when trying to execute TAL.
Then, I hit start again, and it waid it would take 35 minutes.
2 minutes later it says finishedwitherror, and my nbt screen is black. mild freakout! then it started back up with the old software.

trying again with 'activate programming mode for switchable..' turned off...
still failed in the same way.
no other logs...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:46 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST