E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Car threw a code at me and went away



Reply
 
Thread Tools Search this Thread
      01-24-2016, 03:03 AM   #1
Mayan
New Member
0
Rep
29
Posts

Drives: bmw
Join Date: Nov 2015
Location: CA

iTrader: (0)

Car threw a code at me and went away

Car is a 335is e93. I went to fill up some e85 mix about 28-30%. I've done this before ranging from 20-45% with no issues. Car has jb4+, Catless dp's, fmic, chargepipe +bov, dci. I did the usual thing switched to map 1 drove for a couple minutes then back to map 5 and drove to the highway to let the gas mix. Did my 3-4 pulls to calibrate the map and then went for a cruise. I did several more pulls with no issues and then I got a engine malfunction reduced power warning. I checked the codes jb4 was throwing and it threw out the usual two 29f4 and 29f5 for having catless dp's. It also threw out a third one "30ff" meaning I have a boost leak. I got off the highway to the nearest gas station and filled it up with more premium gas to dilute the mixure down to about 4% e85 mix. Turned the car off and back on and checked the charpipe,fmic and everything I could see looked fine. The engine malfunction warning was gone, but the code was still there in jb4 - I think it doesn't go away until you clear it. So I cleared it and it was gone. I drove for about an hour after that to see if it pops back up and did a couple more pulls. Nothing came up. My question is should I be worried or was I just pushing the car too hard with the e85
Appreciate 0
      01-24-2016, 04:25 AM   #2
talhagursoy
First Lieutenant
talhagursoy's Avatar
United_States
101
Rep
300
Posts

Drives: Bmw Z4 sDrive35i
Join Date: Feb 2014
Location: Fairfax, VA

iTrader: (1)

If you checked vacuum lines, charge pipe, DVs, and intercooler and you sure your turbos are fine and not smooking. You should be good. I got 30ff couple months ago, removed diverter valves and replaced, cleared it and it is pretty good right now. When it pops back up, you should be worrying about it but not right now.
__________________
Ar Catless DP, MHD Flash, BMS DCI, ER FMIC, ER CP, Forged DVs
Appreciate 0
      01-24-2016, 06:01 PM   #3
Mayan
New Member
0
Rep
29
Posts

Drives: bmw
Join Date: Nov 2015
Location: CA

iTrader: (0)

Quote:
Originally Posted by talhagursoy View Post
If you checked vacuum lines, charge pipe, DVs, and intercooler and you sure your turbos are fine and not smooking. You should be good. I got 30ff couple months ago, removed diverter valves and replaced, cleared it and it is pretty good right now. When it pops back up, you should be worrying about it but not right now.
Vacuum lines looked okay. Couldn't really see the fmic connections but if there was an issue I wouldn't be getting full boost. I'm kind of worried about the lower chargepipe because when I put it in it took a couple hours to get it right. Was barely enough room to work with when installing it and it wasn't one of those snap in one you had to get your hands in there and tighten a metal band onto the silicon connector to the fmic and upper chargepipe.
Would the smoke be noticeable on the turbos if there was an issue?
Appreciate 0
      01-24-2016, 11:33 PM   #4
atakid
Registered
United_States
2
Rep
4
Posts

Drives: 07 335i e92 6MT
Join Date: Mar 2015
Location: Albuquerque

iTrader: (0)

I got this when I first got my car when it was stock. It happened in the summer when it was really hot a couple times (not sure if the heat has anything to do with it). I took it to a local shop to see if they knew anything and they couldn't find anything on the issue. Since then I have dci and jb4 and it has not happened. Waiting for it to get hot again to see if it will happen again.
Appreciate 0
      01-25-2016, 01:29 AM   #5
talhagursoy
First Lieutenant
talhagursoy's Avatar
United_States
101
Rep
300
Posts

Drives: Bmw Z4 sDrive35i
Join Date: Feb 2014
Location: Fairfax, VA

iTrader: (1)

Quote:
Originally Posted by Mayan View Post
Vacuum lines looked okay. Couldn't really see the fmic connections but if there was an issue I wouldn't be getting full boost. I'm kind of worried about the lower chargepipe because when I put it in it took a couple hours to get it right. Was barely enough room to work with when installing it and it wasn't one of those snap in one you had to get your hands in there and tighten a metal band onto the silicon connector to the fmic and upper chargepipe.
Would the smoke be noticeable on the turbos if there was an issue?
If you get really huge smoke out of your exhaust, usually it means your turbos smooking.
I also got that code when I install my DCI and stayed in traffic over 3-4 hours. Turbos were getting too much hot air and it reduced the boost. Since you are in CA that would be the case. As I said before I wouldn't if it doesn't come back. Hopefully won't
__________________
Ar Catless DP, MHD Flash, BMS DCI, ER FMIC, ER CP, Forged DVs
Appreciate 0
      01-25-2016, 02:40 AM   #6
924er
Lieutenant Colonel
279
Rep
1,898
Posts

Drives: e92 335i '10
Join Date: Feb 2014
Location: Socal

iTrader: (0)

Quote:
Originally Posted by talhagursoy
Quote:
Originally Posted by Mayan View Post
Vacuum lines looked okay. Couldn't really see the fmic connections but if there was an issue I wouldn't be getting full boost. I'm kind of worried about the lower chargepipe because when I put it in it took a couple hours to get it right. Was barely enough room to work with when installing it and it wasn't one of those snap in one you had to get your hands in there and tighten a metal band onto the silicon connector to the fmic and upper chargepipe.
Would the smoke be noticeable on the turbos if there was an issue?
If you get really huge smoke out of your exhaust, usually it means your turbos smooking.
I also got that code when I install my DCI and stayed in traffic over 3-4 hours. Turbos were getting too much hot air and it reduced the boost. Since you are in CA that would be the case. As I said before I wouldn't if it doesn't come back. Hopefully won't
Really? I have never heard of that happening ever.
__________________
'10 e92 N54

DCI intakes, ER chargepipe, TIAL BOV,
VRSF 5in FMIC, BMS Downpipes COBB e30
Appreciate 0
      01-25-2016, 04:23 PM   #7
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3026
Rep
73,538
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

The code disappearing is normal.. Check the cold side of the FMIC connection as well.

Mike
__________________

Your #1 Source For all BMW Related Performance Parts! Super Sales on DAILY!!
www.n54tuning.com
mike@n54tuning.com
Appreciate 0
      02-01-2016, 08:53 PM   #8
Mayan
New Member
0
Rep
29
Posts

Drives: bmw
Join Date: Nov 2015
Location: CA

iTrader: (0)

Quote:
Originally Posted by talhagursoy View Post
If you get really huge smoke out of your exhaust, usually it means your turbos smooking.
I also got that code when I install my DCI and stayed in traffic over 3-4 hours. Turbos were getting too much hot air and it reduced the boost. Since you are in CA that would be the case. As I said before I wouldn't if it doesn't come back. Hopefully won't
I'm not actually from CA, it was around 20 degrees when this happened. My exhaust does smoke a lot more with the catless downpipes though, but I'm not sure how much smoke would indicate its the turbos.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:27 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST