E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > ECS poly trans mount problem



Reply
 
Thread Tools Search this Thread
      12-08-2018, 03:47 PM   #1
AlpineE93
Second Lieutenant
AlpineE93's Avatar
United_States
86
Rep
213
Posts

Drives: 2008 328i cabrio
Join Date: May 2018
Location: Dallas TX

iTrader: (0)

ECS poly trans mount problem

I just installed ECS tuning 70A poly trans mounts. While they do make every shift crisp and keeps everything stiff. There is ALOT more vibrations, substantially more than any other poly mount I've ever used in any other car. I almost thought there was a problem with my trans because of how much noise and vibration I felt. Is there a reason for this, maybe I over tightened them or maybe they need some time to set in? I know there's supposed to be some extra vibration but this is obnoxious. Any one have any insight?
Appreciate 0
      12-10-2018, 10:10 AM   #2
yupetc
Private
12
Rep
98
Posts

Drives: 2009 328i
Join Date: Feb 2013
Location: Houston, TX

iTrader: (0)

Quote:
Originally Posted by AlpineE93 View Post
I just installed ECS tuning 70A poly trans mounts. While they do make every shift crisp and keeps everything stiff. There is ALOT more vibrations, substantially more than any other poly mount I've ever used in any other car. I almost thought there was a problem with my trans because of how much noise and vibration I felt. Is there a reason for this, maybe I over tightened them or maybe they need some time to set in? I know there's supposed to be some extra vibration but this is obnoxious. Any one have any insight?

Does your mount come with that aluminum cup? If it does, just take the cup off and install mount only. I didn't get the red poly mount, but I did get that UUC kit which I believe is 50A. When I put the aluminum cup on, it vibrates really bad. I simply removed the cup and vibration is very smooth, close to OEM.
__________________
'09 328i
Air Scoop, Silicon Intake Tube, Euro-box intake, 3-stage manifold, AA-tune, AA-headers, M3 control arms, UUC transmission enforcer mounts, Halogen headlight to Projector HID/LED conversion, Smoked LED tail light conversion, Retrofitted Euro-fog light into brake light, M-tech rear bumper.
Appreciate 0
      12-11-2018, 10:40 AM   #3
hassmaschine
Major General
United_States
2330
Rep
5,282
Posts

Drives: "NBO" 330i
Join Date: Jun 2014
Location: earth

iTrader: (0)

Sounds normal for 'solid' mounts to me. Unless this is an actual race car, I would just go back to stock.
Appreciate 0
      12-11-2018, 10:49 AM   #4
AlpineE93
Second Lieutenant
AlpineE93's Avatar
United_States
86
Rep
213
Posts

Drives: 2008 328i cabrio
Join Date: May 2018
Location: Dallas TX

iTrader: (0)

Yeah, some one recommend the Rouge Engineering mounts. So I ordered a set.
Appreciate 0
      12-11-2018, 12:19 PM   #5
6ixSpd
Save the manuals!
6ixSpd's Avatar
Canada
2876
Rep
4,531
Posts

Drives: '12 M3 6MT, '09 328i 6MT
Join Date: Feb 2016
Location: 416

iTrader: (1)

I have the 034Motorsports engine and transmission mounts. Love them. Had a tiny increase in vibration at idle on cold starts which I rectified by bumping up the idle RPM speed by approx. 100.
__________________
'12 M3 6MT Alpine White + Fox Red Extended | '09 328i 6MT Space Gray + Saddle Brown

Appreciate 0
      12-11-2018, 08:36 PM   #6
ktm137
Private
7
Rep
53
Posts

Drives: 2006 330i
Join Date: Dec 2014
Location: California

iTrader: (0)

Quote:
Originally Posted by 6ixSpd View Post
I have the 034Motorsports engine and transmission mounts. Love them. Had a tiny increase in vibration at idle on cold starts which I rectified by bumping up the idle RPM speed by approx. 100.
I too have the 034 engine and trans mounts - and notice a little bit of vibration - I'm curious how you upped the idle RPM?
Appreciate 0
      12-11-2018, 09:46 PM   #7
6ixSpd
Save the manuals!
6ixSpd's Avatar
Canada
2876
Rep
4,531
Posts

Drives: '12 M3 6MT, '09 328i 6MT
Join Date: Feb 2016
Location: 416

iTrader: (1)

INPA can permanently set a higher idle RPM.
__________________
'12 M3 6MT Alpine White + Fox Red Extended | '09 328i 6MT Space Gray + Saddle Brown

Appreciate 0
      12-11-2018, 10:20 PM   #8
EndOfAnEra
N54 ftw
EndOfAnEra's Avatar
United_States
283
Rep
1,377
Posts

Drives: 07 E90 335i
Join Date: May 2012
Location: Seminole, FL

iTrader: (12)

Send a message via Yahoo to EndOfAnEra
Quote:
Originally Posted by 6ixSpd View Post
INPA can permanently set a higher idle RPM.
Any chance you can post on here or make a diy on how to change it via inpa?
__________________
flickr

My 07 335i Build

IG: _endofanera
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:52 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST