E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Electrical Issues



Reply
 
Thread Tools Search this Thread
      01-21-2022, 11:37 PM   #1
westonsheisey
New Member
westonsheisey's Avatar
0
Rep
7
Posts

Drives: 2007 BMW 328xi
Join Date: Jan 2022
Location: Colorado, USA

iTrader: (0)

Electrical Issues

Car details: 2007 BMW 328xi Sedan E90 Automatic
Last seven of Vin: K034024
Miles: 173XXX

Background,
So bought the car a month ago with a known problem with the Vanos system. Ended up being the bolts backed out on the back of the camshaft adjusting gears/units. Replaced both camshaft adjusting units and engine is running fine now.

When we went to look at the car before we bought it, the battery was dead/drained. Using another vehicle we jump-started it at the battery in the trunk to hear the noise the Vanos adjusting units were making. Found out later that that was a bad idea and that you should jump via the positive terminal in the engine bay. Anyway, replaced the battery and vanos camshaft adjusting units and all error codes for the Vanos system went away. Ever since the new battery was installed, a bunch of random lights are out and it seem like when the car was jump started, it fried something in the FRM (footwell module). Also, the stability control and 4x4 warning messages are on the car instrument cluster display. Rotating the steering wheel totally to one side and then the other only clears those messages temporary. Parking brake light is also on.

Error codes currently are as listed:

JBBF [JBBF87] | A6CF: AUC sensor
JBBF [JBBF87] | C90B: No description found

EGS [GS1912] | 578E: Gearbox oil: wear

VGSG [VGSG90] | 55C3: AWD limp-home control activated. No DSC specified nominal torque.

FRM [FRM_70] | 9CC0: Communication with step motor controller on the right disrupted
FRM [FRM_70] | 9CBF: Communication with step motor controller on the left disrupted
FRM [FRM_70] | 9CB5: Battery exhausted
FRM [FRM_70] | 9CAA: Terminal 30B connection faulty

DSC [DXC_90] | 5D8D: Hydraulic unit: pump

What should I look at next? Does this point to the FRM module being bad? How can I test this?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:16 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST