E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Airbag faults after programming with ISTA-P 3.6



Reply
 
Thread Tools Search this Thread
      03-10-2017, 11:53 AM   #1
jamba29
Registered
2
Rep
2
Posts

Drives: 2005 E61 535d
Join Date: Mar 2017
Location: Finland

iTrader: (0)

Exclamation Airbag faults after programming with ISTA-P 3.6

Hey!

I have a problem with 2005 e61 535d, I tried to deactivate seatbelt gong with ISTA-P 3.6 automatic conversion function and ended up with seatbelt and airbag lights on. I did convert the gong back to active but lights remain.

I cant access CKM with ISTA P i'm getting error 1000, could this be related?

I tried reprogramming all safety bus modules(8) and still no luck. ISTAP can't set the system time because satellite modules SBSL SBSR and SZL have error codes that cant be erased.

These modules with errors don't come up on NCS expert module list so i cant write empty .MAN file on them either.

No physical work has been done to the car...

Also i can't find the assembly numbers stated in the SBSL backup zif on any sp-daten? Is there a way to reset module to a backup with Tool32?

Any help is much appreciated!!
http://aijaa.com/DFSILW
http://aijaa.com/JlQC2S
http://aijaa.com/EBTmIx
http://aijaa.com/OKztP1




Appreciate 0
      03-10-2017, 03:16 PM   #2
BIMGE
Banned
1117
Rep
1,378
Posts

Drives: Bmw
Join Date: Feb 2017
Location: Atlanta

iTrader: (4)

Try flashing with with winkfp, they may be stuck in Programming mode.
Appreciate 1
      03-10-2017, 07:43 PM   #3
808AWD325xi
Ballin' out of control.
808AWD325xi's Avatar
No_Country
421
Rep
1,263
Posts

Drives: 2009 335i
Join Date: Jul 2007
Location: Moline, IL

iTrader: (0)

Quote:
Originally Posted by jamba29 View Post
Hey!

I have a problem with 2005 e61 535d, I tried to deactivate seatbelt gong with ISTA-P 3.6 automatic conversion function and ended up with seatbelt and airbag lights on. I did convert the gong back to active but lights remain.

I cant access CKM with ISTA P i'm getting error 1000, could this be related?

I tried reprogramming all safety bus modules(8) and still no luck. ISTAP can't set the system time because satellite modules SBSL SBSR and SZL have error codes that cant be erased.

These modules with errors don't come up on NCS expert module list so i cant write empty .MAN file on them either.

No physical work has been done to the car...

Also i can't find the assembly numbers stated in the SBSL backup zif on any sp-daten? Is there a way to reset module to a backup with Tool32?

Any help is much appreciated!!
http://aijaa.com/DFSILW
http://aijaa.com/JlQC2S
http://aijaa.com/EBTmIx
http://aijaa.com/OKztP1




ZB number 6974364 (SBSL module) should be available in any relatively current SP daten...it was released in 2005 and has not been superseded.

Tool32 cannot default code or restore firmware.

I'm not sure why an attempt to deactivate the seat belt reminder would cause these problems...

What is your Terminal 30 (KL30/Battery) voltage?

Are you using an ICOM interface?

Why did you flash the modules on the safety bus?
__________________
Alpina B3 Flash/BMS OCC/ER CP/ETS 5/HKS BOV/M3 Control Arms/OFT
Appreciate 0
      03-12-2017, 12:13 PM   #4
jamba29
Registered
2
Rep
2
Posts

Drives: 2005 E61 535d
Join Date: Mar 2017
Location: Finland

iTrader: (0)

Thanks for replying

I tried flashing with WinKPF it passed OK, but the faults are still there.
I flashed safetybus modules all at once with ISTA-P because i figured it could then set the time properly if all modules are initated at the same time.

I think the automatic function for seatbelt gong programs CAS and LM modules only. Could this be it has corrupted my VO and that is causing the errors?

The part i dont understand is, why are my SBSL modules showing physical fault error codes when only coding has changed? Also the seatbelt light is always illuminated, but when i drive off without seatbelt the chime starts and when i plug in the seatbelt the chime stops. So the parts are working its just the coding thats now off.

Terminal 30 is at 14,5V.
I'm using K+DCAN cable.

If the VO is off, could this be why i can't see SBSL module on NCS expert or is it something that wont show anyways?
Appreciate 0
      09-29-2017, 03:38 AM   #5
S3nder
New Member
1
Rep
8
Posts

Drives: 135i e82
Join Date: Sep 2017
Location: Finland

iTrader: (0)

Hi

Did anyone solved this problem out ??

i have same problem with airbag faults ...
Appreciate 0
      09-29-2017, 07:59 AM   #6
BIMGE
Banned
1117
Rep
1,378
Posts

Drives: Bmw
Join Date: Feb 2017
Location: Atlanta

iTrader: (4)

Quote:
Originally Posted by S3nder View Post
Hi

Did anyone solved this problem out ??

i have same problem with airbag faults ...
Code ABG via Expert Mode with Ncs, clear codes afterwords.

If faults retain, reflash with winkfp, recode with Ncs, clear with Inpa.
Appreciate 0
      09-30-2017, 07:34 AM   #7
S3nder
New Member
1
Rep
8
Posts

Drives: 135i e82
Join Date: Sep 2017
Location: Finland

iTrader: (0)

Quote:
Originally Posted by BimmerGeeks View Post
Code ABG via Expert Mode with Ncs, clear codes afterwords.

If faults retain, reflash with winkfp, recode with Ncs, clear with Inpa.
i have done all that what u mentioned , but still no luck ...

Do u want to help via teamviver and try yourself?

Maybe i am making something wrong way
Appreciate 0
      09-30-2017, 08:44 AM   #8
BIMGE
Banned
1117
Rep
1,378
Posts

Drives: Bmw
Join Date: Feb 2017
Location: Atlanta

iTrader: (4)

Quote:
Originally Posted by S3nder View Post
Quote:
Originally Posted by BimmerGeeks View Post
Code ABG via Expert Mode with Ncs, clear codes afterwords.

If faults retain, reflash with winkfp, recode with Ncs, clear with Inpa.
i have done all that what u mentioned , but still no luck ...

Do u want to help via teamviver and try yourself?

Maybe i am making something wrong way
Possibly. You only started getting these faults after Ista P update?
Appreciate 0
      09-30-2017, 10:36 AM   #9
S3nder
New Member
1
Rep
8
Posts

Drives: 135i e82
Join Date: Sep 2017
Location: Finland

iTrader: (0)

Quote:
Originally Posted by BimmerGeeks View Post
Possibly. You only started getting these faults after Ista P update?
Almost . I tried to code seatbelt reminder off with ncs . Only changed 2 code from abg file what i readed with ncs and after writing back errors came
Appreciate 0
      09-30-2017, 11:45 AM   #10
BIMGE
Banned
1117
Rep
1,378
Posts

Drives: Bmw
Join Date: Feb 2017
Location: Atlanta

iTrader: (4)

Quote:
Originally Posted by S3nder View Post
Quote:
Originally Posted by BimmerGeeks View Post
Possibly. You only started getting these faults after Ista P update?
Almost . I tried to code seatbelt reminder off with ncs . Only changed 2 code from abg file what i readed with ncs and after writing back errors came
Send your teamviwr info
Appreciate 0
Reply

Bookmarks

Tags
airbag, error, ista, programming, sgm

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:15 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST