E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > OE audio Speakers



Reply
 
Thread Tools Search this Thread
      06-25-2018, 04:45 PM   #1
jharar
Lieutenant
jharar's Avatar
United Kingdom
17
Rep
404
Posts

Drives: BMW F31 320d X-Drive Msport
Join Date: Oct 2012
Location: Essex

iTrader: (0)

OE audio Speakers

Has anyone used OE audio speakers available on eBay..
They are plug n play no need to cut wires..

Just want to know if anyone have used it and what they sound like..

Bit on budget side..

Thanks
Appreciate 0
      06-26-2018, 01:02 AM   #2
ptpending
Lieutenant Colonel
184
Rep
1,560
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (1)

Quote:
Originally Posted by jharar View Post
Has anyone used OE audio speakers available on eBay..
They are plug n play no need to cut wires..

Just want to know if anyone have used it and what they sound like..

Bit on budget side..

Thanks
thats not true that you do not need to cut wires
bmw has four types of the audio systems in e9x and four different speakers groups for them
so if you have base system now and install speakers from more advanced system you'll need to add amp to pump them and that will require full rewiring
if you have hifi or top hifi system and want to install better speakers you'll also need to replace amp to pump them and that will require amp plug rebuilding
so what system do you have now ? do you have tweeters in front door sills now ?
__________________
E91 2006. Retrofits:High beam assistant, Individual Audio, Autodim mirrors, CIC, Combox(USB and Bluetooth), Electric Sport Seats, Light package, Front PDC, Heated Steering Wheel, Happy Robot, Climate Comfort Windscreen, Blackline rear lights.
Appreciate 0
      06-27-2018, 04:40 PM   #3
Yam_335i
Private
5
Rep
52
Posts

Drives: White BMW 335i convertible
Join Date: Apr 2018
Location: London

iTrader: (0)

I have OE under seat subs in my E93.

Does the job pretty well, nothing crazy. My stock ones blow after 3 days, these have been pumping with no problem for a few months now.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:54 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST