E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > New Battery Died after couple weeks?



Reply
 
Thread Tools Search this Thread
      07-19-2018, 06:02 AM   #1
masterh
Private First Class
6
Rep
104
Posts

Drives: bmw 328i
Join Date: Oct 2017
Location: seattle wa

iTrader: (0)

New Battery Died after couple weeks?

I know I should do the battery registration but I haven't done it yet. The battery dies after couple weeks. Now I have to jump it after not driving the car for 2 days.

I read someone talking about battery died after 1 year without battery registration. I just figured I could swap it out since it comes with 3 year guarantee.

Anyways, I don't know history about this car. When I bought it a month ago, it had cheap recycled battery so I just figured it had a bad battery.

I am not sure it died because I didn't register it or it might have some parasite drain somewhere (no audio mods or anything)

Maybe the car kept charging the battery when it was full and caused to go bad?

Should I register it now and see how it goes or Replace with new one and register asap?
Appreciate 0
      07-19-2018, 01:01 PM   #2
ctuna
Major General
641
Rep
7,785
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

This is not the sub forum for battery questions which have
been quite hashed out .
1) If you don't drive the car enough the battery won't get charged.
2)If you switched battery types from lead acid to AGM or vice versa
it can cause problems if you don't reprogram the car for battery type
and size.
3) Did you match the amp hour size.
4)You could have a parasitic drain.
5) The alternator could be going bad.

http://www.bimmerfest.com/forums/sho...15&postcount=6

Last edited by ctuna; 07-19-2018 at 01:06 PM.
Appreciate 0
      07-19-2018, 04:05 PM   #3
techwhiz
Colonel
techwhiz's Avatar
United_States
385
Rep
2,865
Posts

Drives: e90 335i Sedan - Arctic
Join Date: Feb 2012
Location: Bay Area, Ca

iTrader: (4)

Quote:
Originally Posted by masterh View Post
I know I should do the battery registration but I haven't done it yet. The battery dies after couple weeks. Now I have to jump it after not driving the car for 2 days.

I read someone talking about battery died after 1 year without battery registration. I just figured I could swap it out since it comes with 3 year guarantee.

Anyways, I don't know history about this car. When I bought it a month ago, it had cheap recycled battery so I just figured it had a bad battery.

I am not sure it died because I didn't register it or it might have some parasite drain somewhere (no audio mods or anything)

Maybe the car kept charging the battery when it was full and caused to go bad?

Should I register it now and see how it goes or Replace with new one and register asap?
My guess is a bad regulator and the battery is under/over charged.
Regulator can be changed with the alternator on the car.
__________________
Arctic Metallic\CF Splitters, Spoiler, Mirror Covers\LED Tails\LSD\Tinted\Coded\Apex EC7-19"\LED Angel Eyes\Gloss Black Grill\Integrated V1 & Galaxy Tab\M-Performance Brakes\Cobb Tuned\xHP Flash\Resonator Removed and -> is your friend.
Appreciate 0
      07-20-2018, 12:34 AM   #4
masterh
Private First Class
6
Rep
104
Posts

Drives: bmw 328i
Join Date: Oct 2017
Location: seattle wa

iTrader: (0)

I doubt the Alternator is going bad. The battery was completely dead. I coudn't even unlock the door with a key fob. I drove around little bit, turned it off and it started normal which means Alternator charged the battery?

thanks for pointing out AGM battery. Maybe the car with AGM from the factory and it hasn't been coded yet.


Quote:
Originally Posted by ctuna View Post
This is not the sub forum for battery questions which have
been quite hashed out .
1) If you don't drive the car enough the battery won't get charged.
2)If you switched battery types from lead acid to AGM or vice versa
it can cause problems if you don't reprogram the car for battery type
and size.
3) Did you match the amp hour size.
4)You could have a parasitic drain.
5) The alternator could be going bad.

http://www.bimmerfest.com/forums/sho...15&postcount=6
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:48 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST