E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Aem meth install question



Reply
 
Thread Tools Search this Thread
      01-13-2020, 02:27 PM   #1
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

Aem meth install question

I had a shop install an AEM v2 meth kit but I do not think meth is flowing. My tank fluid level is not decreasing after multiple pulls and am getting big corrections on a 91 custom wedge tune. He also is wondering if meth is flowing.

I noticed that they tapped into the Vacume lines for the boost selenoid, so the AEM controller can read how much boost and control flow. My question is do you tap into those for boost readings? Or would that give no readings at all? Where are you supposed to tap into? On the charge side? Or is that correct how you are supposed to tap into?

Thanks guys
Appreciate 0
      01-13-2020, 02:47 PM   #2
NRigs
First Lieutenant
49
Rep
308
Posts

Drives: 2011 BMW 335xi
Join Date: Feb 2017
Location: Ma

iTrader: (0)

Not sure if this helps, but I tried tapping the charge pipe for boost when i was using the controller with internal map. I was getting boost fluctuations and even methanol coming out of my controller (Controller's are known to leak boost). I ended up getting the external MAP controller (one that uses the blue wire) and tapped the blue wire into the yellow wire of the TMAP sensor on the charge pipe. Set the controller to start at 60% and full at 80%. Everything has been perfect since.

You should also have the LED installed in your line of sight to let you know when the meth is flowing.
__________________
Current: 2011 BMW 335xi | Wedge Tuned | Meth | VRSF DP | VRSF 5" Intercooler | VRSF Chargepipe | BMS Intake | xHP Stg 3
Totaled:2014 Audi A4 CTS K04 APR Tuned
Appreciate 0
      01-13-2020, 02:55 PM   #3
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

I have the Led installed but it just stays green all the time, I thought that was just a power led.Is there a second led? Or just the one? They are the ones that ordered the kit and installed everything. I do know the controller is the internal map version though because it uses the boost line. I just was wondering if they tapped it to the right source to read boost. But now I am wondering about this led lol.
Appreciate 0
      01-13-2020, 03:10 PM   #4
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
3209
Rep
72,984
Posts


Drives: C6 Z06, 09 335i, 10 335xi
Join Date: Dec 2008
Location: www.TopGearSolutions.com

iTrader: (37)

Quote:
Originally Posted by sbuchana12 View Post
I had a shop install an AEM v2 meth kit but I do not think meth is flowing. My tank fluid level is not decreasing after multiple pulls and am getting big corrections on a 91 custom wedge tune. He also is wondering if meth is flowing.

I noticed that they tapped into the Vacume lines for the boost selenoid, so the AEM controller can read how much boost and control flow. My question is do you tap into those for boost readings? Or would that give no readings at all? Where are you supposed to tap into? On the charge side? Or is that correct how you are supposed to tap into?

Thanks guys
The ideal place to tap for vacuum would be the intake manifold as that is what the engine sees regarding PSI/boost pressure. Anything else before it will not be accurate.
__________________
|Like us on Facebook||Evolution Racewerks| |Active Autowerke| |ETS| |Burger Tuning| |PURE Turbos| |Mishimoto||VRSF| |AWE| |Wagner|

|20% Off ER | 10% VRSF Ends 3/31| |KW| |Spec| |ST Coilovers| |Koni| |Bilstein| |Borla| |Magnaflow| |AFE| |Fabspeed| |Injen| Discounts VRSF ER BM3 CSF Pure & More!
Appreciate 0
      01-13-2020, 03:31 PM   #5
NRigs
First Lieutenant
49
Rep
308
Posts

Drives: 2011 BMW 335xi
Join Date: Feb 2017
Location: Ma

iTrader: (0)

Quote:
Originally Posted by sbuchana12 View Post
I have the Led installed but it just stays green all the time, I thought that was just a power led.Is there a second led? Or just the one? They are the ones that ordered the kit and installed everything. I do know the controller is the internal map version though because it uses the boost line. I just was wondering if they tapped it to the right source to read boost. But now I am wondering about this led lol.
The LED should not remain lit. The light should be very dim until you hit the boost target. The LED becomes noticeably bright when you are at full boost target.

Check the controller to see if the led status light on the controller is also very bright. Also, do you have the boost safe option? If not, is the green wire connected to anything? Green wire should not be connected to anything if there is no boost safe.

You can also remove the meth nozzle and press the test button yourself to make sure it sprays properly.
__________________
Current: 2011 BMW 335xi | Wedge Tuned | Meth | VRSF DP | VRSF 5" Intercooler | VRSF Chargepipe | BMS Intake | xHP Stg 3
Totaled:2014 Audi A4 CTS K04 APR Tuned

Last edited by NRigs; 01-13-2020 at 03:40 PM..
Appreciate 0
      01-13-2020, 04:43 PM   #6
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

Ok so clearly they did not install properly. (Jeff where on the intake do you tap into for boost reading?)

1) the light says green and lit 100% of the time. I have not noticed it getting dimmer or brighter, but again I thought that just meant power was on, so have not been looking at it)
2) the pump does not shut off with the car (Even after 1 hour, they tapped into the idrive for a power source) I have to unplug the controller.
3) they tapped into the vacume lines going to the boost selenoid instead of the intake for boost readings.
4) Uggggggg

When I push the test Button it sprays but that is just a pump test. That does not mean it is installed correctly right?

Thanks for the replies and help guys
Appreciate 0
      01-13-2020, 06:18 PM   #7
Turbod
Major
Turbod's Avatar
United_States
324
Rep
1,146
Posts

Drives: 2014 E84 X1 35i M Sport
Join Date: Mar 2015
Location: Oregon

iTrader: (0)

You shouldn't take projects like this to shops that are not familiar with how to install these systems. For the N55 you will use the AEM (30-3305). When logging you should see the IATs drop down to ambient and then only slowly rise (unless you're on the stock intercooler). I never setup my LED so I couldn't tell you what that will look like when activated. Overall the system isn't difficult to install. For power you should just find a switched power source in your fuse box and run an inline fuse.
__________________
2011 E92 335i Auto 0-60 = 3.66 | 12.0 @ 125MPH JB4 / 11.7 @ 120MPH E30 MHD
Sold
2014 E84 X1 35i 0-60 = 4.55 | 12.75 @ 107MPH 293 AWHP 305 AWTW When stock
VRSF Chargepipe | BMS Intake | JB4 ISO | VRSF 7" Intercooler | ER Turbo Outlet | XHP Stage 2 | BMS Methanol Injection | Pure Stage 2 Turbo V3 | Pure Inlet | DV+ | AR DP |
Appreciate 1
anjuna179.50

      01-13-2020, 07:29 PM   #8
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

They said they have installed them in the past. I will bring up the switched power source and inline fuse to them. Where should they tap into on the intake manifold side for boost readings? I have a lot of mods they have installed for me so I trusted them.

Pure stage 1
Vrsf intercooler
Pure inlet pipe
Dps
Diverter valve

Edit: I looked up that controller Turbod and that is different from the one I have lol. Keeps getting better hahahah

Last edited by sbuchana12; 01-13-2020 at 07:37 PM..
Appreciate 0
      01-14-2020, 07:54 AM   #9
NRigs
First Lieutenant
49
Rep
308
Posts

Drives: 2011 BMW 335xi
Join Date: Feb 2017
Location: Ma

iTrader: (0)

For my 5V switched power source I used the red wire from the the exhaust flap plug in the trunk. For the battery power I plugged straight into the battery power distribution box. I ordered a socket housing and connector. I soldered the wire to the clip so the power wire clips in easily to the power distribution socket. It sounds like the shop complicated things.

http://tiny.cc/p5voiz - socket housing

http://tiny.cc/k4voiz - flat connector

Quote:
Originally Posted by sbuchana12 View Post
Edit: I looked up that controller Turbod and that is different from the one I have lol. Keeps getting better hahahah
You should really fix your power / wiring issues and then switch to the 30-3305 controller. That controller will most likely start leaking boost at some point.
__________________
Current: 2011 BMW 335xi | Wedge Tuned | Meth | VRSF DP | VRSF 5" Intercooler | VRSF Chargepipe | BMS Intake | xHP Stg 3
Totaled:2014 Audi A4 CTS K04 APR Tuned

Last edited by NRigs; 01-14-2020 at 08:06 AM..
Appreciate 0
      01-14-2020, 08:51 AM   #10
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

Ok thanks a lot guys. Really appreciate it
Appreciate 0
      01-14-2020, 12:25 PM   #11
Turbod
Major
Turbod's Avatar
United_States
324
Rep
1,146
Posts

Drives: 2014 E84 X1 35i M Sport
Join Date: Mar 2015
Location: Oregon

iTrader: (0)

If I recall correctly it is the yellow wire you want to tap into on your tmap for the boost signal.
__________________
2011 E92 335i Auto 0-60 = 3.66 | 12.0 @ 125MPH JB4 / 11.7 @ 120MPH E30 MHD
Sold
2014 E84 X1 35i 0-60 = 4.55 | 12.75 @ 107MPH 293 AWHP 305 AWTW When stock
VRSF Chargepipe | BMS Intake | JB4 ISO | VRSF 7" Intercooler | ER Turbo Outlet | XHP Stage 2 | BMS Methanol Injection | Pure Stage 2 Turbo V3 | Pure Inlet | DV+ | AR DP |
Appreciate 0
      02-09-2020, 07:33 PM   #12
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

So I got the shop to install the correct meth kit (30-3350) this issue is meth is not flowing still..... The blue wire from the controller is plugged into the yellow wire on the tmap for voltage readings like you guys suggested and I got them to fix the pump so now the pump turns off with the car. Also when the test button is pushed the light glows brighter and meth flows.

Now when driving, the light stays constantly dim and never gets brighter regardless of boost. fluid level never drops in the tank so meth is not flowing. You guys said said the green boost safe wire? If that is connected to something would that stop the flow meth? I do not have a boost safe option and I am not sure if they connected that to anything or not.

Any Ideas? Ugg I just want this fixed
Nrigs? Turbod?
Appreciate 0
      02-10-2020, 11:16 AM   #13
NRigs
First Lieutenant
49
Rep
308
Posts

Drives: 2011 BMW 335xi
Join Date: Feb 2017
Location: Ma

iTrader: (0)

Quote:
Originally Posted by sbuchana12 View Post
So I got the shop to install the correct meth kit (30-3350) this issue is meth is not flowing still..... The blue wire from the controller is plugged into the yellow wire on the tmap for voltage readings like you guys suggested and I got them to fix the pump so now the pump turns off with the car. Also when the test button is pushed the light glows brighter and meth flows.

Now when driving, the light stays constantly dim and never gets brighter regardless of boost. fluid level never drops in the tank so meth is not flowing. You guys said said the green boost safe wire? If that is connected to something would that stop the flow meth? I do not have a boost safe option and I am not sure if they connected that to anything or not.

Any Ideas? Ugg I just want this fixed
Nrigs? Turbod?
Green wire should be disconnected. Set the meth controller to 60% start and 80% full. This will have the meth turn on at 10 psi. If the green wire is connected to ground, it may stop the meth from flowing. I believe the boost fail safe will switch to ground and stop any flow if it senses a fault so definitely make sure the green is not connected to anything.
__________________
Current: 2011 BMW 335xi | Wedge Tuned | Meth | VRSF DP | VRSF 5" Intercooler | VRSF Chargepipe | BMS Intake | xHP Stg 3
Totaled:2014 Audi A4 CTS K04 APR Tuned
Appreciate 0
      02-11-2020, 10:27 PM   #14
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

It is working now I set it at 60% and full at 80% like you suggested. I am using the large nozzle that came with the kit what psi is 80%?
Appreciate 0
      02-11-2020, 11:11 PM   #15
TunafishE93
Banned
25
Rep
387
Posts

Drives: BMW 335i
Join Date: Dec 2019
Location: NV

iTrader: (0)

I think it goes buy stock psi regardless of tune.. So stock max is 10 psi so 80% it triggers at 8 psi.. Start triggers at 60% or 6 psi.. I am sure I will be corrected..
Appreciate 0
      02-12-2020, 07:35 AM   #16
NRigs
First Lieutenant
49
Rep
308
Posts

Drives: 2011 BMW 335xi
Join Date: Feb 2017
Location: Ma

iTrader: (0)

Quote:
Originally Posted by TunafishE93 View Post
I think it goes buy stock psi regardless of tune.. So stock max is 10 psi so 80% it triggers at 8 psi.. Start triggers at 60% or 6 psi.. I am sure I will be corrected..
It depends what your targets are. For me, 60% will be approximately 10 psi and 80% will be a bit higher around 14 psi.
__________________
Current: 2011 BMW 335xi | Wedge Tuned | Meth | VRSF DP | VRSF 5" Intercooler | VRSF Chargepipe | BMS Intake | xHP Stg 3
Totaled:2014 Audi A4 CTS K04 APR Tuned
Appreciate 0
      02-12-2020, 08:18 AM   #17
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

My targets are 17psi steady until redline. Is the 1000cc ok for that? Or is that too much? Dont want to cause quench/misfires
Appreciate 0
      02-12-2020, 08:56 AM   #18
TunafishE93
Banned
25
Rep
387
Posts

Drives: BMW 335i
Join Date: Dec 2019
Location: NV

iTrader: (0)

But the aem controller doesn't know what your targets are.. They are preset from the factor I am guessing to stock specs.. Unless your flashing the aem controller also??
Appreciate 0
      02-12-2020, 09:37 AM   #19
NRigs
First Lieutenant
49
Rep
308
Posts

Drives: 2011 BMW 335xi
Join Date: Feb 2017
Location: Ma

iTrader: (0)

Quote:
Originally Posted by TunafishE93 View Post
But the aem controller doesn't know what your targets are.. They are preset from the factor I am guessing to stock specs.. Unless your flashing the aem controller also??
It doesn't have to. It is based off the frequency at the yellow signal wire of the TMAP.
__________________
Current: 2011 BMW 335xi | Wedge Tuned | Meth | VRSF DP | VRSF 5" Intercooler | VRSF Chargepipe | BMS Intake | xHP Stg 3
Totaled:2014 Audi A4 CTS K04 APR Tuned
Appreciate 0
      02-12-2020, 09:41 AM   #20
NRigs
First Lieutenant
49
Rep
308
Posts

Drives: 2011 BMW 335xi
Join Date: Feb 2017
Location: Ma

iTrader: (0)

Quote:
Originally Posted by sbuchana12 View Post
My targets are 17psi steady until redline. Is the 1000cc ok for that? Or is that too much? Dont want to cause quench/misfires
1000 will be enough. I am currently using a DO7 which is 670 ml/min and my tuner suggested I go bigger. My HPFP is dipping so the extra flow should help that. I have a DO3 coming in the mail to go dual nozzle. That will give me a total flow rate of a little over 1000 ml/min. I was going to go DO10 but devils own are completely out of the DO10 nozzle and it would be several months before they were able to ship me one. I am hoping the dual DO7 and DO3 will fix any issues I am having.
__________________
Current: 2011 BMW 335xi | Wedge Tuned | Meth | VRSF DP | VRSF 5" Intercooler | VRSF Chargepipe | BMS Intake | xHP Stg 3
Totaled:2014 Audi A4 CTS K04 APR Tuned
Appreciate 0
      02-12-2020, 10:00 AM   #21
TunafishE93
Banned
25
Rep
387
Posts

Drives: BMW 335i
Join Date: Dec 2019
Location: NV

iTrader: (0)

Hum I thought it was based off of voltage from the tmap.. I must of read the install wrong..

Edit. I looked into it and the tmap is not a frequency wire it is voltage.. It does not matter if you have a tune boost of 10 or 20psi the voltage will remain the same for 10psi no matter.. This means the controller is going to trigger at the same point regardless of tune if set to same percentage..

For example a stock 10 psi boost set at 80% on controller will trigger at 8psi and a tune 18psi boost set on 80% will trigger at 8psi.

The tune doesn't change the signal voltage of the tmap.

Last edited by TunafishE93; 02-12-2020 at 10:30 AM..
Appreciate 0
      02-12-2020, 12:10 PM   #22
sbuchana12
Private
3
Rep
80
Posts

Drives: E92 335i
Join Date: Dec 2016
Location: Victoria BC

iTrader: (0)

So what you are saying...is that any tune above stock 10psi will be open and full spray 100% of the time at 10psi or more, since the controller has 2 dials min spray and max spray 0-100%

If that is the case then what is the point of the controller for progression spray, as it becomes useless above stock levels. That to me makes no sense.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:55 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST