E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Need help identifying the issue of my 335i n54



Reply
 
Thread Tools Search this Thread
      07-20-2018, 02:39 PM   #1
bmwlover123
New Member
0
Rep
23
Posts

Drives: 335i
Join Date: Sep 2017
Location: binghamton

iTrader: (0)

Question Need help identifying the issue of my 335i n54

Hello guys. I bought a 2007 e92 335i 10 months ago. I am having issues with it and can't decide between selling or repairing and keeping it. I definitely don't want to sell it but I dont know if the problem is too big. I was hoping my BMW brothers on this forum can help me identify the issue, so I dont get overcharged by the mechanics.

108,000 miles. It has never seen a mechanic since I bought(103k). I did an oil change but no maintenance other than that. When I was buying it, it had an "oil pan gasket leak", and I have been filling oil every 2 weeks since. I bought the car with this issue because it had 1 owner only and turbos were recently replaced. I finally have the money to get my baby fixed but I want to learn as much as possible before going to the mechanic.

The first issue is the oil pan gasket leak. But also sometimes smoke comes out of my exhausts, does this show that I'm possibly having another leak(walve cover gasket leak)? or the oil pan gasket leak can also cause the white smoke and the smell? I realized that the smoke reduced dramatically when I moved to a hot climate. It was happening much more in the cold.

Another issue with my car is, when I'm going with a steady speed over ~60 miles, the car kind of stutters for a split second, it feels like I removed my foot from the gas pedal for a split second.The rpm makes a really tiny move when this happens. It feels like the car wants me to go faster. Even when I put it in cruise control, same issue. However, it sometimes doesnt happen And this problem stops when I'm over ~100mph.

This stuttering things also happens when the car is in sport mode, and car is not speeding up. Like when I'm in sport mode and driving like a granddad, same thing is happening. It isnt really a problem when I'm driving fast in sport mode but if I'm trying to go with constant speed, this stutter happens like every 2 seconds. I recorded a video of the INPA live data when this issue is happening. I'm hoping pros on this forum can maybe find something out from this. In the video, the issue I'm talking about happens in these seconds: 7, 9-10, 14-15, 17

Video link:


Here are the error codes in INPA:


I really want to get my car fixed. I am going to move soon and the road is 2,000 miles. I dont want my car to break down on this trip so I want to fix as much things as I can at once. What are your recommendations on things I should replace? I dont know much about it but reading on the forums, I feel like replacing the injectors and spark plugs would be good. Also my car shifts well but not so smooth, BMW inspection record says that my transmission fluid is fine, but will replacing it make shifting smoother?
Appreciate 0
      07-22-2018, 02:22 AM   #2
BashShah
Lieutenant Colonel
Canada
149
Rep
1,742
Posts

Drives: 2012 335i Sedan
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

In my Opinion I think you have a UN-REGISTERED Miss Fire.

In order of urgency the things I would get looked at or even just do them completely.

1) Oil Pan Leak.....its just tooo much at once every 2 weeks. I would do the rear main seal also.

2) Walnut Blast.... get it done. (dont think about it.)
3) Plugs and Coils (Plugs use Bosch, Coils use Delphi or Edor Brand..... DO NOT USE Bosch anymore)
4) Inspect VCG and if it needs it, replace it.
5) Inspect OFHG and replace if needed. (Is the front of your engine dirty?
6) Vanos Solenoids (Clean and Swap) or replace
7) Replace all Vacuum lines on left and right of engine
8) Inspect Coolant and replace it with BMW Coolant and distilled water 50/50.
you should end up with 2 full jugs.
9) Belt, Tensioner, and Upper and Lower Pulleys. (I made a DIY on this)
9) Codes:

29f4 and 29F5: do you have Catless downpipes installed?
2DED:
EXPLANATION: The closed circuit current momentarily exceeds its threshold value when the TCU wakes up to perform the "Stolen Vehicle Recovery" function. This should not cause a discharged battery.
FIX: Take to dealer.

also clear all codes and then run again, after a short drive and lets see what comes up.
Appreciate 0
      07-24-2018, 09:10 PM   #3
bmwlover123
New Member
0
Rep
23
Posts

Drives: 335i
Join Date: Sep 2017
Location: binghamton

iTrader: (0)

Quote:
Originally Posted by BashShah View Post
In my Opinion I think you have a UN-REGISTERED Miss Fire.

In order of urgency the things I would get looked at or even just do them completely.

1) Oil Pan Leak.....its just tooo much at once every 2 weeks. I would do the rear main seal also.

2) Walnut Blast.... get it done. (dont think about it.)
3) Plugs and Coils (Plugs use Bosch, Coils use Delphi or Edor Brand..... DO NOT USE Bosch anymore)
4) Inspect VCG and if it needs it, replace it.
5) Inspect OFHG and replace if needed. (Is the front of your engine dirty?
6) Vanos Solenoids (Clean and Swap) or replace
7) Replace all Vacuum lines on left and right of engine
8) Inspect Coolant and replace it with BMW Coolant and distilled water 50/50.
you should end up with 2 full jugs.
9) Belt, Tensioner, and Upper and Lower Pulleys. (I made a DIY on this)
9) Codes:

29f4 and 29F5: do you have Catless downpipes installed?
2DED:
EXPLANATION: The closed circuit current momentarily exceeds its threshold value when the TCU wakes up to perform the "Stolen Vehicle Recovery" function. This should not cause a discharged battery.
FIX: Take to dealer.

also clear all codes and then run again, after a short drive and lets see what comes up.

Thank you so much for the response. This is really helpful. I recorded videos of sensor and injector screens when this is happening. Can you please watch this and let me know if you can think of anything more specific?

I am new in U.S. I dont have that much money and trying to do maintenance for the first time in 9 months since I bought it. Do you have any ideas on how to get a good deal with a mechanic to do a bunch of fixes?

I realized that it only happens over 2000rpm. That is why it happens in sport mode and normal mode when going fast and with constant speed over 2000rpm causes the issue. Does this ring any bell to you



Appreciate 0
      07-25-2018, 06:23 AM   #4
BashShah
Lieutenant Colonel
Canada
149
Rep
1,742
Posts

Drives: 2012 335i Sedan
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

are you modded or not?
if so, what mods?

also, have you cleaned and swapped your Vanos Solenoids?
when is the last time and walnut blast was done to clean the intake ports?

please answer these.
this hesitation sound like slight miss fires when have been knowned to be caused by either gunked up Vanos Solenoids or Carbon baked Intake ports on N54.

do you DIY or not?
Appreciate 0
      07-25-2018, 08:32 AM   #5
bmwlover123
New Member
0
Rep
23
Posts

Drives: 335i
Join Date: Sep 2017
Location: binghamton

iTrader: (0)

Quote:
Originally Posted by BashShah View Post
are you modded or not?
if so, what mods?

also, have you cleaned and swapped your Vanos Solenoids?
when is the last time and walnut blast was done to clean the intake ports?

please answer these.
this hesitation sound like slight miss fires when have been knowned to be caused by either gunked up Vanos Solenoids or Carbon baked Intake ports on N54.

do you DIY or not?
No fully stock. I havent cleanead and swapped them. Do you think I can do that myself? I am not really experienced but willing to get the tools and work on it if it is gonna be worth it. I bought the car 12k miles ago and I didnt do any walnut blast. I dont know when it was done before I got it.

It only happens if Im not accelerating and trying to with steady speed. Does that ring any bell?
Appreciate 0
      07-26-2018, 07:51 AM   #6
BashShah
Lieutenant Colonel
Canada
149
Rep
1,742
Posts

Drives: 2012 335i Sedan
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

It only happens if Im not accelerating and trying to with steady speed. Does that ring any bell?

this sentence is exactly what used to happen to me.
Walnut Blast fixed it.

But mind you I did everything else before this:
so you need to do this:
1) Walnut Blast, make sure it is a walnut blast, not scrunching and cleaning.
2) Replace all Plugs and Coils. Bosch Brand Plugs, and Delphi or Edor Brand Coils, DO NOT use Bosch brand coils again.
3) Replace Air Filter
4) Clean and swap Vanos Solenoids (I bought new ones) easy job.
5) Replace all Vacuum Lines, let me know and I will point out a good cheap source. (this is something that on a 10 year old car is bound to break, cause plastic, rubber wears over time).
6) Go to Chevron on nearly empty tank, fill up with Chevon's 91 or 92 octance.
this will have techron already premixed in the gas, and it will clean your injectors and Combustion chamber. (this is like putting bmw injector cleaner in a tank)
7) Since you are already using INPA, do a Full Adaptation reset. see attached. this is the proper way of doing it.
Attached Images
File Type: pdf BMW Fuel and Adaptation Reset.pdf (1.01 MB, 8 views)
Appreciate 0
      07-26-2018, 09:07 PM   #7
bmwlover123
New Member
0
Rep
23
Posts

Drives: 335i
Join Date: Sep 2017
Location: binghamton

iTrader: (0)

Quote:
Originally Posted by BashShah View Post
It only happens if Im not accelerating and trying to with steady speed. Does that ring any bell?

this sentence is exactly what used to happen to me.
Walnut Blast fixed it.

But mind you I did everything else before this:
so you need to do this:
1) Walnut Blast, make sure it is a walnut blast, not scrunching and cleaning.
2) Replace all Plugs and Coils. Bosch Brand Plugs, and Delphi or Edor Brand Coils, DO NOT use Bosch brand coils again.
3) Replace Air Filter
4) Clean and swap Vanos Solenoids (I bought new ones) easy job.
5) Replace all Vacuum Lines, let me know and I will point out a good cheap source. (this is something that on a 10 year old car is bound to break, cause plastic, rubber wears over time).
6) Go to Chevron on nearly empty tank, fill up with Chevon's 91 or 92 octance.
this will have techron already premixed in the gas, and it will clean your injectors and Combustion chamber. (this is like putting bmw injector cleaner in a tank)
7) Since you are already using INPA, do a Full Adaptation reset. see attached. this is the proper way of doing it.

Thank you so much for all this info. I am finally feeling well that I have almost found the issue. Was this issue happening to you in sports mode while travelling slow too? It is way more harsh when Im in sport mode and try to go steady. Another thing with my car is, if I accelerate fast, the boost is perfect, but if I accelerate not so fast but also not so slow, the engine kind of gives the actual boost 1 second after I accelerate. Is this turbo lag or something?
Appreciate 0
      07-27-2018, 02:14 AM   #8
BashShah
Lieutenant Colonel
Canada
149
Rep
1,742
Posts

Drives: 2012 335i Sedan
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

same issue, but i never tried it in sport mode.
it was like a hesitation on light throttle, especially small up hills, or gradual speed increase.
I think in sport mode I was fine.

The Lag you are experiencing is NORMAL per say.
you have 2 issues with Lag.
if you replace all your Vacuum lines, your Lag may decease, mine did.
but if you have the famous rear turbo actuator LOOSE ROD rattle, then your lag will always be there, and no matter what you do, it will be come back.

The ONLY way to fix that is Turbo replace, or rebuild.
Appreciate 0
Reply

Bookmarks

Tags
335i, n54, oil leak, stutter

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:13 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST