E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > engine shake during start up



Reply
 
Thread Tools Search this Thread
      04-21-2011, 02:33 PM   #1
prepster
Private First Class
7
Rep
102
Posts

Drives: bmw 335i
Join Date: Apr 2011
Location: ventura ca

iTrader: (0)

engine shake during start up

Ive searched throughout the forum and didn't find an answer besides replacing the fuel pump which i did. My car has 68k miles on it and i dont have any type of warranty on it. Ive done all the maintaince i can do to bring it as close to top shape as possible...oil flush, transmission drain and refill, brake flush with new brakes etc...but my engine still has minor shakes and has small vibration on and off for the first three minutes during cold start ups. what could this be? faulty fuel injectors? or is this normal? I plan to do the techron injector cleaning once i get closer to my next oil change if it is the injectors.
Appreciate 0
      04-21-2011, 02:55 PM   #2
Blk07335i
Captain
Blk07335i's Avatar
United_States
31
Rep
928
Posts

Drives: 2012 Alpine White e93 Msport
Join Date: Mar 2007
Location: San Diego

iTrader: (4)

Send a message via AIM to Blk07335i
If it only happens at cold start up I wouldn't worry about it. Mine is a little rough as well until it settles at idle. I have 58K miles.
Appreciate 0
      04-21-2011, 02:56 PM   #3
wtfmateim65
Second Lieutenant
8
Rep
291
Posts

Drives: AW 92 335i JB4
Join Date: Sep 2008
Location: Vegas

iTrader: (2)

The infamous n54 idle shakes. Almost everyones got em. Troubleshooting options: spark plugs, coils, injectors!

Did u get the injector recall done already?

Some techron should help periodically.

It's usually the spark plugs though, if not people have a bad injector or two, otherwise it's the coil packs acting up. Don't depend on the dealer completely to diagnose because they will run you in circles, tell you it's normal, or tell you "unable to duplicate customer concern" or some amateur hour bs like usual
Appreciate 0
      04-21-2011, 03:47 PM   #4
wren57
Roll Tide
wren57's Avatar
398
Rep
2,245
Posts

Drives: 335i
Join Date: Jul 2010
Location: St Louis

iTrader: (10)

Change your spark plugs.

I think I recall reading where fuel injector additive you put in your gas tank is useless in our DI cars. Am I wrong?
__________________
Fix your broken/stripped cowl bolts with this elegant brass solution!
http://www.e90post.com/forums/showthread.php?p=20230306
Appreciate 0
      04-21-2011, 04:49 PM   #5
wtfmateim65
Second Lieutenant
8
Rep
291
Posts

Drives: AW 92 335i JB4
Join Date: Sep 2008
Location: Vegas

iTrader: (2)

Quote:
Originally Posted by wren57 View Post
Change your spark plugs.

I think I recall reading where fuel injector additive you put in your gas tank is useless in our DI cars. Am I wrong?
You are right for cleaning the valves, since the fuel doenst wash over injectors in DI,but techron will still clean the injectors and cylinders walls since it's in the fuel
Appreciate 0
      04-21-2011, 05:18 PM   #6
JoosyJoos
Major
JoosyJoos's Avatar
United_States
71
Rep
1,335
Posts

Drives: 2011 335d
Join Date: Apr 2007
Location: Atlanta, GA

iTrader: (1)

Garage List
2008 BMW 335i  [0.00]
Could also be your motor mounts... And you're only noticing it on cold start where it revs it up above normal idle range at standstill.
__________________

1997 M3 Coupe - BMWCCA I-Prepared #22
2006 M Roadster - 23,000 miles and slowly counting
Appreciate 0
      04-21-2011, 05:22 PM   #7
Robert H
New Member
1
Rep
9
Posts

Drives: E90 335i
Join Date: Aug 2007
Location: SF Bay Area

iTrader: (0)

I'm curious whether you had the HPFP related recall work done on your car.

I took my '07 w/ 57k in for the recall about a month ago due to long crank and malfunction light/reduced power issue. The dealer replaced HPFP, a couple of injectors and reprogrammed the car. It came back from the dealer running extremely rough after every cold start...stutters/misfires for the first few minutes and then runs normal. It never did this before the recall work was done.

I took the car back to dealer Tuesday and they called to tell me the cold start is due to carbon buildup and has nothing to do with the recall work. I guess that could be the case but I'm a little skeptical. The dealer is calling BMWNA to see if they will cover the repair cost.

If you search "rough cold idle" there is at least one other person who experienced the same after recall repair. Anybody else?
Appreciate 0
      04-21-2011, 06:05 PM   #8
genuinekid
Enlisted Member
1
Rep
36
Posts

Drives: 335i
Join Date: Nov 2010
Location: van nuys

iTrader: (0)

Quote:
Originally Posted by Robert H View Post
I'm curious whether you had the HPFP related recall work done on your car.

I took my '07 w/ 57k in for the recall about a month ago due to long crank and malfunction light/reduced power issue. The dealer replaced HPFP, a couple of injectors and reprogrammed the car. It came back from the dealer running extremely rough after every cold start...stutters/misfires for the first few minutes and then runs normal. It never did this before the recall work was done.

I took the car back to dealer Tuesday and they called to tell me the cold start is due to carbon buildup and has nothing to do with the recall work. I guess that could be the case but I'm a little skeptical. The dealer is calling BMWNA to see if they will cover the repair cost.

If you search "rough cold idle" there is at least one other person who experienced the same after recall repair. Anybody else?
i am in a similar situation. Mines a 08 w/ 38k miles. Due to the rough idle, i so far had 6 spark plugs, injectors, changed, the hpfp changed, updated software all under warranty. But even after that i had a simi rough idle at stops. And now, they are cleaning my valves since due to carbon buildup. They are decarbonizing? or something.
Appreciate 0
      04-21-2011, 09:46 PM   #9
prepster
Private First Class
7
Rep
102
Posts

Drives: bmw 335i
Join Date: Apr 2011
Location: ventura ca

iTrader: (0)

Quote:
Originally Posted by JoosyJoos View Post
Could also be your motor mounts... And you're only noticing it on cold start where it revs it up above normal idle range at standstill.
yeah it only happens when the engine is cold at start up around 700 rpm. Ive read the repair manuall and can someone confirm if when replacing the fuel injectors, you have to calibrate them on the computer with the bmw software? Meaning only the dealerships or independant shops can do this? I plan to replace the spark plugs within the next oil change. I will also BG engine decarbinizer to clean the valves, and also run chevron techron as well to clean the injectors. is there anything else i can try?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:47 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST