E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > What did you do to your car today?



Reply
 
Thread Tools Search this Thread
      06-15-2020, 10:48 PM   #1651
jard
Private
jard's Avatar
Australia
17
Rep
88
Posts

Drives: 2007 BMW 335i
Join Date: Apr 2019
Location: Melbourne

iTrader: (0)

Quote:
Originally Posted by Socket View Post
Rock in line ..... that wont help
It was a full wtf moment when I found it haha
__________________
07' E92 335i | Catless DPs | Empire performance catback | Mishimoto Catch Can | RB PCV | 19' Star spoke 230's | BMS spacers
Appreciate 0
      06-16-2020, 03:28 AM   #1652
Socket
Lieutenant General
Socket's Avatar
Australia
3218
Rep
11,131
Posts

Drives: 335i
Join Date: Nov 2014
Location: Melbourne

iTrader: (4)

Garage List
2008 BMW E92  [0.00]
Quote:
Originally Posted by jard View Post
It was a full wtf moment when I found it haha
Hahhaha
Appreciate 0
      06-22-2020, 06:12 PM   #1653
EB89
Brigadier General
EB89's Avatar
Australia
523
Rep
3,174
Posts

Drives: 2011 335i e92 DCT
Join Date: Sep 2015
Location: Australia, NSW

iTrader: (0)

Garage List
My car had been running like a dog for over a year.

I was hating it so much.

Cold starts where the car would take 10 seconds to turn on, embarrassing.

Doing a pull on a street or highway and Iíd get misfires, if I kept pulling for too long full engine malfunction and limp mode.

I read HPFP codes and knew what it was..

I had no time to do anything about it, local dealer had a month wait to get in, and when it finally got in they couldn'tí find ANYTHING wrong, no codes and told me the car started fine and drove fine, so frustrating.

I even said keep it overnight and do a full cold start in the morning and somehow it started fine for them.

I asked them to quote on the HPFP replacement which took like a week or two and I just got an email with ďahhh $4,000 to do the HPFPĒ

I though stuff this

Ordered one from FCP for way less

Took a day off work and installed it (ass of a job)

Instantly cold starts weíre perfect again.
Pressing the start button now and the car couldnít start faster if it tried lol

However misfires when doing pulls remained still, misfires code on 2 cylinders.

Ordered six new plugs and coils from FCP, I worked out I donít think they had ever been changed in the 9 years and 150,000kms of life the car has.... no record in the service book of it at lease and Iíve had the car for 5 years.

Another day off work to install them, and now the car is running better than it ever has since over owned it.

I forgot how much I enjoyed driving a car without issues.

Treated it to some new genuine piano black interior trim pieces which look so much better than the stock wood grain crap.

Coolant expansion tank took a dump, second time over replaced that but I got the first from FCP so I should be able to return the first broken one, havenít sent it back yet, new one arrived and fixed that coolant leak, it was the exact same failure as the first. Plastic cracked and was pissing out coolant. Easy to install.

Then, thereís I was, long weekend, bored, sitting at home and I open up my service NsW app on my phone for no reason and just look around in it, I see my license, I see registrations and go into that, and thereís none there, hmm weird, so I do a rego lookup and my cars registration had been expired for 7 months....

I had no idea..

Unfortunately after 3 months they take your number plates and you need to go through the full blue slip process. So my EB89 plates are gone and I have generic plates, but I got it registered again with no issues.

Apparently since they removed the window stickers, cars falling out of registration by accident has skyrocketed.

The app didnít try to warn me and I moved house so can only assume the snail mail went to someone else, no idea where the reminder email is, I canít find it.

Anyway, as of right now the car is running really well, Iím loving to drive it, happy days... knock on wood

Last edited by EB89; 06-22-2020 at 06:21 PM..
Appreciate 0
      06-23-2020, 05:34 AM   #1654
Hoper
Captain
Hoper's Avatar
Australia
152
Rep
606
Posts

Drives: 2008 E92 335i 6MT
Join Date: Sep 2016
Location: Canberra Australia

iTrader: (0)

Quote:
Originally Posted by EB89 View Post
My car had been running like a dog for over a year.

I was hating it so much.

Cold starts where the car would take 10 seconds to turn on, embarrassing.

Doing a pull on a street or highway and I’d get misfires, if I kept pulling for too long full engine malfunction and limp mode.

I read HPFP codes and knew what it was..

I had no time to do anything about it, local dealer had a month wait to get in, and when it finally got in they couldn't’ find ANYTHING wrong, no codes and told me the car started fine and drove fine, so frustrating.

I even said keep it overnight and do a full cold start in the morning and somehow it started fine for them.

I asked them to quote on the HPFP replacement which took like a week or two and I just got an email with “ahhh $4,000 to do the HPFP”

I though stuff this

Ordered one from FCP for way less

Took a day off work and installed it (ass of a job)

Instantly cold starts we’re perfect again.
Pressing the start button now and the car couldn’t start faster if it tried lol

However misfires when doing pulls remained still, misfires code on 2 cylinders.

Ordered six new plugs and coils from FCP, I worked out I don’t think they had ever been changed in the 9 years and 150,000kms of life the car has.... no record in the service book of it at lease and I’ve had the car for 5 years.

Another day off work to install them, and now the car is running better than it ever has since over owned it.

I forgot how much I enjoyed driving a car without issues.

Treated it to some new genuine piano black interior trim pieces which look so much better than the stock wood grain crap.

Coolant expansion tank took a dump, second time over replaced that but I got the first from FCP so I should be able to return the first broken one, haven’t sent it back yet, new one arrived and fixed that coolant leak, it was the exact same failure as the first. Plastic cracked and was pissing out coolant. Easy to install.

Then, there’s I was, long weekend, bored, sitting at home and I open up my service NsW app on my phone for no reason and just look around in it, I see my license, I see registrations and go into that, and there’s none there, hmm weird, so I do a rego lookup and my cars registration had been expired for 7 months....

I had no idea..

Unfortunately after 3 months they take your number plates and you need to go through the full blue slip process. So my EB89 plates are gone and I have generic plates, but I got it registered again with no issues.

Apparently since they removed the window stickers, cars falling out of registration by accident has skyrocketed.

The app didn’t try to warn me and I moved house so can only assume the snail mail went to someone else, no idea where the reminder email is, I can’t find it.

Anyway, as of right now the car is running really well, I’m loving to drive it, happy days... knock on wood
Nice EB, always good to get them running right, I've been walnut blasting a few cars and always get good reports back, also done some fuel pumps, injectors and water pumps recently

everyone loves them when they're running nice
Appreciate 0
      06-23-2020, 06:31 AM   #1655
Aus335iguy
Colonel
Aus335iguy's Avatar
538
Rep
2,033
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Garage List
2009 BMW 335i  [5.00]
Quote:
Originally Posted by EB89 View Post
My car had been running like a dog for over a year.

I was hating it so much.

Cold starts where the car would take 10 seconds to turn on, embarrassing.

Doing a pull on a street or highway and I’d get misfires, if I kept pulling for too long full engine malfunction and limp mode.

I read HPFP codes and knew what it was..

I had no time to do anything about it, local dealer had a month wait to get in, and when it finally got in they couldn't’ find ANYTHING wrong, no codes and told me the car started fine and drove fine, so frustrating.

I even said keep it overnight and do a full cold start in the morning and somehow it started fine for them.

I asked them to quote on the HPFP replacement which took like a week or two and I just got an email with “ahhh $4,000 to do the HPFP”

I though stuff this

Ordered one from FCP for way less

Took a day off work and installed it (ass of a job)

Instantly cold starts we’re perfect again.
Pressing the start button now and the car couldn’t start faster if it tried lol

However misfires when doing pulls remained still, misfires code on 2 cylinders.

Ordered six new plugs and coils from FCP, I worked out I don’t think they had ever been changed in the 9 years and 150,000kms of life the car has.... no record in the service book of it at lease and I’ve had the car for 5 years.

Another day off work to install them, and now the car is running better than it ever has since over owned it.

I forgot how much I enjoyed driving a car without issues.

Treated it to some new genuine piano black interior trim pieces which look so much better than the stock wood grain crap.

Coolant expansion tank took a dump, second time over replaced that but I got the first from FCP so I should be able to return the first broken one, haven’t sent it back yet, new one arrived and fixed that coolant leak, it was the exact same failure as the first. Plastic cracked and was pissing out coolant. Easy to install.

Then, there’s I was, long weekend, bored, sitting at home and I open up my service NsW app on my phone for no reason and just look around in it, I see my license, I see registrations and go into that, and there’s none there, hmm weird, so I do a rego lookup and my cars registration had been expired for 7 months....

I had no idea..

Unfortunately after 3 months they take your number plates and you need to go through the full blue slip process. So my EB89 plates are gone and I have generic plates, but I got it registered again with no issues.

Apparently since they removed the window stickers, cars falling out of registration by accident has skyrocketed.

The app didn’t try to warn me and I moved house so can only assume the snail mail went to someone else, no idea where the reminder email is, I can’t find it.

Anyway, as of right now the car is running really well, I’m loving to drive it, happy days... knock on wood
Good to hear you're back on the road EB!
Any pics of the piano black trim? I've been thinking about how that might look on mine ?
__________________
When you doppelkaplung you doppel your fun.
Appreciate 0
      06-23-2020, 07:18 AM   #1656
Socket
Lieutenant General
Socket's Avatar
Australia
3218
Rep
11,131
Posts

Drives: 335i
Join Date: Nov 2014
Location: Melbourne

iTrader: (4)

Garage List
2008 BMW E92  [0.00]
Quote:
Originally Posted by EB89 View Post
My car had been running like a dog for over a year.

I was hating it so much.

Cold starts where the car would take 10 seconds to turn on, embarrassing.

Doing a pull on a street or highway and Iíd get misfires, if I kept pulling for too long full engine malfunction and limp mode.

I read HPFP codes and knew what it was..

I had no time to do anything about it, local dealer had a month wait to get in, and when it finally got in they couldn'tí find ANYTHING wrong, no codes and told me the car started fine and drove fine, so frustrating.

I even said keep it overnight and do a full cold start in the morning and somehow it started fine for them.

I asked them to quote on the HPFP replacement which took like a week or two and I just got an email with ďahhh $4,000 to do the HPFPĒ

I though stuff this

Ordered one from FCP for way less

Took a day off work and installed it (ass of a job)

Instantly cold starts weíre perfect again.
Pressing the start button now and the car couldnít start faster if it tried lol

However misfires when doing pulls remained still, misfires code on 2 cylinders.

Ordered six new plugs and coils from FCP, I worked out I donít think they had ever been changed in the 9 years and 150,000kms of life the car has.... no record in the service book of it at lease and Iíve had the car for 5 years.

Another day off work to install them, and now the car is running better than it ever has since over owned it.

I forgot how much I enjoyed driving a car without issues.

Treated it to some new genuine piano black interior trim pieces which look so much better than the stock wood grain crap.

Coolant expansion tank took a dump, second time over replaced that but I got the first from FCP so I should be able to return the first broken one, havenít sent it back yet, new one arrived and fixed that coolant leak, it was the exact same failure as the first. Plastic cracked and was pissing out coolant. Easy to install.

Then, thereís I was, long weekend, bored, sitting at home and I open up my service NsW app on my phone for no reason and just look around in it, I see my license, I see registrations and go into that, and thereís none there, hmm weird, so I do a rego lookup and my cars registration had been expired for 7 months....

I had no idea..

Unfortunately after 3 months they take your number plates and you need to go through the full blue slip process. So my EB89 plates are gone and I have generic plates, but I got it registered again with no issues.

Apparently since they removed the window stickers, cars falling out of registration by accident has skyrocketed.

The app didnít try to warn me and I moved house so can only assume the snail mail went to someone else, no idea where the reminder email is, I canít find it.

Anyway, as of right now the car is running really well, Iím loving to drive it, happy days... knock on wood
Man what a drama.... glad its running sweet now
Appreciate 0
      06-24-2020, 06:05 PM   #1657
EB89
Brigadier General
EB89's Avatar
Australia
523
Rep
3,174
Posts

Drives: 2011 335i e92 DCT
Join Date: Sep 2015
Location: Australia, NSW

iTrader: (0)

Garage List
Quote:
Originally Posted by Aus335iguy View Post
Good to hear you're back on the road EB!
Any pics of the piano black trim? I've been thinking about how that might look on mine ?
Here’s some pics, they don’t really do justice, the gloss black looks really good.

Photos seem to make black interiors look much lighter than they are in person.

I haven’t finished the trim yet, just did the two front dash and shifter surround.

Ill do the doors and rear soon, they came from schmiedmann








Last edited by EB89; 06-24-2020 at 07:13 PM..
Appreciate 2
      06-24-2020, 07:15 PM   #1658
EB89
Brigadier General
EB89's Avatar
Australia
523
Rep
3,174
Posts

Drives: 2011 335i e92 DCT
Join Date: Sep 2015
Location: Australia, NSW

iTrader: (0)

Garage List
Hoper Socket Aus335iguy

Thanks guys, was painful, but im really loving the car again at the moment
__________________
/ MHD Stage 2+ / AR CATLESS DP / PE MOD 4 INCH TIPS / BMR FMIC / K&N DROP IN / BMS CP /
Appreciate 1
      06-24-2020, 09:36 PM   #1659
Socket
Lieutenant General
Socket's Avatar
Australia
3218
Rep
11,131
Posts

Drives: 335i
Join Date: Nov 2014
Location: Melbourne

iTrader: (4)

Garage List
2008 BMW E92  [0.00]
Quote:
Originally Posted by EB89 View Post
Hereís some pics, they donít really do justice, the gloss black looks really good.

Photos seem to make black interiors look much lighter than they are in person.

I havenít finished the trim yet, just did the two front dash and shifter surround.

Ill do the doors and rear soon, they came from schmiedmann]
Looks beautiful
Appreciate 0
      06-25-2020, 03:38 AM   #1660
Aus335iguy
Colonel
Aus335iguy's Avatar
538
Rep
2,033
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Garage List
2009 BMW 335i  [5.00]
@EB89
How much was the trim? I thought you painted it I was going congratulate you and that it look really smooth
__________________
When you doppelkaplung you doppel your fun.
Appreciate 0
      06-25-2020, 07:51 AM   #1661
EB89
Brigadier General
EB89's Avatar
Australia
523
Rep
3,174
Posts

Drives: 2011 335i e92 DCT
Join Date: Sep 2015
Location: Australia, NSW

iTrader: (0)

Garage List
Quote:
Originally Posted by Aus335iguy View Post
@EB89
How much was the trim? I thought you painted it I was going congratulate you and that it look really smooth
The first order of 4 pieces was $630AUD including delivery

The second order of 6 pieces will be $650AUD landed (havenít ordered yet)

So $1280 AUD delivered for all 10 pieces

I have tried painting in the past and in summer the Aussie heat just obliterates home paint jobs, at least my home paint jobs.

Iíve painted trim and it bubbles
Iíve wrapped trim and it turns to shit

Summer just fucks it.

Genuine trim is what I should have done from day one
Appreciate 1
      06-25-2020, 09:56 PM   #1662
DR-JEKL
Major General
Australia
788
Rep
6,220
Posts

Drives: Space Grey E92 335i 6MT
Join Date: Jul 2012
Location: Newcastle Ozstraylia

iTrader: (3)

Haha EB89 you're so fkn lucky you didn't get pulled over for no rego! I always get an sms for my cars when their rego is due?

The $ you saved almost help cover for your nice piano black interior trim!
Appreciate 0
      06-26-2020, 05:07 AM   #1663
EB89
Brigadier General
EB89's Avatar
Australia
523
Rep
3,174
Posts

Drives: 2011 335i e92 DCT
Join Date: Sep 2015
Location: Australia, NSW

iTrader: (0)

Garage List
Quote:
Originally Posted by DR-JEKL View Post
Haha EB89 you're so fkn lucky you didn't get pulled over for no rego! I always get an sms for my cars when their rego is due?

The $ you saved almost help cover for your nice piano black interior trim!
I really donít know how it happened. No email, I didnít get SMSs, no notification from the Service NSW app, and I moved house so I assume a letter went elsewhere.

Yeah extremely lucky police didnít get me. Why canít they just auto debit me...

Tell me I need an inspection 45 days out or what ever it is and keep reminding via the app.

Auto debit if a green slip and inspection exist.

Ehhh
Appreciate 0
      Yesterday, 11:32 PM   #1664
Coupes33
Major
276
Rep
1,190
Posts

Drives: 2006 335i, 2017 Audi S3
Join Date: Aug 2013
Location: Brisbane, QLD, Australia

iTrader: (0)

Yesterday, I removed my M3 diff. I will take it to Diff Lab to have the gear ratio changed from 3.25 back to 3.45. Today, I removed the Fuel-It PI. Intake ports are still clean with no build up of carbon on the valves.

Name:  IMG_2478.jpg
Views: 10
Size:  472.5 KB

Name:  IMG_2477.jpg
Views: 10
Size:  260.7 KB

Name:  IMG_2467.jpg
Views: 10
Size:  494.0 KB

Name:  IMG_2479.jpg
Views: 10
Size:  387.0 KB
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:01 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST