E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > FRM3 won't accept coding



Reply
 
Thread Tools Search this Thread
      07-04-2019, 10:56 AM   #1
vaceuf
New Member
0
Rep
5
Posts

Drives: 2011 328i RWD
Join Date: Jul 2019
Location: MB

iTrader: (0)

FRM3 won't accept coding

My issues are two-fold:

a) My car (2011 328i) has 3 bulb errors that come up every time I start the vehicle (L&R front direction indicator faulty & license plate light faulty). Ista also finds a R brake light and sidemarker fault code, however they don't pop up in the check control. This causes my rear tail lights to flicker, and I get the 3 quick "bulb out" flashes the first time I use my signals every morning. However all lights come on as required, no LED's are out.

b) Due to this, I wanted to just code out all bulb fault errors. I read the file through NCS expert, changed the KALTUE_FRA & WARMUE_FRA TO NICHT_AKTIV, saved as .man file, did the getpsw command in NCS expert, and changed job to SG codiern, execute, and all looks like it goes well. Then I read the psw file again and none of my changes are made, it goes right back to default. I have found that apparently I need to code some of the CC_Meldung lines as well, but can't find what to change the WERT values to.
Either way, it may be useless as I've tried numerous times with various combinations and none of them actually change any settings permanently. I can successfully code other ECUs.

So now I'm starting to wondering if either a) my FRM has issues or b) I may have faulty taillights that are causing other issues? I wonder about the taillights because I know it's had a rear end accident, and one tail light has a droopy LED "bar". Anyone with experience with this?
Appreciate 0
      07-04-2019, 03:01 PM   #2
Sensible_
Colonel
423
Rep
2,444
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Quote:
Originally Posted by vaceuf View Post
My issues are two-fold:

a) My car (2011 328i) has 3 bulb errors that come up every time I start the vehicle (L&R front direction indicator faulty & license plate light faulty). Ista also finds a R brake light and sidemarker fault code, however they don't pop up in the check control. This causes my rear tail lights to flicker, and I get the 3 quick "bulb out" flashes the first time I use my signals every morning. However all lights come on as required, no LED's are out.

b) Due to this, I wanted to just code out all bulb fault errors. I read the file through NCS expert, changed the KALTUE_FRA & WARMUE_FRA TO NICHT_AKTIV, saved as .man file, did the getpsw command in NCS expert, and changed job to SG codiern, execute, and all looks like it goes well. Then I read the psw file again and none of my changes are made, it goes right back to default. I have found that apparently I need to code some of the CC_Meldung lines as well, but can't find what to change the WERT values to.
Either way, it may be useless as I've tried numerous times with various combinations and none of them actually change any settings permanently. I can successfully code other ECUs.

So now I'm starting to wondering if either a) my FRM has issues or b) I may have faulty taillights that are causing other issues? I wonder about the taillights because I know it's had a rear end accident, and one tail light has a droopy LED "bar". Anyone with experience with this?
In NCS Expert what profile are you loading? Have you checked manipulation is ticked when you 'edit profile'...
Appreciate 0
      07-04-2019, 03:56 PM   #3
vaceuf
New Member
0
Rep
5
Posts

Drives: 2011 328i RWD
Join Date: Jul 2019
Location: MB

iTrader: (0)

Yes, both "FSW-/PSW-Trace" & "FSW-/PSW-Manipulate with FSW_PSW.MAN" are ticked.
Appreciate 0
      07-04-2019, 08:05 PM   #4
vaceuf
New Member
0
Rep
5
Posts

Drives: 2011 328i RWD
Join Date: Jul 2019
Location: MB

iTrader: (0)

Successfully coded the CAS and KOMBI tonight, so I'm starting to think that my FRM has issues. in ISTA I can activate all the lights, but when I delete error codes they come back right away.

The car does have LED angel eyes, think that Might have something to do with it?
Appreciate 0
      07-06-2019, 06:43 PM   #5
ErikF80
Enlisted Member
United_States
16
Rep
34
Posts

Drives: 2014 F80
Join Date: Jul 2016
Location: CT

iTrader: (0)

Be careful with FRM. I bricked mine apparently today and it's got nothing to do with coding. They just seem to fail BMW even had a recall campaign for them. It's a $500 part new.
Appreciate 0
      07-12-2019, 07:39 AM   #6
vaceuf
New Member
0
Rep
5
Posts

Drives: 2011 328i RWD
Join Date: Jul 2019
Location: MB

iTrader: (0)

I fixed my problem last night. So for searching later, here's what I did:

I upgraded my FRM with WinkFP to whatever it thought was the latest zusb available. I just let it figure it out on its own through comfort mode. That went through succesfully, but then I got a red triangle and the car kept warning me to shut the car off because the lights may not be working. I then "reset" the FRM by going into NCS expert and coding it, I won't get into the details, but google "reset FRM with NCS expert".

After that, all my errors are gone, which was what I was trying to accomplish with the coding to begin with.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:57 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST