E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > E90 climate control not working



Reply
 
Thread Tools Search this Thread
      11-12-2011, 09:02 PM   #1
Lolitskasey
Private First Class
Lolitskasey's Avatar
10
Rep
115
Posts

Drives: 2006 Black 325xi
Join Date: Aug 2011
Location: Alaska

iTrader: (0)

E90 climate control not working

So on my 2006 e90 my climate control is not working, it doesn\'t even turn on even when the car is started. Anyone have any ideas.
Appreciate 0
      11-13-2011, 12:39 AM   #2
Glim
Captain
Canada
18
Rep
780
Posts

Drives: 2006 330i & 2013 X5 35i
Join Date: Jun 2011
Location: Victoria, BC

iTrader: (0)

Check your fuses, look in your owners manual, do a search here for fuses.

Fuses are located behind your glove box, the fuse puller is the orange pretzel in the middle/left of the fuse box.

The map for the fuses is in the plastics you remove to access the fuses.
Appreciate 0
      11-13-2011, 01:09 AM   #3
queensfield
First Lieutenant
United_States
18
Rep
364
Posts

Drives: 2006 330i E90
Join Date: Aug 2011
Location: So Cal

iTrader: (0)

If fuses check out, then blower motor or ac compressor are the next possibilities.
Appreciate 0
      11-13-2011, 01:36 AM   #4
Lolitskasey
Private First Class
Lolitskasey's Avatar
10
Rep
115
Posts

Drives: 2006 Black 325xi
Join Date: Aug 2011
Location: Alaska

iTrader: (0)

Checked the fuses they all seem fine.
Appreciate 0
      11-13-2011, 09:25 AM   #5
fdriller9
Banned
United_States
229
Rep
7,089
Posts

Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [6.44]
Does the panel work? Or are you just talking about the blower motor?

There's a TSB out for the windshield cowl cover to lift allowing water to drip onto the blower motor. This causes the unit to rust and eventually fail.
Appreciate 0
      11-13-2011, 01:19 PM   #6
Lolitskasey
Private First Class
Lolitskasey's Avatar
10
Rep
115
Posts

Drives: 2006 Black 325xi
Join Date: Aug 2011
Location: Alaska

iTrader: (0)

Quote:
Originally Posted by ********* View Post
Does the panel work? Or are you just talking about the blower motor?

There's a TSB out for the windshield cowl cover to lift allowing water to drip onto the blower motor. This causes the unit to rust and eventually fail.
No the panel doesn't even light up.
Appreciate 0
      02-12-2012, 12:45 AM   #7
n54pwr
Private
8
Rep
92
Posts

Drives: 07 Sparkling Graphite e90 335i
Join Date: Dec 2011
Location: Norfolk, VA

iTrader: (0)

Did you ever find out what the problem was? I'm having the same issue on my car at this moment.
__________________
Mods: JB4/usb, Injen DCI, 35% tinting, 6k LED interior/plates, led blinkers, carbon wrapped interior trim, VIS carbon hood, matte black grills, and MTEC angel eyes.

Packages: Premium & Sport
Appreciate 0
      03-05-2012, 01:07 PM   #8
Alexm007
Second Lieutenant
Alexm007's Avatar
United_States
20
Rep
220
Posts

Drives: '19 G01 X3, 09 E70,07 E92 335i
Join Date: Sep 2010
Location: Antarctica

iTrader: (3)

Check the Final Stage Resistor, or do a search on this.
__________________

Current: 2019 G01 X3
Before that: 2009 e70 X5
Before that: 2007 BMW 335i Coupe - ZSP
Appreciate 0
      03-05-2012, 07:11 PM   #9
GMWNashville
Colonel
United_States
169
Rep
2,372
Posts

Drives: 19 G05, 16 F80, 10 E70x5D
Join Date: Jan 2008
Location: Nashville, TN

iTrader: (2)

final stage has nothing to do with the panel itself not even lighting up. Its likely a dead ihka...
Appreciate 0
      08-13-2012, 02:41 PM   #10
E90ROXS
Captain
E90ROXS's Avatar
201
Rep
649
Posts

Drives: E90
Join Date: Feb 2012
Location: SJ

iTrader: (1)

I changed my trunk interior light last night and found out this morning that the climate control was dead. I didn't light up. I'm going to check the fuse box later. Can someone chime in on this? Thanks
Appreciate 0
      07-28-2013, 12:52 AM   #11
Prodipper
Captain
Prodipper's Avatar
United_States
89
Rep
602
Posts

Drives: e90
Join Date: Oct 2008
Location: PA/Ny,NY

iTrader: (3)

Garage List
2007 328i  [10.00]
has anyone found the solution to this, OP?
__________________
,BMW 328i,Arctic Metallic,M tech,Ram Dinan CAI,Bmw Performance Exhaust,Performance spark plugs,Black Line,Euroswitch,Xenon Conversion with HID KIT from Halogens, 199- 19" Star spoke,InteriorTerra Leather,Premium Cold weather package,Led Lights.New> M3 spoiler, angel eyes harness,corner delete MOD,Lux h8.0, LCI 09 Xenon headlights,BMW Performance auto shift knob+boot,vinyl roof,Oem M3 220 wheels.
Appreciate 0
      08-10-2013, 04:40 PM   #12
darth_bimmer88
Not Broke Yet
12
Rep
48
Posts

Drives: 2008 335i Coupe
Join Date: Feb 2013
Location: Milwaukee, WI

iTrader: (4)

Had this same problem... fuse #77 did it for me
Appreciate 0
      10-18-2013, 06:13 AM   #13
Beberle
New Member
0
Rep
14
Posts

Drives: 2009 328it
Join Date: Oct 2013
Location: Atlanta

iTrader: (0)

Ditto. Just got my car back from the body shop after being rear-ended. Climate control was dead. Turns out fuse 77 was blown.

No idea why...
Appreciate 0
      12-09-2014, 08:18 AM   #14
Zero_09
Captain
Canada
33
Rep
627
Posts

Drives: 07 E90, 2011 E90
Join Date: Jul 2012
Location: =

iTrader: (1)

I'm having the same issues now and changed the 30A #77 fuse. Still not lighting up and not working....
Appreciate 0
      11-22-2017, 03:31 PM   #15
Mrverser37
Registered
0
Rep
1
Posts

Drives: 2011 bmw 328i
Join Date: Nov 2017
Location: Killeen

iTrader: (0)

I bought a whole new climate control module only to figure out that it was fuse #77, also this fuse controls the trunk light and the glove compartment lighting
Appreciate 0
      05-19-2022, 01:57 PM   #16
sam9116
Private
Canada
8
Rep
56
Posts

Drives: ​
Join Date: Apr 2017
Location: Edmonton, Alberta, Canada

iTrader: (0)

Quote:
Originally Posted by Zero_09 View Post
I'm having the same issues now and changed the 30A #77 fuse. Still not lighting up and not working....
For everyone else, you can also try checking fuse 15/61, that worked for my car
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:18 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST