E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N57 / M57 Turbo Diesel Discussions - 335d > Am I making this up?



Reply
 
Thread Tools Search this Thread
      06-09-2020, 02:51 AM   #1
Tambohamilton
Major
United Kingdom
505
Rep
1,478
Posts

Drives: E91 330d
Join Date: Apr 2019
Location: Wiltshire, UK

iTrader: (0)

Am I making this up?

I seem to remember reading somewhere that CBU on the piston crown can build up to a level where it actually impacts the cylinder head, and causes knocking, etc? Is that true? How could I test it? Would it show up on a compression test?

I'm hearing a knocking noise from the engine when cold, at around 1200rpm, and only when cruising (30mph, 4th gear). It's quiet, and sounds fairly distant - I can only hear it when the road surface is smooth. It's definitely there, though.

I don't think my engine is too worn. I don't get excessive blow-by or oil consumption, and no smoke at all.

M57TU2 330d, 135k miles. 0w-30 castrol edge.

Another potential cause might be a loose injector (not sealing to the cyl head properly)? There is maybe a slight tap on idle, but nothing offensive.

Any ideas/suggestions beyond turning up the music?
Appreciate 0
      06-09-2020, 09:00 AM   #2
BB_cuda
Brigadier General
BB_cuda's Avatar
634
Rep
3,164
Posts

Drives: 2011 335D Msport, 2013 X5D
Join Date: Nov 2011
Location: Clear Lake, Texas

iTrader: (0)

No direct experience here. Perhaps pull a glow plug and look down in at piston with a boroscope, if one will fit. I've never heard or read what you mention. Your 2nd hypothesis has a better chance of being true.
Appreciate 1
      06-11-2020, 12:21 PM   #3
ranthum
Private First Class
22
Rep
125
Posts

Drives: Looking to Buy
Join Date: Jan 2015
Location: United States

iTrader: (0)

I have never heard of cbu on the piston. When I disassembled my engine the pistons were fine after 100k. I believe it gets too hot for CBU to build up in the combustion chamber.

As far as your noise, it could just be injectors. Or it could be something on the belt drive. Or maybe you or the previous owner didn't change oil often and the oil pump or passages are a little gummed up.
Appreciate 1
      06-11-2020, 04:43 PM   #4
Tambohamilton
Major
United Kingdom
505
Rep
1,478
Posts

Drives: E91 330d
Join Date: Apr 2019
Location: Wiltshire, UK

iTrader: (0)

OK, cool. CBU on the piston is out!

Getting an oil analysis done next oil change ~end of the month, so we'll see if that highlights anything of note. Next time I have the engine cover off I'll check torques on the injector hold-downs, but I doubt that'll actually show any issues... I don't want to just tear into it and start replacing parts because it runs nicely as it is.

Thanks guys
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:58 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST