E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Valve cover replacement: 10mm bolt wont tighten



Reply
 
Thread Tools Search this Thread
      06-28-2020, 01:41 PM   #1
Yobroham
BHendricks
United_States
0
Rep
3
Posts

Drives: 09 BMW 328i
Join Date: Jun 2020
Location: San Diego, CA

iTrader: (0)

I just finished replacing the valve cover on my 09 328i. It "mostly" went off without a hitch. There are two 10mm bolts that have ground wires attached...one in back and one towards the front. The one in back tightened without a problem but the front one wont tighten...it feels like something is stopping it from reaching the hole.

Any suggestions? I REALLY don't want to take the whole thing apart! Not sure if its the bolt and housing thats the issue but I doubt having a ground wire connected to a loose bolt is a good idea.
Attached Images
  
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:55 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST