E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Retrofitted iDrive and MULF2... But problems



Reply
 
Thread Tools Search this Thread
      06-21-2020, 02:39 PM   #1
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Retrofitted iDrive and MULF2... But problems

Evening all

Firstly yes mine is an E89, but the systems are basically the same.

OK I've retrofitted a CIC MID unit into my car, yes I'm aware it shouldn't have a MID version but that's not the problem. Everything seems to be working, Radio FM & DAB, CD, NAV (with an emulator), but there are some exceptions.....

NAV only locks onto your current location once you've started driving, from a fresh boot it seems to want to revert to it's last (previous owners) location. Going into Service mode shows GPS as not working with no positioning information, but then how does it pick up my location once I'm driving (still the same in settings after driving!)?
I've plugged a glovebox USB into the back of the headunit and tried updating MAPS but it's not recognising it.

The other problem seems to be the MULF2 unit, I can't get Bluetooth to show up. MOST must be working as it is picking up the AUX and USB ports that are plugged in.

As for coding I've removed $663, that was for my original Professional headunit that had Bluetooth and USB control built in (and both worked perfectly fine). I've left in the coding $6NN, $6FL, +KMP3 and +IPOD.
And I've added in $644, $606 (CIC MID) and $654 (DAB) to the VO and then written these to the CAS, NFRM and MCIC.

So can anyone help, what have I missed? I've done about 24 hours of Google searching and I keep coming up with the same stuff, all of which I've done, I just can't see what I've missed.

Oh I've not codded the CID as I'm running with an Android screen. Sorry if this is a bit of a dumb question but I'm pulling my hair out (and I've not got a lot of it left!!)
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!

Last edited by DavesZed; 06-23-2020 at 01:15 AM.. Reason: amendment
Appreciate 0
      06-22-2020, 12:10 AM   #2
smass
Major
253
Rep
1,267
Posts

Drives: 09 X5d - 06 325i & 330i
Join Date: Sep 2010
Location: Phoenix, AZ

iTrader: (1)

In the US, most MULF are used for USB only and their BT is disabled. Did you code the MULF to enable/check the Bluetooth? Search for BT or Bluetooth and change to aktiv.
Appreciate 0
      06-22-2020, 03:16 AM   #3
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Quote:
Originally Posted by smass View Post
In the US, most MULF are used for USB only and their BT is disabled. Did you code the MULF to enable/check the Bluetooth? Search for BT or Bluetooth and change to aktiv.
Thank you smass, I'll look into it and see if I've missed anything in that part of the coding
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      06-23-2020, 02:08 AM   #4
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

OK, well I'm still not getting anywhere.
Firstly I've amended my first post, I actually removed $633 and added $644.

Attached are the photos of the MULF2 I've bought.

Now I've tried going through the tcr file and amended it accordingly for Bluetooth etc and written it back to the CIC, I've also changed the VIN in the MULF with WINKFP which was successful. But I must be missing something somewhere as I don't see anything that I can think of as relating to the MULF in the module list. Should I see something like ULF? Like I say I can see MCIC and CID (even though I don't actually have a CID). If I should see it what should it be displayed as and how can I rectify this?

TIA
Attached Images
  
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      06-23-2020, 08:43 AM   #5
smass
Major
253
Rep
1,267
Posts

Drives: 09 X5d - 06 325i & 330i
Join Date: Sep 2010
Location: Phoenix, AZ

iTrader: (1)

Check INPA UIF for 55 ISPB
Appreciate 0
      06-23-2020, 10:17 AM   #6
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Quote:
Originally Posted by smass View Post
Check INPA UIF for 55 ISPB
Now this is a little strange, it is showing the ISPB as there with the Manuf date which matches the sticker on the side (19.08.2010) but it's not showing the VIN. Now I've followed the instructions and set the VIN (and checked it afterward) with Tool32, and I've just done it again just in case and it's still not showing the VIN.
Print outs attached

Thanks for your help, it's appreciated
Attached Images
File Type: pdf INPA-PrintFile - na_id.tmp.pdf (35.1 KB, 5 views)
File Type: pdf INPA-PrintFile - na_aif.tmp.pdf (28.3 KB, 3 views)
File Type: pdf INPA-PrintFile - na_fzg.tmp.pdf (28.3 KB, 3 views)
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      06-23-2020, 10:48 AM   #7
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

And this is what I'm seeing on the screen...

Now just a thought, my MOST optic cables are going directly from the CIC to the MULF, no other component is included. So I'm assuming this is all OK as the AUX and USB are working. The wires going into the 56 pin plug on the MULF are positive and negative, AUX and microphone, then there's the USB plug and the Bluetooth antenna plug.
Attached Images
 
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      06-23-2020, 03:59 PM   #8
smass
Major
253
Rep
1,267
Posts

Drives: 09 X5d - 06 325i & 330i
Join Date: Sep 2010
Location: Phoenix, AZ

iTrader: (1)

Most fiber devices sometimes don't display their vin to INPA. That is completely normal. The vin is not really needed to get bluetooth coding to work.
Appreciate 0
      06-24-2020, 01:58 AM   #9
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Quote:
Originally Posted by smass View Post
Most fiber devices sometimes don't display their vin to INPA. That is completely normal. The vin is not really needed to get bluetooth coding to work.
I was out checking it again later and the Bluetooth name now appears on the screen when in the service menu, but still no joy in it actually working properly.

As a matter of interest this the list of modules available for coding according to NCS. Unless I'm missing something I do not see any relation to the MULF, should I?

These may seem dumb questions but I've never had problems coding before so assumed, after all the reading I've done on it, that this would work!
Attached Images
 
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      06-26-2020, 12:02 AM   #10
ptpending
Colonel
245
Rep
2,079
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (1)

I believe that 6NN option is not compatible with MULF2
haven't seen 606 option in e89, can you show full picture of your monitor in dashboard ?
__________________
E91 2006. Retrofits:High beam assistant, Individual Audio, Autodim mirrors, CIC, Combox(USB and Bluetooth), Electric Sport Seats, Light package, Front PDC, Heated Steering Wheel, Happy Robot, Climate Comfort Windscreen, Blackline rear lights.
Appreciate 0
      06-26-2020, 02:01 AM   #11
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Quote:
Originally Posted by ptpending View Post
I believe that 6NN option is not compatible with MULF2
haven't seen 606 option in e89, can you show full picture of your monitor in dashboard ?
Thank you for that.
If 6NN is not compatible, then what would be the correct code to use?

606 is specifically for the CIC-MID unit which is Business Nav as opposed to 609 (Professional Nav) which is what the e89 should have. It works but is just a 2/3 on the left of the screen. It's made for the 6.6" screen, but I've got an Android 10.25" screen on mine which I'm using in place of the OEM flip-up screen.
Although it is the smaller headunit it is operating perfectly apart from the Bluetooth issue and that I can't get the glovebox USB to work (tried with a second USB as well). Centre console USB and AUX work perfectly fine through the MULF so the MOST must be working.
I've attached a couple of photos of the screen, not recent ones as I've not taken a full shot of it yet.
Attached Images
  
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      06-26-2020, 02:12 AM   #12
ptpending
Colonel
245
Rep
2,079
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (1)

Quote:
Originally Posted by DavesZed View Post
Thank you for that.
If 6NN is not compatible, then what would be the correct code to use?

606 is specifically for the CIC-MID unit which is Business Nav as opposed to 609 (Professional Nav) which is what the e89 should have. It works but is just a 2/3 on the left of the screen. It's made for the 6.6" screen, but I've got an Android 10.25" screen on mine which I'm using in place of the OEM flip-up screen.
Although it is the smaller headunit it is operating perfectly apart from the Bluetooth issue and that I can't get the glovebox USB to work (tried with a second USB as well). Centre console USB and AUX work perfectly fine through the MULF so the MOST must be working.
I've attached a couple of photos of the screen, not recent ones as I've not taken a full shot of it yet.
nice screen
i think that for MULF2 you have to use only 644 and 6FL. 6NN switches these functions to internal headunit boards, which CIC MID do not have
__________________
E91 2006. Retrofits:High beam assistant, Individual Audio, Autodim mirrors, CIC, Combox(USB and Bluetooth), Electric Sport Seats, Light package, Front PDC, Heated Steering Wheel, Happy Robot, Climate Comfort Windscreen, Blackline rear lights.
Appreciate 0
      06-26-2020, 02:41 AM   #13
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Quote:
Originally Posted by ptpending View Post
nice screen
i think that for MULF2 you have to use only 644 and 6FL. 6NN switches these functions to internal headunit boards, which CIC MID do not have
I will delete 6NN then and see what happens as 644 has already been coded in (could be a conflict then!). Thanks
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      07-02-2020, 03:12 AM   #14
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

OK, so it's taken me a week to get back to this project but alas no further along.
6NN was deleted and still didn't achieve anything, still got "please wait" all the time in Bluetooth mode
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      07-03-2020, 07:53 AM   #15
smass
Major
253
Rep
1,267
Posts

Drives: 09 X5d - 06 325i & 330i
Join Date: Sep 2010
Location: Phoenix, AZ

iTrader: (1)

Do you really need bluetooth phone from your MULF when you have an Android screen with the same function? My screen came with it's own mic that was easy to run to the factory location. The newer systems can work better than the factory BMW one in many cases.
Appreciate 0
      07-04-2020, 03:05 AM   #16
DavesZed
Second Lieutenant
United Kingdom
43
Rep
219
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Quote:
Originally Posted by smass View Post
Do you really need bluetooth phone from your MULF when you have an Android screen with the same function? My screen came with it's own mic that was easy to run to the factory location. The newer systems can work better than the factory BMW one in many cases.
That's a very good point, and one I have thought about, but I am also considering to change the Android screen for an OEM one (as someone is giving me one for free!!) and then I'd simply use one of the plug-n-play CarPlay/Android Auto boxes instead as TBH I only use Android Auto anyway so this would be a nice OEM option
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:24 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST