E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Problems with the PAC RP4.1-BM21 wiring harness



Reply
 
Thread Tools Search this Thread
      02-27-2017, 02:39 PM   #1
Reptar0nIce
Registered
0
Rep
4
Posts

Drives: 2010 BMW 335i M Sport
Join Date: Feb 2017
Location: Wa

iTrader: (0)

Problems with the PAC RP4.1-BM21 wiring harness

Hi,

I've tried searching around to see if anyone else has encountered issues using the PAC RP4.2-BM21 wiring harness. I installed my Pioneer AVH-4100NEX head unit with it. It's supposed to support warning chimes, and ensure the PDC still functions (which my car has on the rear bumper). After installing it my PDC doesn't function at all, and the warning chimes only sounds some of the time. When I first start up the car I hear the chimes just fine, but if I get back into the car after it's been sitting for maybe 15 minutes I hear nothing. It also doesn't play any chimes for the seatbelt being unbuckled. I also hear a beep every minute or so through the Bluetooth speaker mounted in the drivers footwell (I connected it to the PAC interface per the instructions). I have the standard Professional stereo, and everything else seems to function correctly (including the steering wheel controls). I'm going to call the manufacturers tech line, but thought I'd see if anyone else encountered a similar issue.
Appreciate 0
      04-11-2017, 09:46 PM   #2
Reptar0nIce
Registered
0
Rep
4
Posts

Drives: 2010 BMW 335i M Sport
Join Date: Feb 2017
Location: Wa

iTrader: (0)

Sorry to dredge this one back up but has not a single other person used this interface with an aftermarket stereo? I contacted PAC and they have no idea what the issue is. They told me to return it to the retailer I bought it from through the warranty (Amazon sent a new one without asking for the old one). I plug in the new unit and am having the exact same symptoms! I'm beginning to wonder if PAC did any actual f*cking QA. Has anyone successfully used this particular interface? I'm debating on tearing it out and getting the Connects2.
Appreciate 0
      04-12-2017, 11:00 AM   #3
taibanl
Brigadier General
taibanl's Avatar
208
Rep
4,125
Posts

Drives: BMW
Join Date: Sep 2010
Location: NA

iTrader: (4)

Im not an expert on this particular subject but i dont think those features will work without the oem head unit.

You could attempt to code your vehicle for 'no radio' but i think this is why most folks to to retain the oem head unit. You may have some success in jeffb's dynavin n6 thread.
Appreciate 0
      04-12-2017, 04:04 PM   #4
Reptar0nIce
Registered
0
Rep
4
Posts

Drives: 2010 BMW 335i M Sport
Join Date: Feb 2017
Location: Wa

iTrader: (0)

Quote:
Originally Posted by taibanl View Post
Im not an expert on this particular subject but i dont think those features will work without the oem head unit.

You could attempt to code your vehicle for 'no radio' but i think this is why most folks to to retain the oem head unit. You may have some success in jeffb's dynavin n6 thread.
Thanks for the reply. One of the reasons I went with the PAC unit is they state it will retain steering wheel controls as well as warning chimes without the need to retain the factory head unit. If no one has been able to use this unit and have it function I'm just going to tear the damn thing out and be done with it.
Appreciate 0
      04-13-2017, 12:11 PM   #5
Reptar0nIce
Registered
0
Rep
4
Posts

Drives: 2010 BMW 335i M Sport
Join Date: Feb 2017
Location: Wa

iTrader: (0)

Once again heard back from PAC about the second unit. They have no clue what the issue is (most likely lack of adequate QA on their part). They've told me to attempt to get a refund for the unit. I guess word of caution for anyone wanting to install an aftermarket head unit into their car, avoid PAC at all cost.
Appreciate 0
      07-03-2018, 11:46 PM   #6
Stubbie Blue
Private
United_States
70
Rep
85
Posts

Drives: 2012 135i Coupe
Join Date: Mar 2017
Location: Florida

iTrader: (0)

In case anyone is interested, I had the same issue with the PDC not working and an intermittent beep on my 2012 BMW 135i. I discovered that the solution was to downgrade the firmware to version 1.00.03 on the PAC website.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:32 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST