E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Won't Rev at WOT.. Misfire?



Reply
 
Thread Tools Search this Thread
      06-29-2014, 12:27 PM   #1
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Won't Rev at WOT.. Misfire?

So I've run into a very confusing problem. 2 nights ago I filled up about 40/60 E85/ 93 and the car was running great. Drove through about 4 gallons. Parked the car and the next day I fixed my battery cable issue that I had. The cable was frayed and was causing charge issue and was only putting about 12-12.5v to the battery.All went fine with that. I rehooked the battery back up and all of a sudden I have this crazy odd issue. If I floor the car it won't rev past 3k-4k and will start misfiring or atleast sounds like misfiring. I have thrown some random misfire codes across different cylinders.

1. I don't believe I have a vacuum leak because i unplugged a line after the car was off for a while and I heard vacuum. I also can hear a clear difference when unhooking a vacuum line while the car is on

2. It seems almost like traction control limiting and it doesn't throw misfire codes all the time. It just sounds like it sorta.

3. It builds boost and you can hear it clearly.

4. I can rev the car to 5-6k if I gradually increase it and it sounds fine. It's only if I floor it.

Any ideas?

Update w/ Codes
2E0F: No description and have had for weeks prior... car was running fine with it

2BE9: Fuel pressure: Pressure below minimum pressure; injection deactivation for catalytic

2C90: Blow-off valve, mechanics: Jammed closed (read a while back that this code is normal with JB4 hooked up.)

2C58: Boost pressure control, deactivation: Boost- pressure build-up blocked
__________________

Last edited by JcLusso; 06-29-2014 at 05:30 PM.
Appreciate 0
      06-29-2014, 01:06 PM   #2
scflaw
Captain
127
Rep
643
Posts

Drives: 2019 M2C, M135I, CLS400
Join Date: Jan 2011
Location: HKG

iTrader: (1)

I'm pretty sure somebody would ask the same question.
Mod list?
Tune or supporting hardware for ethanol?
Appreciate 0
      06-29-2014, 02:19 PM   #3
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Jb4, FBO + Meth. Ran half of the gas out and tried unhooking jb4. Still have issues. Here's a video.

Appreciate 0
      06-29-2014, 05:30 PM   #4
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Update w/ Codes
2E0F: No description and have had for weeks prior... car was running fine with it

2BE9: Fuel pressure: Pressure below minimum pressure; injection deactivation for catalytic

2C90: Blow-off valve, mechanics: Jammed closed (read a while back that this code is normal with JB4 hooked up.)

2C58: Boost pressure control, deactivation: Boost- pressure build-up blocked
__________________
Appreciate 0
      06-29-2014, 07:46 PM   #5
.mark
Private
4
Rep
76
Posts

Drives: '11 335i M Sport
Join Date: Sep 2013
Location: VA/NC

iTrader: (3)

Honestly I'd double check your battery cable first..sounds like you may be having some power issues.
Appreciate 0
      06-29-2014, 08:41 PM   #6
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Hidden OB menu reads 14v solid....

Quote:
Originally Posted by .mark View Post
Honestly I'd double check your battery cable first..sounds like you may be having some power issues.
__________________
Appreciate 0
      06-29-2014, 08:51 PM   #7
.mark
Private
4
Rep
76
Posts

Drives: '11 335i M Sport
Join Date: Sep 2013
Location: VA/NC

iTrader: (3)

Quote:
Originally Posted by JcLusso View Post
Hidden OB menu reads 14v solid....
At idle or with a load on it?
Appreciate 0
      06-29-2014, 08:57 PM   #8
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Both. If I rev it to 6k slowly it gets there fine. If I try and push the car to accelerate it just chokes.... or if I rev it in neutral. It's like something is limiting it almost in my opinion.
__________________
Appreciate 0
      06-30-2014, 06:59 AM   #9
bk335ilci
Private First Class
6
Rep
105
Posts

Drives: 2011 335i Alpine White
Join Date: May 2013
Location: Brooklyn NY

iTrader: (0)

Hpfp??
Appreciate 0
      06-30-2014, 12:43 PM   #10
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Quote:
Originally Posted by bk335ilci View Post
Hpfp??
Wouldn't I have startup issues and long cranks. Car runs fine at idle and startup
__________________
Appreciate 0
      06-30-2014, 04:05 PM   #11
bk335ilci
Private First Class
6
Rep
105
Posts

Drives: 2011 335i Alpine White
Join Date: May 2013
Location: Brooklyn NY

iTrader: (0)

Doesn't the hpfp work off of the rpm because it is gear driven. Do some logs and ask Terry?
Appreciate 0
      06-30-2014, 07:16 PM   #12
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
I don't think its the HPFP. HPFP is very common on N54 but I'm N55. Also, car show no signs of long cranks or rough idle...
__________________
Appreciate 0
      07-01-2014, 11:57 AM   #13
thomas88162
Lieutenant
17
Rep
594
Posts

Drives: E92 328i
Join Date: Jun 2013
Location: Clinton, IN

iTrader: (0)

Yet you have a pressure deviation code... Even some N55's occasionally reject HPFP's.
Appreciate 0
      07-01-2014, 12:03 PM   #14
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Quote:
Originally Posted by thomas88162 View Post
Yet you have a pressure deviation code... Even some N55's occasionally reject HPFP's.
Wouldn't HPFP be more sporadic. Like I figured car would randomly have start issues, almost die out and stuff like that. Did you see the video about? It's so identical every time and just makes me feel like its something electronic restricting it almost...
__________________
Appreciate 0
      07-02-2014, 01:28 AM   #15
SUPAN
Private First Class
3
Rep
157
Posts

Drives: E92 n55 335 2011 dct
Join Date: Oct 2013
Location: Malaysia, KL

iTrader: (0)

Ignition coil changed ? spark plugs ?
Appreciate 0
      07-02-2014, 02:24 AM   #16
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Quote:
Originally Posted by thomas88162 View Post
Yet you have a pressure deviation code... Even some N55's occasionally reject HPFP's.
Had my friend check it out and his computer diagnosed HPFP.... symptoms make sense too now. Also, the issue has worsened and it won't rev past like 2k now.
__________________
Appreciate 0
      07-02-2014, 03:33 AM   #17
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Anyone have a guide on replacing the HPFP for N55. Found a N54 DIY.... but no N55
__________________
Appreciate 0
      07-02-2014, 06:33 AM   #18
bk335ilci
Private First Class
6
Rep
105
Posts

Drives: 2011 335i Alpine White
Join Date: May 2013
Location: Brooklyn NY

iTrader: (0)

How many miles on your car? And how many were you tuned for?
Appreciate 0
      07-02-2014, 07:02 AM   #19
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Quote:
Originally Posted by bk335ilci View Post
How many miles on your car? And how many were you tuned for?
49k. Tuned since 10-12k w/ JB4 + FBO. Started running meth around 43k and mixing E85 around 47k.
__________________
Appreciate 0
      07-02-2014, 03:59 PM   #20
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Turns out something else still must be wrong since the HPFP was replaced and I'm still having this issue....
__________________
Appreciate 0
      02-13-2015, 09:32 PM   #21
RyanMv4
First Lieutenant
16
Rep
361
Posts

Drives: 2106 435xi
Join Date: Jun 2010
Location: PA

iTrader: (2)

Any update on this ? Same exact thing happened to me today
__________________
2016 435xi Coupe .... aFe Stage 2 Intake, JB4, aWe Exhaust + Performance Mid Pipe, ER Charge Pipes
Appreciate 0
      02-14-2015, 11:54 PM   #22
JcLusso
i build cool shit
JcLusso's Avatar
United_States
483
Rep
656
Posts

Drives: 2018 Individual SMB F80 M3
Join Date: Mar 2011
Location: Long Island, New York

iTrader: (1)

Garage List
2018 BMW X5 M  [0.00]
2016 BMW i3  [0.00]
Quote:
Originally Posted by RyanMv4
Any update on this ? Same exact thing happened to me today
No idea. It went away after sometime and didn't return. When it would happen id power car off and then back on really fast and it would just go away. Sometimes would take a few on/off tries.
__________________
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:42 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST