E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Bimmerlabs 330i Tune DIY Step by Step



Reply
 
Thread Tools Search this Thread
      02-18-2021, 11:56 AM   #419
mattpete13
First Lieutenant
81
Rep
350
Posts

Drives: 2011 e91 6mt
Join Date: Oct 2014
Location: SE MA

iTrader: (2)

tried to install files from bimmergeeks and apparently will only work with windows NT and XP Pro are supported?

Does anyone have some insight?

I'm running windows 10 home.
Appreciate 0
      02-18-2021, 02:07 PM   #420
desertman123
E82 Mudflap Ambassador
desertman123's Avatar
United_States
2040
Rep
2,107
Posts

Drives: '08 128i
Join Date: May 2016
Location: Orlando, FL

iTrader: (0)

Garage List
2008 BMW 128i  [5.00]
2014 BMW 528i  [5.00]
Quote:
Originally Posted by mattpete13 View Post
tried to install files from bimmergeeks and apparently will only work with windows NT and XP Pro are supported?

Does anyone have some insight?

I'm running windows 10 home.
Run in compatibility mode. I've never flashed on any OS besides win10
__________________

My 2008 128i - Sparkling Graphite/Beige - Sport pkg - 6MT - Click me!
Parents' 2014 528i - Mineral White/Ivory White - fully loaded
Instagram @Andreys_128i
Appreciate 1
      03-06-2021, 02:01 PM   #421
mattpete13
First Lieutenant
81
Rep
350
Posts

Drives: 2011 e91 6mt
Join Date: Oct 2014
Location: SE MA

iTrader: (2)

been working on this for a few days, have gotten cable recognized by INPA but cannot get INPA to see that the ignition is on...

- the car should be in accessory mode and not actually running right?

what the hell am I missing?
Appreciate 0
      03-06-2021, 03:58 PM   #422
E92William
Banned
1946
Rep
2,026
Posts

Drives: 2008 E92 328xi
Join Date: Nov 2019
Location: Miami

iTrader: (0)

Garage List
2008 BMW 328xi  [0.00]
Quote:
Originally Posted by mattpete13 View Post
been working on this for a few days, have gotten cable recognized by INPA but cannot get INPA to see that the ignition is on...

- the car should be in accessory mode and not actually running right?

what the hell am I missing?
Should be in accessory mode aka button pressed with key in but no brake pedal. Your cable switch should be left i believe for e90. Check that you can use your cigarette lighter because it uses the same fuse as the obd connector
Appreciate 0
      03-06-2021, 08:45 PM   #423
bluewater328
Colonel
United_States
564
Rep
2,039
Posts

Drives: 2011 bluewater 328i LCI sedan
Join Date: Aug 2010
Location: Hawaii

iTrader: (0)

Quote:
Originally Posted by E92William View Post
Quote:
Originally Posted by mattpete13 View Post
been working on this for a few days, have gotten cable recognized by INPA but cannot get INPA to see that the ignition is on...

- the car should be in accessory mode and not actually running right?

what the hell am I missing?
Should be in accessory mode aka button pressed with key in but no brake pedal. Your cable switch should be left i believe for e90. Check that you can use your cigarette lighter because it uses the same fuse as the obd connector
E90 is to the right.

"E46, E39, E53, E38, E83 and anything older set the switch LEFT, for models such as E90, E60, E70, E88 and anything newer set the switch RIGHT, Ignore the middle position. "
Appreciate 1
      03-07-2021, 07:22 AM   #424
mattpete13
First Lieutenant
81
Rep
350
Posts

Drives: 2011 e91 6mt
Join Date: Oct 2014
Location: SE MA

iTrader: (2)

Quote:
Originally Posted by bluewater328 View Post
Quote:
Originally Posted by E92William View Post
Quote:
Originally Posted by mattpete13 View Post
been working on this for a few days, have gotten cable recognized by INPA but cannot get INPA to see that the ignition is on...

- the car should be in accessory mode and not actually running right?

what the hell am I missing?
Should be in accessory mode aka button pressed with key in but no brake pedal. Your cable switch should be left i believe for e90. Check that you can use your cigarette lighter because it uses the same fuse as the obd connector
E90 is to the right.

"E46, E39, E53, E38, E83 and anything older set the switch LEFT, for models such as E90, E60, E70, E88 and anything newer set the switch RIGHT, Ignore the middle position. "
Thanks guys.

Cigarette lighter works as I have my dash cam plugged into it. Maybe it should be unplugged?

Also my bimmergeeks cable has a button with two positions, in and out. No third position.

Yours all have switches?
Appreciate 0
      03-07-2021, 08:57 AM   #425
rjahl
Colonel
rjahl's Avatar
802
Rep
2,031
Posts

Drives: Z4 35is
Join Date: Jun 2011
Location: Tampa

iTrader: (0)

Garage List
2012 Z4 35is  [0.00]
Quote:
Originally Posted by mattpete13 View Post
been working on this for a few days, have gotten cable recognized by INPA but cannot get INPA to see that the ignition is on...

- the car should be in accessory mode and not actually running right?

what the hell am I missing?
Ignition should be on but not running if you trying to flash a module.
Appreciate 1
      03-08-2021, 11:39 AM   #426
mattpete13
First Lieutenant
81
Rep
350
Posts

Drives: 2011 e91 6mt
Join Date: Oct 2014
Location: SE MA

iTrader: (2)

Quote:
Originally Posted by rjahl View Post
Quote:
Originally Posted by mattpete13 View Post
been working on this for a few days, have gotten cable recognized by INPA but cannot get INPA to see that the ignition is on...

- the car should be in accessory mode and not actually running right?

what the hell am I missing?
Ignition should be on but not running if you trying to flash a module.
Tried that. Still won't recognize the car.

Should the switch on the cable be up or down?
Appreciate 0
      03-08-2021, 04:42 PM   #427
rjahl
Colonel
rjahl's Avatar
802
Rep
2,031
Posts

Drives: Z4 35is
Join Date: Jun 2011
Location: Tampa

iTrader: (0)

Garage List
2012 Z4 35is  [0.00]
Switch, don't really know about your cable/car set up. The switch is pretty simple, just jumps pin 7 & 8 on the ODB connector. nothing more. Hell, I added the switch on my first Cable. If I'm not mistaken older cars needed Pin 7 & 8 connected.

If "Up" does not work then try "down". Ignition should be on. If that does not work, you have a set up issue.

What ever you do, Resist the temptation to flash your modules until you have the communications 100% sorted.
Appreciate 1
      03-13-2021, 08:34 PM   #428
Savedamanualse90
Private First Class
Savedamanualse90's Avatar
United_States
15
Rep
113
Posts

Drives: 6spd n52
Join Date: Mar 2019
Location: Cebu

iTrader: (0)

Does anyone have a 330i tune with injen intake, afe header, o2 delete and secondary cat delete tune they can share or sell me, please! I have been trying to get a tune from bimmerlabs for months now but no response. I guess they're really busy. I need this tune ASAP, thank you! 2007 Bmw 6spd msv80.
__________________
If you can?t daily drive it, what?s the point. #savethemanuals
#NA
3IM AA PE eibach sportline with bilstein Megan rear arm kits AFE Headers and AFE mids euro intake m3 SSK JVC CarPlay.
Appreciate 0
      03-13-2021, 11:42 PM   #429
Mark963
Enlisted Member
United_States
17
Rep
49
Posts

Drives: 2011 328i
Join Date: Jun 2018
Location: Iowa

iTrader: (0)

Garage List
2011 BMW 328  [0.00]
If you're having trouble getting your pc/laptop to connect with the usb/OBD cable, make sure the com port settings are right in device manager, USB Serial Port, Port Settings, Advanced, - normally COM1 and and Latency TImer (ms): 1.
Appreciate 0
      03-13-2021, 11:46 PM   #430
Savedamanualse90
Private First Class
Savedamanualse90's Avatar
United_States
15
Rep
113
Posts

Drives: 6spd n52
Join Date: Mar 2019
Location: Cebu

iTrader: (0)

Quote:
Originally Posted by Mark963 View Post
If you're having trouble getting your pc/laptop to connect with the usb/OBD cable, make sure the com port settings are right in device manager, USB Serial Port, Port Settings, Advanced, - normally COM1 and and Latency TImer (ms): 1.
You also want to follow the steps correctly in the guide https://www.bimmerlabs.com/help
__________________
If you can?t daily drive it, what?s the point. #savethemanuals
#NA
3IM AA PE eibach sportline with bilstein Megan rear arm kits AFE Headers and AFE mids euro intake m3 SSK JVC CarPlay.
Appreciate 0
      03-15-2021, 06:53 AM   #431
Alexvier
New Member
Alexvier's Avatar
11
Rep
17
Posts

Drives: Crimson Red 325i M sport
Join Date: Jul 2020
Location: NZ

iTrader: (0)

What does it mean that there are 3 stock tunes.

Does it mean there's a little performance increase for the little n52b25 with 3SM?

Is it a 330 tune?

The n52b25 is really a highly tuned 323i, will it ever reach 330 territory?
Attached Images
 
__________________
Ultimate Driving Experience........
Appreciate 0
      03-15-2021, 05:48 PM   #432
Savedamanualse90
Private First Class
Savedamanualse90's Avatar
United_States
15
Rep
113
Posts

Drives: 6spd n52
Join Date: Mar 2019
Location: Cebu

iTrader: (0)

Quote:
Originally Posted by Alexvier View Post
What does it mean that there are 3 stock tunes.

Does it mean there's a little performance increase for the little n52b25 with 3SM?

Is it a 330 tune?

The n52b25 is really a highly tuned 323i, will it ever reach 330 territory?
I believe if you look at it closely the end of each file it's state each different transmission type. Example "smg". I could be wrong
__________________
If you can?t daily drive it, what?s the point. #savethemanuals
#NA
3IM AA PE eibach sportline with bilstein Megan rear arm kits AFE Headers and AFE mids euro intake m3 SSK JVC CarPlay.
Appreciate 0
      03-22-2021, 11:46 AM   #433
mattpete13
First Lieutenant
81
Rep
350
Posts

Drives: 2011 e91 6mt
Join Date: Oct 2014
Location: SE MA

iTrader: (2)

Anyone here want to remote code mine for me?

I just don't have the patience and am in way over my head. :
Appreciate 0
      03-22-2021, 09:17 PM   #434
eljay
Major
340
Rep
1,016
Posts

Drives: ///M + E91
Join Date: Jun 2010
Location: NS

iTrader: (1)

Are the Bimmerlabs files VIN-specific?
I flashed a friend's car with RSA Delete and that ran successfully, but we're getting an error trying to flash my files to his car. Both are MSV80 (2009 and 2011 MY). He is waiting for activation email from Bimmerlabs still, but we got impatient and used my files, which worked fine on my car.

Any ideas?

The car is obviously immobile after the RSA Delete.
Appreciate 0
      03-22-2021, 09:24 PM   #435
eljay
Major
340
Rep
1,016
Posts

Drives: ///M + E91
Join Date: Jun 2010
Location: NS

iTrader: (1)

Here's the error we're getting.

Can anyone help? It's late night and his car is now disabled.
Attached Images
 
Appreciate 0
      03-22-2021, 10:16 PM   #436
eljay
Major
340
Rep
1,016
Posts

Drives: ///M + E91
Join Date: Jun 2010
Location: NS

iTrader: (1)

OK, cancel the alarm. The battery voltage dropped too low as the charger seems faulty. Once we used boost cables from my car, the flash tune loaded fine and the car started! Yay! Another successful 3SIM conversion is roaming the streets.

Thanks everyone.
Appreciate 3
4 Doors557.50
Soup13.50
      03-23-2021, 07:38 AM   #437
Soup
New Member
14
Rep
5
Posts

Drives: E91
Join Date: Feb 2021
Location: Vancouver

iTrader: (0)

Huge thank you to eljay for the master assistance on my 3SIM installation (and E92William for rebuilding the large DISA in record time).

The first drive in the car last night after the tune was very telling - big improvement in drivability.
Appreciate 2
eljay339.50
4 Doors557.50
      03-23-2021, 07:47 AM   #438
eljay
Major
340
Rep
1,016
Posts

Drives: ///M + E91
Join Date: Jun 2010
Location: NS

iTrader: (1)

Just adding some helpful troubleshooting tips from our experience:

- Errors indicating 'Datatransmission disturbed' relate to cable setup. My cabke was fine, connected through INPA, but I discovered that because I switched to a different USB port on the laptop, the latency in the COM port settings switched back to default 16ms. It needs to be set to 1. After that correction, everything was fine.

- wipers going crazy and ignition not cycling properly etc. were indications of voltage dropping dangerously low as we've discovered. The batch showed the above error of ECU-Address. The car was connected to a charger, but it turned out to be faulty. When we switched to a good charger, it was too late as the voltage dropped to 6-7V. So, we used booster cables to connect to my car and flashed the tune that way with the other car running. It worked right away and took only a couple of minutes.
Appreciate 1
4 Doors557.50
      03-23-2021, 01:07 PM   #439
bluewater328
Colonel
United_States
564
Rep
2,039
Posts

Drives: 2011 bluewater 328i LCI sedan
Join Date: Aug 2010
Location: Hawaii

iTrader: (0)

Wipers going crazy isn't necessarily an indication of voltage drop. That happened to me and I was well within thresholds before/during/after (had a voltage regulator). Other stuff maybe.

Glad you're all sorted.
Appreciate 0
      03-24-2021, 12:02 AM   #440
JonOhh
Lieutenant
JonOhh's Avatar
United_States
520
Rep
593
Posts

Drives: 06' 330i
Join Date: Dec 2019
Location: Tuscaloosa, Alabama

iTrader: (0)

Garage List
Sorry if this was mentioned, I searched for but couldn't find it in the 20 pages before.

Is there a way to take a backup of my stock tune file before I flash the new one? I do want to be able to return the car 100% to stock, so I'd like to get a copy of it from the car before I flash it out of existence.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:50 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST