E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Cosmetic and Lighting Modifications (exterior/interior) > HID Fog Lights Work, But...



Reply
 
Thread Tools Search this Thread
      02-07-2017, 06:49 PM   #1
CTrink
Private First Class
CTrink's Avatar
20
Rep
109
Posts

Drives: 2006 330i
Join Date: Sep 2015
Location: Kent, OH

iTrader: (0)

Garage List
2006 BMW 330i  [0.00]
HID Fog Lights Work, But...

Just recently replaced my brake pads on my '06 e90 330i and while I had it on the rack I installed some HID fog lights (non CANBUS) since one bulb went out. Everything went fine, found a good mounting point and everything worked. Drove home in the dark and pulled into a gas station to check them out.

The drivers side (same that went out before HID) was out. Turned the car off and on, it worked. Both dogs were on. Got home (10 mins later) and it was out. Seemed like it would be on then go out after x amount of time.

Called the company (Alien's HID) and told them the problem. They asked that I switch the bulbs to see if it were the bulb or the ballast and they would replace it. I haven't had time yet, but the strange part is that the drivers side worked fine for two days and now it's back.

I coded out the error from the original bulb going out so I'm not sure if they are issuing a code. I'm interested to know if the ecu shuts off just one or both when it finds a problem before I put it back on the rack to switch them so I can just return them.

Last edited by CTrink; 02-09-2017 at 12:00 AM.
Appreciate 0
      02-09-2017, 01:13 PM   #2
Wilkz
Private First Class
23
Rep
109
Posts

Drives: n/a
Join Date: Mar 2015
Location: VA

iTrader: (1)

I have an 07 that had HID fogs when I got it. One would stay out for months and all of a sudden start working again. I could have them on and turn the car off, restart it right away and it would be out. Wait 5 minutes, restart again and it would come back.

I know the ECU will stop sending a signal to the headlight after 50 ignition cycles. I'm assuming it's the same for the fogs, but in your case since it's working and going out I don't think the ECU is the problem.

It may be pulling too much power/getting too hot and cutting off if they only stay on for 10 min then go out. Maybe check the wattage and how much the ballast are putting out? If it was the FRM/ECU, you would have probably had to reset it after it went out the first time.

The early model E90s apparently have more electrical problems than the later years. I ended up just pulling mine out and putting in regular bulbs for now. It was too much of a hassle trying to fix it for me.
Appreciate 0
      02-09-2017, 06:33 PM   #3
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
2715
Rep
58,716
Posts


Drives: C6 Z06, 09 335i, 10 335xi
Join Date: Dec 2008
Location: www.TopGearSolutions.com

iTrader: (37)

Intermittent on and off issues could be an indication of a bulb that is failing.

I honestly forget what happens when the fog lights error out since the ones we use are error free. I thought it would only shut of the failed side but I'm not 100% sure.

FYI it's fairly easy to access the fog lights, just turn the wheel in and undo a few bolts on the fender liner and peel it back. I install fog lights on locals cars in about 15-20 min.
__________________
|Like us on Facebook||Evolution Racewerks| |Active Autowerke| |ETS| |Burger Tuning| |PURE Turbos| |Mishimoto||VRSF| |AWE| |Wagner|

|Holiday Sales All December!| |KW| |Spec| |ST Coilovers| |Koni| |Bilstein| |Borla| |Magnaflow| |AFE| |Fabspeed| |Injen| Up to 10% Off!
Appreciate 0
      02-09-2017, 10:17 PM   #4
matteblue3er
Captain
169
Rep
816
Posts

Drives: Racecar
Join Date: Jul 2015
Location: Philly

iTrader: (0)

Most likely PWM issue. You can try coding to raise PWM duty cycle so voltage is higher.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:09 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST