E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Hesitation @ low RPM



Reply
 
Thread Tools Search this Thread
      02-28-2017, 08:58 PM   #89
E90joee
Captain
United_States
94
Rep
724
Posts

Drives: 2011 335i xdrive
Join Date: Feb 2013
Location: queens, ny

iTrader: (0)

Quote:
Originally Posted by TheAxiom View Post
Quote:
Originally Posted by BimmerGeeks View Post
Cool. Let me know if you need anything.
Thank you, I mean that.
About to part out and sell at this point
Appreciate 0
      03-01-2017, 12:00 AM   #90
BIMGE
1108
Rep
1,378
Posts

Drives: Bmw
Join Date: Feb 2017
Location: Atlanta

iTrader: (4)

Quote:
Originally Posted by E90joee View Post
About to part out and sell at this point
Stay strong!
Attached Images
 
Appreciate 1
      03-03-2017, 05:46 PM   #91
TurnersInOz
New Member
0
Rep
11
Posts

Drives: 2006 330i
Join Date: Jan 2017
Location: Sydney, AU

iTrader: (0)

Quote:
Originally Posted by PhaseP View Post
You may have fuel delivery problem pump or regulator. Fuel pressure measurement on the fuel rail may shed some light.
Thank you PhaseP, I'll see about getting that measured.
Appreciate 0
      06-07-2017, 01:57 PM   #92
DaanBMW
Captain
DaanBMW's Avatar
Romania
33
Rep
687
Posts

Drives: 2007 328i coupe
Join Date: Jun 2011
Location: Portland, OR

iTrader: (1)

Quote:
Originally Posted by PhaseP View Post
You may have fuel delivery problem pump or regulator. Fuel pressure measurement on the fuel rail may shed some light.
How do you do that on a moving car ? Since I've no symptoms at idle.
__________________
328i Sports Pkg, Michelin PSS on Staggered 18" OZ Ultraleggeras
. BMS Powerbox. Cyba scoops + Rev motoring intake hose + charcoal delete. Wavetrac LSD
. M3: subframe bushings + sways + control arms (fr & rr). Meyle rear toe arms. M3 diff fr bushings
. BMW Perf: v2 springs + v1 dampers. Valeo SMFW+clutch. 034 MotorSport engine mounts
. Short Shifter + Turner PU bearing + ECS Teflon bushings + ZHP M weighted shift knob. CDV delete
Appreciate 0
      07-17-2017, 03:32 PM   #93
chriscpmtmp
New Member
0
Rep
26
Posts

Drives: 2011 335d
Join Date: May 2017
Location: Michigan

iTrader: (0)

I read through this post. I think I have similar issues in my 2011 328 xdrive. I notice roughness when it starts, and some weird shifting. I didn't break it down as much as some others. I do think it clunks into reverse if the car is trying to find the idle after a cold start. We usually count to 10, then go. If not, it tends to clunk an pulsate.

I bought it as a CPO about 2 years ago with 53k. It has 70k now. At the end of the CPO I had them look at the issue. After a few NPFs, they replaced the ignition coils, but not the spark plugs. The spec for plugs is 60k. Seems cheap on their part.

This is normally my wife's car, but I've been driving it lately. I notice with the AC stopped at a light, the RPM went pretty low - near 500. I think the dealer set it super low for the transmission clunk. I bumped that up 100 overall.

Did anyone find an easy fix for this?
Appreciate 0
      08-13-2017, 07:02 PM   #94
chriscpmtmp
New Member
0
Rep
26
Posts

Drives: 2011 335d
Join Date: May 2017
Location: Michigan

iTrader: (0)

I did the plugs. Then increased the idle by 100. Not much luck.

It really runs like craps when it is cold. Then decent when it warms up. We literally count to 10 before driving away. Otherwise it like a small boat on rough water - rrrr .... rrrr .... rrrr ...

ouch.

Quote:
Originally Posted by chriscpmtmp View Post
I read through this post. I think I have similar issues in my 2011 328 xdrive. I notice roughness when it starts, and some weird shifting. I didn't break it down as much as some others. I do think it clunks into reverse if the car is trying to find the idle after a cold start. We usually count to 10, then go. If not, it tends to clunk an pulsate.

I bought it as a CPO about 2 years ago with 53k. It has 70k now. At the end of the CPO I had them look at the issue. After a few NPFs, they replaced the ignition coils, but not the spark plugs. The spec for plugs is 60k. Seems cheap on their part.

This is normally my wife's car, but I've been driving it lately. I notice with the AC stopped at a light, the RPM went pretty low - near 500. I think the dealer set it super low for the transmission clunk. I bumped that up 100 overall.

Did anyone find an easy fix for this?
Appreciate 0
      08-27-2017, 05:23 PM   #95
fleetfoot
New Member
8
Rep
10
Posts

Drives: 2013 E92 328i
Join Date: Apr 2013
Location: Atlanta,GA

iTrader: (0)

I had some of the same symptoms as many have described here:
1) random power "hiccups" at lower rpms (around 2-3k) in the first few minutes of driving a couple times each week
2) Uneven power delivery across the entire rev range
3) Rough idle
4) No CEL or engine codes to help with diagnosis
5) 70,000 on the odometer

I began by cleaning my MAF and VANOS solenoids, but they both looked clean and there wasn't any improvement after cleaning.

Next, I tried resetting my adaptive throttle, which also didn't improve things.

I finally started using my Automatic Car Adapter to start reading Short Term Fuel Rates and saw some symptoms indicating an ignition (spark plugs) problem. So I replaced all 6 plugs, which took me about 2 hours. The hardest part was getting the spark plug socket to stay on my socket extension, which I solved by putting a small square of theraband rubber on the end of the extension between it and socket. Then the socket stayed in place.

I just cranked her up and the idle was back to normal. Went for a drive and didn't have any hiccups. The power delivery also felt much smoother. I have the 3-stage intake manifold on my engine, and the transition felt much less abrupt than it had the past few months. It might be placebo effect, but I felt like I was able to shift smoother (manual) because the throttle was working better.

Lessons learned:
1) If you're at 65,000 miles on an N52, think about replacing the spark plugs
2) If you have a 3-stage intake manifold (with a tune), make sure you aren't applying heavy throttle at low rpms just because you have all that new torque at low rpms. I always thought I knew what "lugging" was and that I wasn't doing it, but looking back maybe I was. Apparently lugging can cause premature spark plug failure. So moral of the story is, if you're going to accelerate hard go ahead and downshift so you don't damage your spark plugs.

Hopefully this info is helpful to someone else! Feels good to have my buttery smooth straight 6 back
__________________
2013 E92 328i M-Sport: Black Sapphire Metallic, 6MT, BMW Performance Exhaust, 3-stage Intake Manifold, AA Tune, BMW Short Shifter, M Shift Knob, CDV Delete, Michelin Pilot Sport AS/3+, 35% Formula One Pinnacle Tint, OBDII Automatic Car Adapter
Maintenance Log http://www.motorlogbook.com/fleetfoot15/328E92
Appreciate 0
      08-29-2017, 06:24 AM   #96
Spitfire007
Lieutenant
Spitfire007's Avatar
95
Rep
567
Posts

Drives: 09 328i Sport 6MT
Join Date: Dec 2011
Location: Baltimore, MD

iTrader: (0)

Garage List
2009 BMW 328i  [0.00]
I just did plugs and coils, at 86000 miles. Solved my hesitation and rough idle issues, granted they were mild to begin with, but the hesitation was getting progressively worse.
Appreciate 0
      09-08-2017, 01:51 PM   #97
DaanBMW
Captain
DaanBMW's Avatar
Romania
33
Rep
687
Posts

Drives: 2007 328i coupe
Join Date: Jun 2011
Location: Portland, OR

iTrader: (1)

did plugs, coils, maf, solenoids, vvt motor, camshaft positioning sensors, vvt check valves. symptoms still there: hesitation/stumbling at starts or low rpms + the rpms drop badly when taken out of gear after coasting, at times killing the engine (with a/c on). puzzled by this beyond belief...
__________________
328i Sports Pkg, Michelin PSS on Staggered 18" OZ Ultraleggeras
. BMS Powerbox. Cyba scoops + Rev motoring intake hose + charcoal delete. Wavetrac LSD
. M3: subframe bushings + sways + control arms (fr & rr). Meyle rear toe arms. M3 diff fr bushings
. BMW Perf: v2 springs + v1 dampers. Valeo SMFW+clutch. 034 MotorSport engine mounts
. Short Shifter + Turner PU bearing + ECS Teflon bushings + ZHP M weighted shift knob. CDV delete

Last edited by DaanBMW; 09-21-2017 at 09:10 PM.
Appreciate 1
      09-18-2017, 12:42 PM   #98
archuzzi
New Member
Canada
0
Rep
5
Posts

Drives: e91 328i xDrive 2012
Join Date: Mar 2017
Location: Calgary, AB

iTrader: (0)

Quote:
Originally Posted by TheAxiom View Post
Thank you, I mean that.
Did you ever find a solution? Having the same issues you have described.
Appreciate 0
      09-21-2017, 05:18 PM   #99
archuzzi
New Member
Canada
0
Rep
5
Posts

Drives: e91 328i xDrive 2012
Join Date: Mar 2017
Location: Calgary, AB

iTrader: (0)

Eccentric Shaft Sensor

Coils and plugs not the issue so I took it to my independent for them to read it even though I wasn't getting any errors. The eccentric shaft sensor sent out 5 codes and was my issue, flooded with oil. Here is a DIY guide:

http://www.e90post.com/forums/showthread.php?t=697252

Appreciate 0
      03-28-2018, 12:46 PM   #100
gabrielh
New Member
2
Rep
8
Posts

Drives: 2011 Z4 3.0
Join Date: Sep 2017
Location: Florida

iTrader: (0)

Just to chime in, I had exact same issue than OP on my 2011 Z4 N52 3.0 engine 51k miles so I came across this thread. I replaced the spark plug and cleaned the VANOS Solenoid with brake cleaner and it's been running flawlessly since.
Appreciate 0
      04-11-2018, 07:05 AM   #101
major330i
New Member
0
Rep
9
Posts

Drives: bmw 330i e93 n53
Join Date: Apr 2018
Location: Berlin, Germany

iTrader: (0)

Hesitation at lower rpm

Hey Daan,

did you managed to solve the problem with the hesitation at lower rpm? I have exactly the same problem and also no fault codes stored. Would be nice to hear your status about fixing this.

best regards

Major

Quote:
Originally Posted by DaanBMW View Post
did plugs, coils, maf, solenoids, vvt motor, camshaft positioning sensors, vvt check valves. symptoms still there: hesitation/stumbling at starts or low rpms + the rpms drop badly when taken out of gear after coasting, at times killing the engine (with a/c on). puzzled by this beyond belief...
Appreciate 0
      04-11-2018, 04:45 PM   #102
DaanBMW
Captain
DaanBMW's Avatar
Romania
33
Rep
687
Posts

Drives: 2007 328i coupe
Join Date: Jun 2011
Location: Portland, OR

iTrader: (1)

Still not solved it. However during the colder season it's a bit better and it gets less noticeable.

List of parts swapped out: spark plugs, coils, maf, solenoids, vvt motor, camshaft positioning sensors, vvt check valves, fuel pump ECU.

Also cleaned throttle body.

Also all my software is the latest possible via INPA.
__________________
328i Sports Pkg, Michelin PSS on Staggered 18" OZ Ultraleggeras
. BMS Powerbox. Cyba scoops + Rev motoring intake hose + charcoal delete. Wavetrac LSD
. M3: subframe bushings + sways + control arms (fr & rr). Meyle rear toe arms. M3 diff fr bushings
. BMW Perf: v2 springs + v1 dampers. Valeo SMFW+clutch. 034 MotorSport engine mounts
. Short Shifter + Turner PU bearing + ECS Teflon bushings + ZHP M weighted shift knob. CDV delete

Last edited by DaanBMW; 04-11-2018 at 04:46 PM. Reason: clarif
Appreciate 0
      04-11-2018, 05:03 PM   #103
DaanBMW
Captain
DaanBMW's Avatar
Romania
33
Rep
687
Posts

Drives: 2007 328i coupe
Join Date: Jun 2011
Location: Portland, OR

iTrader: (1)

major330i: Just read your visitor message (seems no notifications for these msgs are received ?).

It's depressing... my really last card was replacing the fuel pump & relay. You listed fuel pump & filter, but not the relay.

No idea about EGR - was not on my list.

I don't have DISA valves mine is the 1 stg intake.
__________________
328i Sports Pkg, Michelin PSS on Staggered 18" OZ Ultraleggeras
. BMS Powerbox. Cyba scoops + Rev motoring intake hose + charcoal delete. Wavetrac LSD
. M3: subframe bushings + sways + control arms (fr & rr). Meyle rear toe arms. M3 diff fr bushings
. BMW Perf: v2 springs + v1 dampers. Valeo SMFW+clutch. 034 MotorSport engine mounts
. Short Shifter + Turner PU bearing + ECS Teflon bushings + ZHP M weighted shift knob. CDV delete
Appreciate 0
      04-12-2018, 05:56 PM   #104
major330i
New Member
0
Rep
9
Posts

Drives: bmw 330i e93 n53
Join Date: Apr 2018
Location: Berlin, Germany

iTrader: (0)

I have an n53.. there is just the disa left over and the egr valve. If you look at the symptoms the problem seems to appear when the car running with open egr valve.
I have Ista+ on my laptop (the original bmw Diagnose Software). When I check the my car there are no fault Codes so I did a couple of test modules. Only The test module „misfire detection“, which is specially developed to analyze misfires caused by coils, Injectors and spark plugs, detected misfires on cylinder 2. in the end of the test module Ista tells me to replace coil spark plug and injector on cylinder 2. the coils and spark plugs are completely new and all Injectors are index 11 and were installed half a year ago + coded. My Plan is to switch injector 2 (misfire cylinder) with another injector and repeat the test module. If the misfire appears on the other cylinder it must be the injector. Without Ista it’s all guesswork especially when there are no fault Codes stored. I will report if I manage to fix this problem.
Appreciate 0
      04-12-2018, 06:44 PM   #105
DaanBMW
Captain
DaanBMW's Avatar
Romania
33
Rep
687
Posts

Drives: 2007 328i coupe
Join Date: Jun 2011
Location: Portland, OR

iTrader: (1)

Quote:
Originally Posted by major330i View Post
I have an n53.. there is just the disa left over and the egr valve. If you look at the symptoms the problem seems to appear when the car running with open egr valve.
I have Ista+ on my laptop (the original bmw Diagnose Software). When I check the my car there are no fault Codes so I did a couple of test modules. Only The test module „misfire detection“, which is specially developed to analyze misfires caused by coils, Injectors and spark plugs, detected misfires on cylinder 2. in the end of the test module Ista tells me to replace coil spark plug and injector on cylinder 2. the coils and spark plugs are completely new and all Injectors are index 11 and were installed half a year ago + coded. My Plan is to switch injector 2 (misfire cylinder) with another injector and repeat the test module. If the misfire appears on the other cylinder it must be the injector. Without Ista it’s all guesswork especially when there are no fault Codes stored. I will report if I manage to fix this problem.
EGR... like I said I never researched it. Since mine doesn't have DISA it's low probability. What about the fuel relay ? although if you said the fuel filter you likely did the full kit incl. the relay - can you confirm ? (that'd be a good reference point for me) I read about some people installing an extra fuel filter instead of replacing the stock one in the kit.

My strong impression is that the VVT is causing it. The VVT activates only when car is warm, which is when I see the symptoms, not with the car cold (not sure if EGR does the same). I looked at disabling it but so far haven't found a way.

I only have INPA and I don't think it has such test modules, but have to check. I sure hope you get the injector to be the culprit, but from the sounds of it it's not highly likely.
__________________
328i Sports Pkg, Michelin PSS on Staggered 18" OZ Ultraleggeras
. BMS Powerbox. Cyba scoops + Rev motoring intake hose + charcoal delete. Wavetrac LSD
. M3: subframe bushings + sways + control arms (fr & rr). Meyle rear toe arms. M3 diff fr bushings
. BMW Perf: v2 springs + v1 dampers. Valeo SMFW+clutch. 034 MotorSport engine mounts
. Short Shifter + Turner PU bearing + ECS Teflon bushings + ZHP M weighted shift knob. CDV delete
Appreciate 0
      04-13-2018, 03:55 AM   #106
major330i
New Member
0
Rep
9
Posts

Drives: bmw 330i e93 n53
Join Date: Apr 2018
Location: Berlin, Germany

iTrader: (0)

i changed both parts which are under the backseat (the fuel pump, the second part is a filter which also includes the pressure control). Nothing changed! I had the same idea as you -> fuel relay! but.. there is no fuel relay.. the car has an control module for the fuel pump and regulates the fuel pump. So the relay is integrated in this module or there is no need for it. So i changed the control module (sits behind the backseat) and coded it. Nothing changed.

My car has no Valvetronic.. if we have exactly the same issue then the VVT and DISA shouldn't be the problem.
There just 5 options left.
1:air leaks (trottle Body sealing, egr sealing, vacuum hoses)
2.The Egr valve can't close properly (thinking about to deactivate the whole egr system)
3. Injector (because of the test module "misfire detection")
4. Problems with nox Sensor or catalytic converter (i have the secondary cats/ nox cats deleted)
5. Transmission problem (low oil level or bad torque converter)

The egr is closed while cold start. The car has to reach a certain cooling temperature until the egr starts to work. The egr works just in a special rpm range (i think 1000-2000). It could be that the egr can't close properly like it should so there could be a leak where exhaust gases enter the intake.

i read they changed allready your injectors. Which index have your injectors (this is important). Injectors with index under "11" had problems. But if they changed some injectos and replaced them with index "11" then all Injectors have to be index "11". It's not allowed to mix them up.. only if the injectors below index "11" can mixed up. A second point is that they have to be coded after replacing them. So this is also a point to check if ur not sure about it.
Appreciate 0
      04-13-2018, 08:51 AM   #107
PhaseP
Major
374
Rep
1,402
Posts

Drives: 325XI
Join Date: May 2010
Location: Earth

iTrader: (0)

You two are comparing different engines n52 and n53. N52 doesn’t use EGR, and doesn’t have direct fuel injectors. It uses port injection, low pressure injectors.
Appreciate 0
      04-15-2018, 10:03 PM   #108
DaanBMW
Captain
DaanBMW's Avatar
Romania
33
Rep
687
Posts

Drives: 2007 328i coupe
Join Date: Jun 2011
Location: Portland, OR

iTrader: (1)

I always thought an injector would manifest itself at more than this take-off/low speed hesitation, like issues at idle and/or at higher speeds. So I never tested anything injectors.

I just realized the N53 is direct injected... I would think it's not injector related given mine is port-injected.

And mine being a manual tranny in which I changed the oil 4 times in 40k miles, I doubt it's anything related to tranny.

Excellent to see more info about different attempts to solve this. I for one I'm still stumped...
__________________
328i Sports Pkg, Michelin PSS on Staggered 18" OZ Ultraleggeras
. BMS Powerbox. Cyba scoops + Rev motoring intake hose + charcoal delete. Wavetrac LSD
. M3: subframe bushings + sways + control arms (fr & rr). Meyle rear toe arms. M3 diff fr bushings
. BMW Perf: v2 springs + v1 dampers. Valeo SMFW+clutch. 034 MotorSport engine mounts
. Short Shifter + Turner PU bearing + ECS Teflon bushings + ZHP M weighted shift knob. CDV delete
Appreciate 0
      04-16-2018, 10:12 AM   #109
W37V
[Oo=||=oO]
No_Country
569
Rep
1,644
Posts

Drives: Car
Join Date: Aug 2014
Location: Location

iTrader: (0)

Quote:
Originally Posted by DaanBMW View Post
I always thought an injector would manifest itself at more than this take-off/low speed hesitation, like issues at idle and/or at higher speeds. So I never tested anything injectors.

I just realized the N53 is direct injected... I would think it's not injector related given mine is port-injected.

And mine being a manual tranny in which I changed the oil 4 times in 40k miles, I doubt it's anything related to tranny.

Excellent to see more info about different attempts to solve this. I for one I'm still stumped...
Silly question, but have you done a smoke test to see if you have any vacuum leaks? Vacuum leaks can lead to bad idle etc.

I didn’t bother to read it all, but have you tried swapping MAF and clean your throttle body?

Last edited by W37V; 04-16-2018 at 10:18 AM.
Appreciate 0
      04-16-2018, 05:50 PM   #110
major330i
New Member
0
Rep
9
Posts

Drives: bmw 330i e93 n53
Join Date: Apr 2018
Location: Berlin, Germany

iTrader: (0)

I have already changed the maf sensor and cleaned the throttle body and changed the sealing. The hesitation is still there. No smoke test done yet. That’s a good idea.
There are not many things left which can cause hesitation.
Disa, Injector, Agr valve, air leak.. but no fault Codes ?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:14 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST