E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Different issues with my E91 320D LCI



Reply
 
Thread Tools Search this Thread
      11-26-2020, 11:34 AM   #1
Dorco
New Member
Netherlands
1
Rep
10
Posts

Drives: BMW E91 320D
Join Date: Nov 2020
Location: Netherlands

iTrader: (0)

Different issues with my E91 320D LCI

Hi Guys,

Sorry for the long post, if you are not interested, start reading from the error log

I'm new here and plan to stay for a long time. I have a BMW E91 320D Automatic since 2,5 years now. It is imported from germany into the netherlands. Last year i ran into some serious issues with the car. While driving the car normally behind a truck (slowly) the engine quit working. Later turned out the gasket and the wall between two cilinder chambers was completely broken. Result was installing a another engine. My car was for 6 months at the garage, and it cost me a crap load of money.

During that same period i also got the AGM battery replaced for a 80Ah lead battery (my car doesn't support automatic start/stop). The garage told me they coded and registered the battery in de computer. But the car kept resetting my kilometer counter, date and time. Also it shows the "high discharge" error message so now and then. After looking this up i keep finding topics where they mention that the battery is not registered.
Now i finaly bought the Carly tool, and i finally figured out that indeed the battery was still registered as AGM 80Ah. I changed/coded and registered the correct battery (almost a year later). I haven't used the car much after i changed this, so i'll see the next days if this fixed the probelms of the resetting counters/date/time.

The car shows a message that the engine oil needs to be replaced, but since the engine is replaced last year, and i only drove it 3000km i don't think it is necessary to replace the oil. However it is somehow impossible to reset the oil maintenance! We (garage and myself) tried it manually and with the computer. Now i also tried it with Carly, and it just says "Failed".
I'm not sure what could be the issue, and the garage also doesn't know it. (he was guessing maybe the generator since there was an error message about a "generator" in the error log, but it would be trial and error for him to fix it. And i've got to pay all the attempts.)

There for i decided to buy the Carly adapter and abbo to see what the actual alarms are, and what i can do about it myself to safe a bit of money (and time without a car).

The following alarms turned up with Carly;

================================================

Health Status: Very Bad

Engine
Fault code: 004A07 Generator (layer BSD)
Fault code: 004A10 Bit-serial data interface BSD
Fault code: 004B37 Oil condition sensor (layer QLT)
Fault code: 004A27 Intelligent battery sensor (layer DIBS1)

Foot Well Module
Fault code: 009CC6 Hall sensor defective window passenger door / Heated side mirrors passenger side defective
Fault code: 009CC5 Hall sensor defective window driver door / Mirror heating driver's side defect

Junction Box Passenger Module
Fault code: 00A6CF Auc sensor


================================================


Based on the above messages i have to say that i don't see any problems with the seat heating.
Also the generator seems to be working, 12V when the engine is not running, and 14V when the engine is running.

Still i'm thinking that maybe there is something else in the generator that could cause this, is there a communication line with the generator, that could cause a lot of errors when it is disconnected?

All help is very very welcome! If anyone could help me to solve/look into any of these errors it would be very much appreciated!

Thanks in advance,

Last edited by Dorco; 11-26-2020 at 04:11 PM..
Appreciate 0
      11-27-2020, 04:25 AM   #2
Dorco
New Member
Netherlands
1
Rep
10
Posts

Drives: BMW E91 320D
Join Date: Nov 2020
Location: Netherlands

iTrader: (0)

anyone please?
Appreciate 0
      11-27-2020, 09:56 PM   #3
e91Owner
e91Owner
United_States
47
Rep
242
Posts

Drives: 2011 BMW 328i Wagon
Join Date: Mar 2018
Location: Charleston, SC

iTrader: (0)

Quote:
Originally Posted by Dorco View Post
anyone please?
Some of those faults look like stuff you get when changing a battery. Have you tried to clear the faults and see what comes back?

Sounds like your oil condition sensor might need replacing given that you have the 4B37 code and seemly incorrect CBS indications.
Appreciate 0
      11-28-2020, 03:06 PM   #4
Dorco
New Member
Netherlands
1
Rep
10
Posts

Drives: BMW E91 320D
Join Date: Nov 2020
Location: Netherlands

iTrader: (0)

I did some more research on the internet and saw this video about the BSD bus being down. Also it seems that the generator, the oil sensor and the IBS sensor are all on that bus... (all sensors that are in alarm) so probably one of them is messing up the communication. I want to disconnect the sensors one by one tomorrow to see if it restores the BSD bus.

Unfortunatly i donít have a scope to read the bus communication, so it will be some trial en error with carly scans i think. If someone has some other suggestion, please let me know
Appreciate 0
      11-28-2020, 07:30 PM   #5
e91Owner
e91Owner
United_States
47
Rep
242
Posts

Drives: 2011 BMW 328i Wagon
Join Date: Mar 2018
Location: Charleston, SC

iTrader: (0)

Quote:
Originally Posted by Dorco View Post
I did some more research on the internet and saw this video about the BSD bus being down. Also it seems that the generator, the oil sensor and the IBS sensor are all on that bus... (all sensors that are in alarm) so probably one of them is messing up the communication. I want to disconnect the sensors one by one tomorrow to see if it restores the BSD bus.

Unfortunatly i don’t have a scope to read the bus communication, so it will be some trial en error with carly scans i think. If someone has some other suggestion, please let me know
Just to confirm, you cleared the codes and then reran Carly to confirm that they still persist, correct?
Appreciate 0
      11-29-2020, 05:15 PM   #6
Dorco
New Member
Netherlands
1
Rep
10
Posts

Drives: BMW E91 320D
Join Date: Nov 2020
Location: Netherlands

iTrader: (0)

Yes i cleared the errors and ran another carly health check, they kept showing up.
Appreciate 0
      12-02-2020, 02:25 PM   #7
Dorco
New Member
Netherlands
1
Rep
10
Posts

Drives: BMW E91 320D
Join Date: Nov 2020
Location: Netherlands

iTrader: (0)

I opened a special thread for the BSD bus issue that i have, so it would be awesome if someone could assist me with that!

https://www.e90post.com/forums/showthread.php?t=1780067
__________________
Driving: BMW E91 320D LCI (N47) 2008
Appreciate 0
Reply

Bookmarks

Tags
bmw, e90, fault codes, generator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:37 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST