E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > Lean codes after battery death & replacement N55



Reply
 
Thread Tools Search this Thread
      03-14-2024, 09:21 AM   #1
vdwlkr
New Member
0
Rep
11
Posts

Drives: 2011 bmw 335xi
Join Date: Aug 2020
Location: Virginia

iTrader: (0)

Garage List
2011 BMW 335xi  [0.00]
Exclamation Lean codes after battery death & replacement N55

2011 335xi N55 MHD stage 2+ e30 blend AT
Data log: https://datazap.me/u/vdwlkr/2011-335...13-17-18-19-20

A few days ago, my battery died and I replaced with a new Diehard Plat AGM battery. The thing is, for the past 2 years the wrong battery was installed. My old AGM I bought the car with died in 2021, and being broke at the time, I bought a battery off FB marketplace. Being stupid, I was bamboozled into thinking it was an AGM by a fake label placed on the outside, but it was actually a diehard gold lead acid. Devious, and definitely tricked me. That being said, I assumed since it was an even swap, no coding or registration was necessary. The battery had continuous issues for the past year, and began dying a few weeks ago. Last week I jumped it, had it on trickle all week, and was welcomed to a dead battery a few days ago. Jumping wouldn't revive it this time, so I went off and got the new one. Coded to 70ah AGM in BimmerCode & registered it on MHD.

I took the car for 3 drives before I got an SES.
Active codes: 2BC0 Mixture control, fuel air mixture too lean - 36FD DME main relay, plausibility, prematurely dropped out - 387C Power management, battery total discharge - 3887 vehicle voltage, working area: voltage too low. The battery codes are likely from when the old one died, as I didn't clear the codes since; but the mixture control one was new.

Shadow codes: 2C42 Mixture control, multiple fault - 2D45 Valvetronic, adjustment range, stop not taught in due to ambient conditions

Driving, I can see small spikes in the AFR from 14.7 to 16.2 occasionally at bumper-to-bumper traffic speeds (thanks DC). WOT pulls hard initially, but felt like it tapered off weirdly - which is evident in the low peak boost numbers. On other less-formal autologs I hit 18PSI, but typically I see 21 at max. Idle feels good, WOT just feels a little weak on the upper-range, slow driving is intermittently sluggish and choppy.

Any ideas on where to start here? Planning to clean MAF & MAP tonight, and have heard fuel rail sensor & HPFP sensor can cause this.
Appreciate 0
Reply

Bookmarks

Tags
335i, datalog, n55

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:16 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST