E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Car starting then dying



Reply
 
Thread Tools Search this Thread
      10-26-2020, 06:57 PM   #1
TedIsBoosted
New Member
1
Rep
15
Posts

Drives: 335i
Join Date: Jan 2020
Location: UK

iTrader: (0)

Car starting then dying

Hey everyone. Having a bit of a nightmare.

I installed my stage 2 LPFP around 3 days ago. After install I took it out and got some great logs. Everything seemed perfect. Had to recode the EKPM3 to the Brazilian X1 or X3 I believe (Ethanol) pump allows no fuel pump plausibility, anyways.

I left the car for a full day and the next day, I got in started fine, idled fine.

The car felt like it was misfiring so I quickly pulled over plugged the MHD adapter in, didn’t see anything popup and continued. After about 3 seconds of driving it just cut. Absolutely no power etc. When I tried to restart it would switch on then die. At the time I got the error codes :
29DC (Cylinder injection cutout)
29F3 (Low pressure sensor, electric)
2BA2 (Terminal 15 deactivation, activation) this one I have had for a while. And happened after I unplugged vacuum from Actuator on the exhaust.

Anyways I managed to get it home via a tow truck. And then Everytime I start it it dies. Even if I apply throttle it builds pressure in the HPFP to even 2,000 PSI but still cuts out.
The current codes I get are:

Active
2BA2 (Terminal 15)

Shadow

2FCA (Fuel high pressure being Freigabe Der Einspritzung)
2FDA (Crankshaft sensor signal missing)

I did notice the other day my LPFP sensor was acting up and was stuck on 140 PSI.

I will attach some graphs and videos etc.

I ordered a new HPFP sensor, LPFP sensor with rail (new revision) and a Crankshaft sensor.

Would any of these things cause these issues ? Or has anyone else had a similar issue ?

Click this text for a video of what happens
(In the video I apply throttle and with the log attached the HPFP hits 2,000 psi)


Click here for first log

Click here for second log

Many thanks for any help!
Appreciate 0
      10-27-2020, 10:59 AM   #2
TedIsBoosted
New Member
1
Rep
15
Posts

Drives: 335i
Join Date: Jan 2020
Location: UK

iTrader: (0)

Changed fuse F76. Car started and then died again with crankshaft code around about the same time it died last time.
Appreciate 0
      10-27-2020, 12:51 PM   #3
Jeff@TopGearSolutions
Jeff@TopGearSolutions's Avatar
United_States
3442
Rep
79,211
Posts

Drives: C6 Z06, 09 335i, 10 335xi
Join Date: Dec 2008
Location: www.TopGearSolutions.com

iTrader: (37)

Likely crankshaft sensor. Not a bad idea to get everything fresh on the fuel side. Without a good crank signal, the car won't run.
Appreciate 0
      10-28-2020, 09:52 AM   #4
TedIsBoosted
New Member
1
Rep
15
Posts

Drives: 335i
Join Date: Jan 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by Jeff@TopGearSolutions View Post
Likely crankshaft sensor. Not a bad idea to get everything fresh on the fuel side. Without a good crank signal, the car won't run.
Replaced sensor. Car just cranks with no start.

Getting DME : Terminal 15 deactivation, activation
CAS : Engine start, starter operation.

Any ideas ?
Appreciate 0
      10-28-2020, 05:58 PM   #5
BSM n54iS
Brigadier General
BSM n54iS's Avatar
2685
Rep
4,203
Posts

Drives: '11 335is | '16 Macan Turbo
Join Date: Aug 2015
Location: Everywhere and Nowhere

iTrader: (7)

Do you have a proper log where you stay wot through 6.5k rpm in 3rd?
__________________
'11 335is BSM MT "BMW Performance Editon" | '16 Porsche Macan Turbo
GruppeM CF Intake | AR Resonated DP | ER CP | Turbosmart RacePort BOV | Cobb FMIC | RB Inlets | RB External Mishi/Turner OCC | Michelin PS4 | BMW Performance Springs/Bilstein B8 + Dinan & M3 bits | BMW Brembo BBK | BMW Performance CF Spoiler | BMW Performance CF Lip | BMW Performance Alcantara | PS Designs GTS Armrest | AG H6-40 | Rear Seat Delete
Appreciate 0
      10-28-2020, 08:47 PM   #6
TedIsBoosted
New Member
1
Rep
15
Posts

Drives: 335i
Join Date: Jan 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by BdSM n54iS View Post
Do you have a proper log where you stay wot through 6.5k rpm in 3rd?
I mean considering the car won’t even idle, unfortunately not.

The HPFP has failed. If idle and apply throttle HIGH PRESSURE RAIL plummets
Appreciate 0
      10-31-2020, 06:40 AM   #7
Saif2018
Brigadier General
973
Rep
3,219
Posts

Drives: E90 335i
Join Date: Jan 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by Tedbuildiy View Post
Replaced sensor. Car just cranks with no start.

Getting DME : Terminal 15 deactivation, activation
CAS : Engine start, starter operation.

Any ideas ?
Have a read through this thread...

https://www.e90post.com/forums/showthread.php?t=1307503

Might be helpful in ruling out the starter motor,
Appreciate 0
      11-01-2020, 12:57 AM   #8
Lesssgedittt
Registered
0
Rep
2
Posts

Drives: 2011 335i
Join Date: Nov 2020
Location: bakersfield ca

iTrader: (0)

me too

i have the same issue
Appreciate 0
      11-01-2020, 10:01 AM   #9
feuer
Major General
feuer's Avatar
United_States
4277
Rep
9,209
Posts

Drives: wife crazy!
Join Date: Apr 2015
Location: Chicago, IL

iTrader: (5)

Quote:
Originally Posted by BdSM n54iS View Post
Do you have a proper log where you stay wot through 6.5k rpm in 3rd?
Appreciate 0
      11-01-2020, 10:54 AM   #10
BSM n54iS
Brigadier General
BSM n54iS's Avatar
2685
Rep
4,203
Posts

Drives: '11 335is | '16 Macan Turbo
Join Date: Aug 2015
Location: Everywhere and Nowhere

iTrader: (7)

GEE was this the first log the OP EVER TOOK?? Like, I dunno, maybe he has a log taken BEFORE the issue so we could see that his hpfp was dying and on it's way out?
__________________
'11 335is BSM MT "BMW Performance Editon" | '16 Porsche Macan Turbo
GruppeM CF Intake | AR Resonated DP | ER CP | Turbosmart RacePort BOV | Cobb FMIC | RB Inlets | RB External Mishi/Turner OCC | Michelin PS4 | BMW Performance Springs/Bilstein B8 + Dinan & M3 bits | BMW Brembo BBK | BMW Performance CF Spoiler | BMW Performance CF Lip | BMW Performance Alcantara | PS Designs GTS Armrest | AG H6-40 | Rear Seat Delete
Appreciate 0
      03-04-2021, 02:19 PM   #11
TedIsBoosted
New Member
1
Rep
15
Posts

Drives: 335i
Join Date: Jan 2020
Location: UK

iTrader: (0)

Just here now, forgot to reply. The LPFP Sensor was mimicking HPFP failure, so I replaced the LPFP sensor and it worked.
Appreciate 0
      03-04-2021, 03:14 PM   #12
Saif2018
Brigadier General
973
Rep
3,219
Posts

Drives: E90 335i
Join Date: Jan 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by TedIsBoosted View Post
Just here now, forgot to reply. The LPFP Sensor was mimicking HPFP failure, so I replaced the LPFP sensor and it worked.
Just the LPFP that failed?

HPFP was ok?
Appreciate 0
Reply

Bookmarks

Tags
crankshaft, die, failure, hpfp, stall

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:02 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST