E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > E91 320D DDE error code 4B4D



Reply
 
Thread Tools Search this Thread
      01-29-2019, 12:59 PM   #1
garysmith21
New Member
0
Rep
14
Posts

Drives: 2008 E91 320D M Sport
Join Date: Dec 2018
Location: UK

iTrader: (0)

E91 320D DDE error code 4B4D

Hi all,

Before Xmas my DDE died (one of the PCB components was literally fried) and so I sent it away with my CAS and a key and a replacement DDE paired to my CAS and key was returned.

Installed these in the car and everything worked perfectly. Until I tried the cruise control which was non-responsive.

Using INPA I got the error code 4B4D: Message (torque request, active steering, 0xB1) faulty, receiver DDE, transmitter Active Steering.

Not sure if this is what's stopping the cruise control working but I'd like to get it cleared to rule it out.

Only problem is my car doesn't have Active Steering. So why is my (new) DDE expecting a message from an Active Steering module that doesn't exist in my car?

Any ideas anyone??
Appreciate 0
      01-29-2019, 03:17 PM   #2
Sensible_
Colonel
426
Rep
2,459
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Was the new DDE coded to your car?
Appreciate 0
      01-29-2019, 03:22 PM   #3
garysmith21
New Member
0
Rep
14
Posts

Drives: 2008 E91 320D M Sport
Join Date: Dec 2018
Location: UK

iTrader: (0)

Yes it was. Shows the same VIN as all other modules in car.
Appreciate 0
      01-29-2019, 04:31 PM   #4
Sensible_
Colonel
426
Rep
2,459
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Ok, if you are sure that's fine. Just people sometimes forget to code with NCS Expert. Maybe try update with winkfp and code to your FA again.

Also, are you sure the current zusb is qualified for your car and not slightly different for another vehicle? Find the number in the UIF section if INPA.
Appreciate 0
      01-29-2019, 04:52 PM   #5
garysmith21
New Member
0
Rep
14
Posts

Drives: 2008 E91 320D M Sport
Join Date: Dec 2018
Location: UK

iTrader: (0)

I've already done that myself with the latest Datens and it hasn't made any difference.

I'd also taken copies of the codes in each module before the DDE was changed and every single line matches with what it is now.

I've also used INPA to check that everything the cruise control needs to work properly is working - brake switch, clutch switch, cruise control stalk, steering angle sensor, wheel speed sensors - all of it is functioning properly.

I just can't figure out why the DDE is throwing out this code for not receiving a message from a module that doesn't exist.

ISTA's test plan tells me to look at wiring and fuses etc but how can I check wiring and fuses for a module that isn't there?!
Appreciate 0
      01-29-2019, 04:57 PM   #6
garysmith21
New Member
0
Rep
14
Posts

Drives: 2008 E91 320D M Sport
Join Date: Dec 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by Sensible_ View Post
Ok, if you are sure that's fine. Just people sometimes forget to code with NCS Expert. Maybe try update with winkfp and code to your FA again.

Also, are you sure the current zusb is qualified for your car and not slightly different for another vehicle? Find the number in the UIF section if INPA.
Sorry missed this - I'd taken a UIF download before the DDE went faulty and the ZUSB number is the same then as it is now so that looks fine also.
Appreciate 0
      01-30-2019, 12:53 AM   #7
Sensible_
Colonel
426
Rep
2,459
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Ok, is it definitely your original CAS? Have you checked the FA in the CAS matches your one in FRM and that option 217 doesn't appear in the FA.
Appreciate 0
      01-30-2019, 03:16 AM   #8
garysmith21
New Member
0
Rep
14
Posts

Drives: 2008 E91 320D M Sport
Join Date: Dec 2018
Location: UK

iTrader: (0)

Definitely original CAS and the FA matches now what it did before. No $217 anywhere.
Appreciate 0
      01-30-2019, 03:30 AM   #9
Sensible_
Colonel
426
Rep
2,459
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Ok, have you reset all adaptations? Including learned values? (varianten_loschen job in tool32 for your engine ecu).
Appreciate 0
      01-30-2019, 07:23 AM   #10
garysmith21
New Member
0
Rep
14
Posts

Drives: 2008 E91 320D M Sport
Join Date: Dec 2018
Location: UK

iTrader: (0)

No I haven't done that.

For my ECU (D71N47A0) I don't get 'varianten_loschen', the closest I can see are:
loeschen_dcc_variante
loeschen_kli_fgr_variante

Is it one of those?
Appreciate 0
      01-30-2019, 08:57 AM   #11
Sensible_
Colonel
426
Rep
2,459
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Quote:
Originally Posted by garysmith21 View Post
No I haven't done that.

For my ECU (D71N47A0) I don't get 'varianten_loschen', the closest I can see are:
loeschen_dcc_variante
loeschen_kli_fgr_variante

Is it one of those?
I'm not sure to be honest. The DCC one clears the cruise control I think.

Look in INPA. Do you have: status analog/digital -> digital value -> car equipment ->reset

Or gelernte varienten? Try those first.
Appreciate 1
      01-30-2019, 01:02 PM   #12
garysmith21
New Member
0
Rep
14
Posts

Drives: 2008 E91 320D M Sport
Join Date: Dec 2018
Location: UK

iTrader: (0)

Done. Error gone. Cruise control working.

Thanks!
Appreciate 0
      01-30-2019, 01:38 PM   #13
Sensible_
Colonel
426
Rep
2,459
Posts

Drives: 2008 E90
Join Date: Feb 2012
Location: London

iTrader: (1)

Quote:
Originally Posted by garysmith21 View Post
Done. Error gone. Cruise control working.

Thanks!
Just confirm you did it by resetting learned values? Or something else?
Appreciate 0
      01-30-2019, 02:05 PM   #14
garysmith21
New Member
0
Rep
14
Posts

Drives: 2008 E91 320D M Sport
Join Date: Dec 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by Sensible_ View Post
Just confirm you did it by resetting learned values? Or something else?
Yes exactly that.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:13 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST