E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > MHD Flasher for N54 - general discussion



Reply
 
Thread Tools Search this Thread
      07-25-2019, 04:40 AM   #12123
studio54
Second Lieutenant
34
Rep
239
Posts

Drives: n54 135
Join Date: Feb 2017
Location: belgium

iTrader: (0)

Quote:
Originally Posted by GovernUrMental View Post
I had the very same issue and i emailed mhd about this issue, Their reply below.

"start the flash, pull the cable after 2%, then install MHD back on (full flash)"
Also found this trick online, from MHD too :

"yes, after the BMS canned US flash, your car is "configured" as a US car. Here's a trick to get back to Euro spec for the MHD maps. Start a flash (any map), unplug the cable after the progression is > 0%. Turn off ignition, on again and flash completely this time using the map recovery (2mins) option."

Just something i don't get it, will it work with a 2 minutes recovery flash like said above ? or does it need a full long write?

(a 2 minutes one would be great )
Appreciate 0
      07-25-2019, 12:41 PM   #12124
SJ_1989
Private First Class
SJ_1989's Avatar
United_States
24
Rep
120
Posts

Drives: '08 335i
Join Date: Mar 2012
Location: Illinoisssss

iTrader: (4)

*cough* anti-lag *cough*

__________________
E90 335i 6MT soon to be drag car

📸 Follow my drag build on Instagram: Click here 🙏
🚧 Check out my drag build thread: Click here 🚧
Appreciate 0
      07-28-2019, 11:37 AM   #12125
nb335i
Private First Class
nb335i's Avatar
12
Rep
142
Posts

Drives: 07' 335i
Join Date: May 2014
Location: HI

iTrader: (0)

Quote:
Originally Posted by tylerboland01 View Post
Is anyone having trouble with Samsung's s10+ OTG usb? Recently upgraded and now I can't get MHD or protool to connect.
I have the s10+ and having issues as well. Did you happen to resolve this?
Appreciate 0
      07-28-2019, 01:06 PM   #12126
RealJ22
Second Lieutenant
RealJ22's Avatar
110
Rep
211
Posts

Drives: E90 N52, E92 N54, CT200h Prius
Join Date: Mar 2019
Location: WI / AZ

iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
I'm going to be going MHD on my Stock 335i this week. Only thing it has currently is Muffler delete. Charge pipe will be going on BEFORE the tune though.

Car feels really healthy already. Hopefully a few more PSI will put a smile on my face
Appreciate 0
      07-31-2019, 02:34 AM   #12127
Fallenangel123
Private
2
Rep
63
Posts

Drives: Z4 35is DCT
Join Date: Oct 2017
Location: UK

iTrader: (0)

Any news on the 8.1 map updates?
Appreciate 0
      07-31-2019, 09:40 PM   #12128
SixBanger
Captain
108
Rep
652
Posts

Drives: 08 135i
Join Date: Apr 2005

iTrader: (0)

Is MHD done with us?
Appreciate 0
      08-01-2019, 06:42 PM   #12129
roadkillrob
Major General
United_States
586
Rep
5,125
Posts

Drives: 08 335i,19 X5 35i,14 C63 AMG
Join Date: Jul 2007
Location: Boston

iTrader: (15)

Quote:
Originally Posted by SixBanger View Post
Is MHD done with us?
Their last post in this thread was 4 months ago, so seems like we certainly are not a priority anymore.
__________________
2019 X540i Phytonic Blue M-Sport
2008 E93 335i FBO
2014 Mercedes C63 507 Edition
Appreciate 0
      08-02-2019, 12:59 PM   #12130
JunkyardDogg
Lieutenant
33
Rep
516
Posts

Drives: E92 BSM 335is
Join Date: Dec 2012
Location: Jersey

iTrader: (0)

Hey guys, quick question regarding upgrading FMIC. I was on MHD Stage 1 93 on my stock intercooler. Yesterday I had a G-Plus intercooler installed (amazon). I didn't re-tune yet. But now I get popping burble noises when I get above 4000 rpms, mainly 3rd and 4th gear (i have manual). But I cant tell if its coming from the exhaust or under the car? I haven't done anything but swapped out to a bigger intercooler. Is this normal?
Appreciate 0
      08-02-2019, 09:03 PM   #12131
roadkillrob
Major General
United_States
586
Rep
5,125
Posts

Drives: 08 335i,19 X5 35i,14 C63 AMG
Join Date: Jul 2007
Location: Boston

iTrader: (15)

Quote:
Originally Posted by JunkyardDogg View Post
Hey guys, quick question regarding upgrading FMIC. I was on MHD Stage 1 93 on my stock intercooler. Yesterday I had a G-Plus intercooler installed (amazon). I didn't re-tune yet. But now I get popping burble noises when I get above 4000 rpms, mainly 3rd and 4th gear (i have manual). But I cant tell if its coming from the exhaust or under the car? I haven't done anything but swapped out to a bigger intercooler. Is this normal?
Way not normal should be no difference and run like it did before. Guess would be itís leaking causing the noise but video of the sound would help.
__________________
2019 X540i Phytonic Blue M-Sport
2008 E93 335i FBO
2014 Mercedes C63 507 Edition
Appreciate 0
      08-03-2019, 10:35 AM   #12132
JunkyardDogg
Lieutenant
33
Rep
516
Posts

Drives: E92 BSM 335is
Join Date: Dec 2012
Location: Jersey

iTrader: (0)

Quote:
Originally Posted by roadkillrob View Post
Way not normal should be no difference and run like it did before. Guess would be itís leaking causing the noise but video of the sound would help.
But wuoldn't leaking also cause power loss? I tried recording with my phone but the sound wasn't captured well. I'll try to get another one with a better mic.
Appreciate 0
      08-03-2019, 01:13 PM   #12133
roadkillrob
Major General
United_States
586
Rep
5,125
Posts

Drives: 08 335i,19 X5 35i,14 C63 AMG
Join Date: Jul 2007
Location: Boston

iTrader: (15)

Quote:
Originally Posted by JunkyardDogg View Post
But wuoldn't leaking also cause power loss? I tried recording with my phone but the sound wasn't captured well. I'll try to get another one with a better mic.
depends on the leak if bad enough it should and should also get you a 30ff code, so may be a minor leak but at 15psi it could make some odd noises - hard to tell though without a sound clip. If you did nothing but the intercooler, there should be no change at all in noise, so something would seem wrong and related to the IC install and about all that can go wrong with that is a leak in the IC or in the connections.
__________________
2019 X540i Phytonic Blue M-Sport
2008 E93 335i FBO
2014 Mercedes C63 507 Edition
Appreciate 0
      08-13-2019, 01:42 PM   #12134
studio54
Second Lieutenant
34
Rep
239
Posts

Drives: n54 135
Join Date: Feb 2017
Location: belgium

iTrader: (0)

Quote:
Originally Posted by studio54 View Post
Also found this trick online, from MHD too :

"yes, after the BMS canned US flash, your car is "configured" as a US car. Here's a trick to get back to Euro spec for the MHD maps. Start a flash (any map), unplug the cable after the progression is > 0%. Turn off ignition, on again and flash completely this time using the map recovery (2mins) option."

Just something i don't get it, will it work with a 2 minutes recovery flash like said above ? or does it need a full long write?

(a 2 minutes one would be great )
So i did the test, and i can confirm that a full write is not needed.

A 2 minutes "retry failed flash" is ok.

Start a flash, unplug once it's > 0%, ignition off, ignition on, replug, start the same flash, it should now have the "retry failed flash" 2 minutes options.

I was afraid to have to make a full write, and finally 2 minutes from a retry is OK to get rid of the 2A18 2A13 DMTL codes on EU car.
Appreciate 0
      08-13-2019, 02:05 PM   #12135
riczon.335i
Second Lieutenant
riczon.335i's Avatar
United_States
30
Rep
200
Posts

Drives: 2007 BMW 335i Coupe
Join Date: Aug 2014
Location: Kennewick, WA

iTrader: (1)

Quote:
Originally Posted by SixBanger View Post
Is MHD done with us?
Just get a custom tune. I gave up on waiting they are too occupied with the new platforms anyways, it is what it is.
Appreciate 0
      08-14-2019, 06:18 PM   #12136
SixBanger
Captain
108
Rep
652
Posts

Drives: 08 135i
Join Date: Apr 2005

iTrader: (0)

Quote:
Originally Posted by riczon.335i View Post
Just get a custom tune. I gave up on waiting they are too occupied with the new platforms anyways, it is what it is.
I did that years ago, I just wanted new options..
Appreciate 1
      08-15-2019, 06:12 AM   #12137
NoGuru
Captain
NoGuru's Avatar
255
Rep
690
Posts

Drives: 335is
Join Date: Apr 2017
Location: MI

iTrader: (0)

Garage List
2002 Jeep Cherokee  [0.00]
2014 CTS  [0.00]
2011 335is  [0.00]
Quote:
Originally Posted by SixBanger View Post
I did that years ago, I just wanted new options..
Yeah, I am surprised they have not added inlets to there tune yet.
__________________
2011 335is BQ Tune / BMS CAI / VRSF kittyless DP's / Synapse BOV and charge pipe / 5" ETS FMIC / Stage 2 bucketless / Motive Flex Fuel / Vwetish Diff Brace / 15mm spacers in rear / Arkym front lip/PR coils / Tires PSS 4S's / Relocation Inlets
Appreciate 0
      08-17-2019, 07:31 AM   #12138
cheddle
New Member
Australia
0
Rep
8
Posts

Drives: '07 BMW E90 335i
Join Date: Aug 2019
Location: Tasmania, Aus

iTrader: (0)

Hey E90 drivers! I have just flashed V8 stage 1 (93/98 oct) to my otherwise stock 2007 e90 335i N54 6AT - and I am really liking the extra power :-)

Flashing took a while with about a dozen failures... I used a battery charger the whole time however in the end I needed to hook up another car that was running via jumper leads in order to successfully flash! peak anxiety for sure.

I'm thinking of going for xHp next however I am having an issue I cant seem to find much mention of via search.

Twice now (out of about a half dozen times) when flooring the car off the line (with a small bit of wheelspin) the car fails to shift into 2nd gear and instead hits the rev limiter for a moment (at least until I release the throttle and mash the paddle shifter) the car remains in 1st gear bashing the rev limiter. This never happened prior to the MHD flash. It has happened once in 'DS' mode and once in manual mode.

Any advice as to what I can do to avoid this problem? should I try to flash xHp to solve the issue or should I try a different version of MHD map?

Also, is it possible to go between v8 and v7 without doing a full-write?

thanks :-)
Appreciate 0
      08-17-2019, 03:56 PM   #12139
Silent11N54
Lieutenant
Canada
288
Rep
595
Posts

Drives: 2007 E92 335i
Join Date: Jul 2017
Location: Vancouver, Canada

iTrader: (0)

Quote:
Originally Posted by cheddle View Post
Hey E90 drivers! I have just flashed V8 stage 1 (93/98 oct) to my otherwise stock 2007 e90 335i N54 6AT - and I am really liking the extra power :-)

Flashing took a while with about a dozen failures... I used a battery charger the whole time however in the end I needed to hook up another car that was running via jumper leads in order to successfully flash! peak anxiety for sure.

I'm thinking of going for xHp next however I am having an issue I cant seem to find much mention of via search.

Twice now (out of about a half dozen times) when flooring the car off the line (with a small bit of wheelspin) the car fails to shift into 2nd gear and instead hits the rev limiter for a moment (at least until I release the throttle and mash the paddle shifter) the car remains in 1st gear bashing the rev limiter. This never happened prior to the MHD flash. It has happened once in 'DS' mode and once in manual mode.

Any advice as to what I can do to avoid this problem? should I try to flash xHp to solve the issue or should I try a different version of MHD map?

Also, is it possible to go between v8 and v7 without doing a full-write?

thanks :-)
changing maps takes 1-2 mins .. only the initial flash takes a long time
Appreciate 0
      08-21-2019, 11:28 PM   #12140
KrazyKiwi
Registered
New Zealand
0
Rep
4
Posts

Drives: 07 335i
Join Date: Aug 2019
Location: Auckland, NZ

iTrader: (0)

Ive just installed MHD stage 1 and i get alot of wastegate rattle on idle and deacceleration between 2-5krpm. Ive tried using the MHD wastegate fix and it has made no difference

However on stock and the MHD stage 0 flash i get zero wastegate noise.
Is this a common issue?
Appreciate 0
      08-22-2019, 07:25 AM   #12141
NoGuru
Captain
NoGuru's Avatar
255
Rep
690
Posts

Drives: 335is
Join Date: Apr 2017
Location: MI

iTrader: (0)

Garage List
2002 Jeep Cherokee  [0.00]
2014 CTS  [0.00]
2011 335is  [0.00]
Quote:
Originally Posted by KrazyKiwi View Post
Ive just installed MHD stage 1 and i get alot of wastegate rattle on idle and deacceleration between 2-5krpm. Ive tried using the MHD wastegate fix and it has made no difference

However on stock and the MHD stage 0 flash i get zero wastegate noise.
Is this a common issue?
Yep, Stage 0 is stock so that would make sense.
__________________
2011 335is BQ Tune / BMS CAI / VRSF kittyless DP's / Synapse BOV and charge pipe / 5" ETS FMIC / Stage 2 bucketless / Motive Flex Fuel / Vwetish Diff Brace / 15mm spacers in rear / Arkym front lip/PR coils / Tires PSS 4S's / Relocation Inlets
Appreciate 0
      08-22-2019, 10:57 AM   #12142
riczon.335i
Second Lieutenant
riczon.335i's Avatar
United_States
30
Rep
200
Posts

Drives: 2007 BMW 335i Coupe
Join Date: Aug 2014
Location: Kennewick, WA

iTrader: (1)

Quote:
Originally Posted by KrazyKiwi View Post
Ive just installed MHD stage 1 and i get alot of wastegate rattle on idle and deacceleration between 2-5krpm. Ive tried using the MHD wastegate fix and it has made no difference

However on stock and the MHD stage 0 flash i get zero wastegate noise.
Is this a common issue?
Yup I have had that issue since flashing MHD, tried to bring up this issue years ago lol. I just deal with it with no support.

I have also gone custom tune since map releases have R.I.P, seems like you'll get better support by getting newer platform.
Appreciate 0
      08-22-2019, 06:43 PM   #12143
cheddle
New Member
Australia
0
Rep
8
Posts

Drives: '07 BMW E90 335i
Join Date: Aug 2019
Location: Tasmania, Aus

iTrader: (0)

Quote:
Originally Posted by KrazyKiwi View Post
Ive just installed MHD stage 1 and i get alot of wastegate rattle on idle and deacceleration between 2-5krpm. Ive tried using the MHD wastegate fix and it has made no difference

However on stock and the MHD stage 0 flash i get zero wastegate noise.
Is this a common issue?
I have this as well. I just flashed stage 8 and now I have heaps of wastegate noise where as on stock I really didn't notice it at all.

here is a video of the noise after flashing. I am yet to try the waste gate rattle fix

Appreciate 0
      08-23-2019, 12:09 AM   #12144
KrazyKiwi
Registered
New Zealand
0
Rep
4
Posts

Drives: 07 335i
Join Date: Aug 2019
Location: Auckland, NZ

iTrader: (0)

Quote:
Originally Posted by cheddle View Post
I have this as well. I just flashed stage 8 and now I have heaps of wastegate noise where as on stock I really didn't notice it at all.

here is a video of the noise after flashing. I am yet to try the waste gate rattle fix

Yup, ive got the exact same sound with the MHD flash.
Have you been able to fix it yet?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:21 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST