E90Post
 


European Auto Source (EAS)
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > USA - Florida > AC Help on E92



Reply
 
Thread Tools Search this Thread
      06-04-2019, 03:45 PM   #1
Kentavian328i
New Member
0
Rep
15
Posts

Drives: 2007 BMW 328I
Join Date: Jun 2018
Location: Tallahassee Florida

iTrader: (0)

AC Help on E92

Hey guys I posted about this before but never got much help so here goes again... I have a 2007 BMW 328i coupe. I have this one particular issue. I switched out the OEM radio and put in a Eonon aftermarket radio around this time last year 6/10/18. It was completely plug in play. After the install I lost my AC. I only have heat and it only blows through the defrost vents and not any other vent on the car. Even when driving it the heat comes through the defrost making it extremely hot to drive during the day. Has anyone installed an aftermarket radio and experienced the same problem? I need help so I can get back to driving my car regularly... Its hot AF here in Tallahassee Fl so i need my AC back ASAP
Appreciate 0
      06-04-2019, 09:14 PM   #2
Daniel08E93
Lieutenant
Daniel08E93's Avatar
United_States
48
Rep
501
Posts

Drives: 2008 335i E93
Join Date: Jun 2017
Location: Florida

iTrader: (3)

Garage List
Pull head unit out make sure all clips are all the way in on your climate control and also make sure you didn't punch any wires when putting everything back take your time and check wiring to make sure nothing is being bent you will be able to tell if they were being pinched or not, if your climate control unit is working it shouldn't be your fuse but just double check to make sure you don't have any clown fuses for your ac
Appreciate 0
      06-05-2019, 07:17 AM   #3
Kentavian328i
New Member
0
Rep
15
Posts

Drives: 2007 BMW 328I
Join Date: Jun 2018
Location: Tallahassee Florida

iTrader: (0)

I checked the wires and everything seemed to be in correctly and no pinched wires. I will unhook everything and then plug it and back in and see what happens. I looked at the fuses but ill test them to see if anything is blown. Keep you updated Thanks!
Appreciate 0
      06-05-2019, 07:11 PM   #4
Daniel08E93
Lieutenant
Daniel08E93's Avatar
United_States
48
Rep
501
Posts

Drives: 2008 335i E93
Join Date: Jun 2017
Location: Florida

iTrader: (3)

Garage List
Quote:
Originally Posted by Kentavian328i View Post
I checked the wires and everything seemed to be in correctly and no pinched wires. I will unhook everything and then plug it and back in and see what happens. I looked at the fuses but ill test them to see if anything is blown. Keep you updated Thanks!
Good luck man hope this works, where are you located?
Appreciate 0
      06-05-2019, 07:14 PM   #5
Kentavian328i
New Member
0
Rep
15
Posts

Drives: 2007 BMW 328I
Join Date: Jun 2018
Location: Tallahassee Florida

iTrader: (0)

Quote:
Originally Posted by Daniel08E93 View Post
Quote:
Originally Posted by Kentavian328i View Post
I checked the wires and everything seemed to be in correctly and no pinched wires. I will unhook everything and then plug it and back in and see what happens. I looked at the fuses but ill test them to see if anything is blown. Keep you updated Thanks!
Good luck man hope this works, where are you located?
I'm located in Tallahassee Florida. I just scanned the A/C modules an this what I got
Appreciate 0
      06-05-2019, 07:16 PM   #6
Kentavian328i
New Member
0
Rep
15
Posts

Drives: 2007 BMW 328I
Join Date: Jun 2018
Location: Tallahassee Florida

iTrader: (0)

Quote:
Originally Posted by Kentavian328i View Post
Quote:
Originally Posted by Daniel08E93 View Post
Quote:
Originally Posted by Kentavian328i View Post
I checked the wires and everything seemed to be in correctly and no pinched wires. I will unhook everything and then plug it and back in and see what happens. I looked at the fuses but ill test them to see if anything is blown. Keep you updated Thanks!
Good luck man hope this works, where are you located?
I'm located in Tallahassee Florida. I just scanned the A/C modules an this what I got
I gotta diagnosis the codes
Attached Images
  
Appreciate 0
      06-05-2019, 07:17 PM   #7
Kentavian328i
New Member
0
Rep
15
Posts

Drives: 2007 BMW 328I
Join Date: Jun 2018
Location: Tallahassee Florida

iTrader: (0)

Quote:
Originally Posted by Kentavian328i View Post
Quote:
Originally Posted by Kentavian328i View Post
Quote:
Originally Posted by Daniel08E93 View Post
Quote:
Originally Posted by Kentavian328i View Post
I checked the wires and everything seemed to be in correctly and no pinched wires. I will unhook everything and then plug it and back in and see what happens. I looked at the fuses but ill test them to see if anything is blown. Keep you updated Thanks!
Good luck man hope this works, where are you located?
I'm located in Tallahassee Florida. I just scanned the A/C modules an this what I got
I gotta diagnosis the codes
Maybe it's a fuse or relay
Attached Images
  
Appreciate 0
      06-05-2019, 08:01 PM   #8
Daniel08E93
Lieutenant
Daniel08E93's Avatar
United_States
48
Rep
501
Posts

Drives: 2008 335i E93
Join Date: Jun 2017
Location: Florida

iTrader: (3)

Garage List
Those are a lot of codes if you were closer I'd help personally but you might be right it could be a fuse or relay just double check them and pull them to see if any are burnt that are associated with the ac or climate controls
Appreciate 0
      06-05-2019, 08:03 PM   #9
Kentavian328i
New Member
0
Rep
15
Posts

Drives: 2007 BMW 328I
Join Date: Jun 2018
Location: Tallahassee Florida

iTrader: (0)

Quote:
Originally Posted by Daniel08E93 View Post
Those are a lot of codes if you were closer I'd help personally but you might be right it could be a fuse or relay just double check them and pull them to see if any are burnt that are associated with the ac or climate controls
I'm going to pull them in the morning and check to see if that's the issue. All the code related to the same thing so I'm thinking a relay or fuse
Appreciate 0
      06-06-2019, 10:48 AM   #10
Daniel08E93
Lieutenant
Daniel08E93's Avatar
United_States
48
Rep
501
Posts

Drives: 2008 335i E93
Join Date: Jun 2017
Location: Florida

iTrader: (3)

Garage List
It's looking like it just keep thread updated
Appreciate 0
      06-06-2019, 10:50 AM   #11
Kentavian328i
New Member
0
Rep
15
Posts

Drives: 2007 BMW 328I
Join Date: Jun 2018
Location: Tallahassee Florida

iTrader: (0)

Quote:
Originally Posted by Daniel08E93 View Post
It's looking like it just keep thread updated
No problem 👍🏾
Appreciate 0
      06-22-2019, 11:15 AM   #12
Hart23
New Member
0
Rep
12
Posts

Drives: 2007 328xi
Join Date: Jun 2019
Location: Canada

iTrader: (0)

Any updates?

I am having the same issue after installing a eonon HU. did you resolve the issue?
Appreciate 0
      06-22-2019, 11:18 AM   #13
Kentavian328i
New Member
0
Rep
15
Posts

Drives: 2007 BMW 328I
Join Date: Jun 2018
Location: Tallahassee Florida

iTrader: (0)

Quote:
Originally Posted by Hart23 View Post
I am having the same issue after installing a eonon HU. did you resolve the issue?
Still working on it. I've been keeping up with another forum an one guy said that everything has to be plugged back in tightly or the actual ac unit may be bad so I'm going to test both today
Appreciate 0
      06-25-2019, 01:01 PM   #14
domikiki
Registered
0
Rep
3
Posts

Drives: BMW 335i
Join Date: Apr 2017
Location: Florida

iTrader: (0)

This is the a/c section of the service manual hope it helps.
Attached Images
File Type: pdf ac heating.pdf (2.81 MB, 9 views)
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:48 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST