E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > **First Time Tuners** Start Here** Official Misfire Thread| Updated!



Reply
 
Thread Tools Search this Thread
      03-22-2019, 02:05 PM   #331
Ayedum
Registered
0
Rep
3
Posts

Drives: BMW E90 N54
Join Date: Mar 2019
Location: New York

iTrader: (0)

cant wait to order my cobb
Appreciate 0
      03-25-2019, 07:43 AM   #332
type-dRew
Captain
type-dRew's Avatar
296
Rep
705
Posts

Drives: 2009 335i xDrive
Join Date: Feb 2019
Location: Newport MI

iTrader: (0)

Quote:
Originally Posted by Ayedum View Post
cant wait to order my cobb
Don't do that.
Appreciate 1
      03-26-2019, 09:47 AM   #333
beetle6986
Private First Class
9
Rep
150
Posts

Drives: E90 335xi, E70 X5 50, 04 Cobra
Join Date: Jun 2013
Location: PA

iTrader: (0)

Quote:
Originally Posted by beetle6986 View Post
Removed the JB4. That didnít help. I guess Iíll do O2 sensors next.
Replaced the O2 sensor in bank 1. Didn't help anything.

I'm starting to wonder if the car has a blown headgasket from overheating when the water pump went out the second time (almost a year ago). The car went into limp mode with reduced power. I drove it about another 5 miles on reduced power until I parked it as it wouldn't drive anymore under its own power due to the computer limiting. It was freezing outside when this happened. The next day I started the car and drove it home. It hardly started at first. Once it did start it smoked and misfired horribly for a few minutes. Turns out the water pump mechanics didn't fail. The housing actually cracked allowing all of the coolant to leak out. Possibly it had a minor gasket leak that has slowly gotten worse.
__________________
2008 335xi - JB5 ISO, VFSR catless DP, DCI, VMR V710s.
Appreciate 0
      03-29-2019, 08:08 PM   #334
beetle6986
Private First Class
9
Rep
150
Posts

Drives: E90 335xi, E70 X5 50, 04 Cobra
Join Date: Jun 2013
Location: PA

iTrader: (0)

Quote:
Originally Posted by beetle6986 View Post
Replaced the O2 sensor in bank 1. Didn't help anything.

I'm starting to wonder if the car has a blown headgasket from overheating when the water pump went out the second time (almost a year ago). The car went into limp mode with reduced power. I drove it about another 5 miles on reduced power until I parked it as it wouldn't drive anymore under its own power due to the computer limiting. It was freezing outside when this happened. The next day I started the car and drove it home. It hardly started at first. Once it did start it smoked and misfired horribly for a few minutes. Turns out the water pump mechanics didn't fail. The housing actually cracked allowing all of the coolant to leak out. Possibly it had a minor gasket leak that has slowly gotten worse.

Car passed blown head gasket test.

However, I think I had a break through today with some with something else. I pulled fuse 26 which disables the awd system. The car does not misfire with this fuse out. So I believe it isnít actually a misfire. I think the issue is related to the transfer case or the 4x4 system. It just feels exactly like a misfire.
Appreciate 0
      04-01-2019, 06:19 AM   #335
kchalisuri
Registered
0
Rep
3
Posts

Drives: bmw e60 535xi
Join Date: Oct 2018
Location: Georgia Tbilisi

iTrader: (0)

hello guys, i have e60 xdrive. i wrote post on 5 series forum, but 3 series owners make more tune then 5 series. can someone help

this is my post
https://e60.5post.com/forums/showthr...0#post24594490
Appreciate 0
      04-01-2019, 09:53 PM   #336
avityvan
New Member
United_States
0
Rep
14
Posts

Drives: 2006 bmw 325i
Join Date: Jan 2019
Location: Minnesota

iTrader: (0)

2006 BMW 325i
N52 code: Misfire on cylinder 2

I was driving one day and all suddenly my car loss some power and start idling very bad so I scan the car and it give me a misfire on cylinder 2. Did some research on the forum and I thought maybe is time to replaced this all these things anyway so I took out the 2 solenoids and clean them and I replaced all coils and spark plugs and cylinder 2 injector but nothing change. I did a scan again and is still read misfire cylinder 2.

After everything that I did the car still have the same issues.

Help!!! much appreciated.
Appreciate 0
      04-02-2019, 12:58 PM   #337
mweisdorfer
Brigadier General
mweisdorfer's Avatar
United_States
1042
Rep
4,617
Posts

Drives: 2007 Black/Black 335i e90
Join Date: Apr 2011
Location: Holly, MI

iTrader: (0)

Garage List
2007 BMW E90 335i  [0.00]
2008 bmw x5  [0.00]
Quote:
Originally Posted by avityvan View Post
2006 BMW 325i
N52 code: Misfire on cylinder 2

I was driving one day and all suddenly my car loss some power and start idling very bad so I scan the car and it give me a misfire on cylinder 2. Did some research on the forum and I thought maybe is time to replaced this all these things anyway so I took out the 2 solenoids and clean them and I replaced all coils and spark plugs and cylinder 2 injector but nothing change. I did a scan again and is still read misfire cylinder 2.

After everything that I did the car still have the same issues.

Help!!! much appreciated.
What coils did you use? What sort of tune do you have on a 325? Injector might be the issue. From what I understand, you can only use 11 & 12 in the same bank..

So, if you had like 10 and below in the other 2, in the same bank, and put a new 12 in that would make sense. Also, most people would suggest Eldor coils when doing a tune.
Appreciate 0
      04-02-2019, 04:24 PM   #338
avityvan
New Member
United_States
0
Rep
14
Posts

Drives: 2006 bmw 325i
Join Date: Jan 2019
Location: Minnesota

iTrader: (0)

I replaced all 6 coils with BMW Direct Ignition Coil - Bosch 0221504465 and also replaced injector 2 but is still have cylinder 2 misfire. I don't know what else can it be.

I don't understand what you mean 11 & 12 in the same bank.

Thanks for the help, much appreciated.
Appreciate 0
      04-02-2019, 06:17 PM   #339
rjahl
Lieutenant Colonel
rjahl's Avatar
572
Rep
1,630
Posts

Drives: Z4 35is
Join Date: Jun 2011
Location: Tampa

iTrader: (0)

Garage List
2012 Z4 35is  [0.00]
**First Time Tuners** Start Here** Official Misfire Thread| Updated!

Jump over to the Naturally Aspirated forums. Much more help for the N52 over there.
Appreciate 0
      04-02-2019, 07:58 PM   #340
mweisdorfer
Brigadier General
mweisdorfer's Avatar
United_States
1042
Rep
4,617
Posts

Drives: 2007 Black/Black 335i e90
Join Date: Apr 2011
Location: Holly, MI

iTrader: (0)

Garage List
2007 BMW E90 335i  [0.00]
2008 bmw x5  [0.00]
Quote:
Originally Posted by avityvan View Post
I replaced all 6 coils with BMW Direct Ignition Coil - Bosch 0221504465 and also replaced injector 2 but is still have cylinder 2 misfire. I don't know what else can it be.

I don't understand what you mean 11 & 12 in the same bank.

Thanks for the help, much appreciated.
Bank 1 are cylinders 1-3, Bank 2 are cylinders 4-6.

1 - 11
2 - 12
3 - 9 = no good

1 - 11
2 - 11
3 - 12 = good

You can't go below 11 in a given bank

You can -

1 - 11
2 - 11
3 - 12

4 - 9
5 - 10
6 - 9 = no issues because they are separate banks

The numbers of course like 11, 12 etc are the index numbers of the individual injectors
Appreciate 0
      04-02-2019, 10:15 PM   #341
beetle6986
Private First Class
9
Rep
150
Posts

Drives: E90 335xi, E70 X5 50, 04 Cobra
Join Date: Jun 2013
Location: PA

iTrader: (0)

Quote:
Originally Posted by beetle6986 View Post
Car passed blown head gasket test.

However, I think I had a break through today with some with something else. I pulled fuse 26 which disables the awd system. The car does not misfire with this fuse out. So I believe it isnít actually a misfire. I think the issue is related to the transfer case or the 4x4 system. It just feels exactly like a misfire.
I figured I would give an update. I hate when people have problems and post it in a thread and then never give the final resolution. I changed the transfer case fluid and the differential fluid. The issue is now 90% better. Iím hoping as I drive it more with the new fluid the issue will go away completely. Otherwise, I will put in a replacement transfer case.
Appreciate 0
      04-23-2019, 12:55 PM   #342
XxPotHeadxX420
Registered
0
Rep
1
Posts

Drives: BMW 335i E90
Join Date: Apr 2019
Location: Buffalo, NY

iTrader: (0)

This helped my newbie butt out alot. #NewMember
Appreciate 0
      05-09-2019, 05:26 PM   #343
Fedisrico
Registered
0
Rep
3
Posts

Drives: 2007 Bmw 335is
Join Date: May 2019
Location: Chicago

iTrader: (0)

Great info
Appreciate 0
      05-19-2019, 12:17 AM   #344
Chrisred
Captain
Chrisred's Avatar
Canada
37
Rep
780
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

Hi, I keep getting ALL cylinder misfires on WOT only above 5000rpm.

Have RB turbos on 100% meth, FBO, upgraded LPFP.

Tried NGK 2 step and 1 step colder plugs and stock plugs. No change

New coils. Bimmerlife.

Injectors are index 12. Have replaced cylinders 1-2-3. Same results . Doesn't seem like I have issue there as no morning misfires due to leaks. And misfires are always on different cylinders or in ALL cylinders. Coded well and decouplers in place.

Carbon cleaning done as well.

Logged HPFP & LPFP with Trebila and everything is perfect. Logs are perfect until misfires.

Have stage 3+ spec clutch and flywheel.


No other codes. Just the misfires on several/All cylinders.

O2 sensors fairly new.

Any ideas.?? Anyone??
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH RB TURBO
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG SPEC STG 3
Appreciate 0
      06-09-2019, 04:40 AM   #345
335xirookie
New Member
335xirookie's Avatar
United_States
0
Rep
12
Posts

Drives: 08 335xi E92
Join Date: Dec 2018
Location: 06010

iTrader: (0)

Help

Spark plug gap maybe? prob should be 18-20...Or maybe time for Bimmer life coils...
Appreciate 0
      06-13-2019, 12:27 PM   #346
Chrisred
Captain
Chrisred's Avatar
Canada
37
Rep
780
Posts

Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

iTrader: (0)

Quote:
Originally Posted by 335xirookie View Post
Spark plug gap maybe? prob should be 18-20...Or maybe time for Bimmer life coils...
I currently have new stock plugs. Believe they're not gappable. But either way my mechanic had gapped all my plugs correctly in the past.
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH RB TURBO
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG SPEC STG 3
Appreciate 0
      06-23-2019, 12:57 PM   #347
jasonytl1
New Member
jasonytl1's Avatar
Hong Kong
0
Rep
23
Posts

Drives: E90 335i
Join Date: Jun 2019
Location: Hong kong

iTrader: (0)

Hi, I am from Hong Kong, I have did a lot of review before try to flash my car with MHD, and I finally decide to flash it today, but my flash didnít went well and my car canít turn on anymore, this is the process of my flash, hope that you can help me.

First, I have my battery connected to my car, then I pug in the K+DCAN cable, it connect successfully, I purchases the flasher module and stage 1 map, then I go backup my ECU and start flash the map. Firstly it go well, but then it stuck at (15%, 31min) left. I wait for more than 1 hour but it still stuck at 15%, so I have choices to unplug the cable, then I restart the phone and ofcause my car canít start anymore.

After my phone restarted, I try to flash my car back to stage 0, the MHD app go well and start flash back to stock, later on, it stuck at (89% 2min) left again, after half hours, I have no Choice to unplug the cable again. Finally, the MHD app no longer connects to the ECU, I try with the same cable that I have used and it said no cable detected. That is all the process of my flash, hope that you can give me some help, thanks.
Appreciate 0
      09-18-2019, 06:25 PM   #348
CheesecakeInjection
New Member
0
Rep
5
Posts

Drives: Ď10 e90 335xi
Join Date: Jun 2019
Location: Canada

iTrader: (0)

This was helpful. I had slight intermittent hesitations around 4k rpm. After JB4 i had bad missfires at 4k rpm, every WOT. Then misfire continued and idle was rough. On/Off ignition resolved it till next time i hit 4k. Turned out to be an ignition coil! Good write up.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:40 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST