E90Post
 


European Auto Source (EAS)
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Oxygen sensor good or bad?



Reply
 
Thread Tools Search this Thread
      11-22-2019, 05:33 PM   #1
Wilson335i
New Member
0
Rep
15
Posts

Drives: N54 335i x drive
Join Date: Nov 2019
Location: New York

iTrader: (0)

I unplugged one of my oxygen sensors bec I thought it was bad and it didn't do anything to how my car was running... and didn't trigger a engine light either. It was bank 2 sensor 1 with the grey wire and I've been getting really really bad gas mileage I just put fresh tune up plugs and coils but that only helped a little bit occasionally I get misfire on cyl 4-6 (bank 2) does anyone know what this could mean? I have rough idle and some morning have very rough starts lots of smoke.. gas mileage horrible until clear of code no excessive oil leaks I do have crack in valve cover any help appreciated I really would like to enjoy the car without worrying every second or looking at mpg gauge 😅
Appreciate 0
      11-25-2019, 11:51 PM   #2
BashShah
Lieutenant Colonel
Canada
185
Rep
1,831
Posts

Drives: 2012 335i Sedan
Join Date: Oct 2012
Location: Vancouver, Canada

iTrader: (0)

crack in in the VC is your leak and causing of all your issues.
air getting into the car from VCG.
this causing you to run lean and poor gas mileage.

Your O2 sensor is not a O2 sensor but a AFR sensor.
read up on it.

After VCG replacement, do a Full Adaptation reset.
Appreciate 0
      12-05-2019, 02:36 PM   #3
Wilson335i
New Member
0
Rep
15
Posts

Drives: N54 335i x drive
Join Date: Nov 2019
Location: New York

iTrader: (0)

Quote:
Originally Posted by BashShah View Post
crack in in the VC is your leak and causing of all your issues.
air getting into the car from VCG.
this causing you to run lean and poor gas mileage.

Your O2 sensor is not a O2 sensor but a AFR sensor.
read up on it.

After VCG replacement, do a Full Adaptation reset.
Ok what is a FULL ADAPT reset? I'm going to change that valve cover I have it already with gaskets and bolts however I do believe your correct my "02" sensors seem like they're working as they should.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:24 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST