E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > New Battery



Reply
 
Thread Tools Search this Thread
      12-28-2020, 08:24 PM   #23
m_thompson
Major
m_thompson's Avatar
United_States
108
Rep
1,366
Posts

Drives: M-Sport 128i, 328xi, 3.0CS
Join Date: Jun 2008
Location: New England, USA

iTrader: (0)

Garage List
2009 128i  [0.00]
1972 3.0CS  [5.00]
Quote:
Originally Posted by Horse3000 View Post
I just bought a used 2010 328xi Coupe (n51) back in august and have been loving it. Only a couple issues, had to replace the starter and inner DISA valve.
Shouldn't the DISA valve been covered under the extended warranty for the N51?
__________________
'09 128i - Black Sapphire Metallic\Coral Red\Glacier Silver\N51 DISA\6MT\Navigation\Premium\M-Sport\Heated seats\Xenon Headlights\iPod\Smartphone\Euro Delivery

Appreciate 0
      01-12-2021, 07:11 PM   #24
shield.t
New Member
United_States
0
Rep
6
Posts

Drives: BMW 328i
Join Date: Jan 2021
Location: CA

iTrader: (0)

I changed a Costco battery for my E90 (2011, 328i) ,and I drove the car for 10 min to test it out without battery registering. But after 2 days, I could not start the car. I bought a trickle charger to maintain the battery full but still no luck to start the car. What could be the reason?

New battery: H7 (94R), 80Ah
Original one: 12V 90Ah 720A / 160RC 720 CCA (S: 61 21 7 604 820)

Thanks in advance.
Appreciate 0
      01-12-2021, 07:20 PM   #25
fgpalmer71
Lieutenant
United_States
199
Rep
442
Posts

Drives: 2016 Genesis sedan 3.8 AWD
Join Date: Jun 2020
Location: indiana

iTrader: (0)

I'd guess you replaced an AGM battery with a Non-AGM or vise versa. You can do that.....IF you code for it. That's my assumption. If the battery isn't toasted already I'd try charging it up and registering it. It does seem odd to me that it lasted only 2 days.....coded or not.
Appreciate 0
      01-12-2021, 07:23 PM   #26
shield.t
New Member
United_States
0
Rep
6
Posts

Drives: BMW 328i
Join Date: Jan 2021
Location: CA

iTrader: (0)

The new one is a non-AGM. I'm not sure about the original one. It is a white/grey VARTA battery without AGM mark. (S: 61 21 7 604 820)
Appreciate 0
      01-12-2021, 07:49 PM   #27
HB E90
Second Lieutenant
HB E90's Avatar
37
Rep
204
Posts

Drives: 2010 E90 335i Space Gray
Join Date: Jul 2015
Location: Huntington Beach CA

iTrader: (0)

thats interesting. I put the same one in mine a couple of months ago and its been great. I was able to register it with MHD app. I'd start by checking what voltage is being put on it while its running. Maybe the alternator is shot? On mine it usually sitting around 13.7V but on my Tacoma is always over 14V so I'm wondering if mine is marginal? The battery I pulled out was dated 6-2017 so like 3.5 years. Questionable but 2 days! Are you getting and other codes or warnings ?
__________________
2010 E90 SG 335i Sport, Premium, Nav. MHD, VRSF CP, 5" HD FMIC, DCI's, fresh coils and 1 step colder NGK's, Apex EC-7's and Michelin PS4S, Cree 6000k H8 LED Angel eyes
2011 Toyota Tacoma DC TRDOR 4x4 lifted and armored
2014 Acura MDX SHAWD wifes
Appreciate 0
      01-12-2021, 07:58 PM   #28
shield.t
New Member
United_States
0
Rep
6
Posts

Drives: BMW 328i
Join Date: Jan 2021
Location: CA

iTrader: (0)

Quote:
Originally Posted by HB E90 View Post
thats interesting. I put the same one in mine a couple of months ago and its been great. I was able to register it with MHD app. I'd start by checking what voltage is being put on it while its running. Maybe the alternator is shot? On mine it usually sitting around 13.7V but on my Tacoma is always over 14V so I'm wondering if mine is marginal? The battery I pulled out was dated 6-2017 so like 3.5 years. Questionable but 2 days! Are you getting and other codes or warnings ?
Since I could not start the car, the Bimmer APP won't able to connect to adapter. I noticed another interesting thing - battery voltage number from the multimeter is changing/looping (something like 4-> 8-> 10-> 13, and again). is it normal?

Last edited by shield.t; 01-12-2021 at 08:07 PM..
Appreciate 0
      01-12-2021, 08:16 PM   #29
fgpalmer71
Lieutenant
United_States
199
Rep
442
Posts

Drives: 2016 Genesis sedan 3.8 AWD
Join Date: Jun 2020
Location: indiana

iTrader: (0)

Quote:
Originally Posted by shield.t View Post
Since I could not start the car, the Bimmer APP won't able to connect to adapter. I noticed another interesting thing - battery voltage number from the multimeter is changing/looping (something like 4-> 8-> 10-> 13, and again). is it normal?
The car doesn't need to be started, but the accessories need to be switched on.
Appreciate 0
      01-12-2021, 08:27 PM   #30
e91Owner
e91Owner
United_States
32
Rep
153
Posts

Drives: 2011 BMW 328i Wagon
Join Date: Mar 2018
Location: Charleston, SC

iTrader: (0)

Quote:
Originally Posted by shield.t View Post
Quote:
Originally Posted by HB E90 View Post
thats interesting. I put the same one in mine a couple of months ago and its been great. I was able to register it with MHD app. I'd start by checking what voltage is being put on it while its running. Maybe the alternator is shot? On mine it usually sitting around 13.7V but on my Tacoma is always over 14V so I'm wondering if mine is marginal? The battery I pulled out was dated 6-2017 so like 3.5 years. Questionable but 2 days! Are you getting and other codes or warnings ?
Since I could not start the car, the Bimmer APP won't able to connect to adapter. I noticed another interesting thing - battery voltage number from the multimeter is changing/looping (something like 4-> 8-> 10-> 13, and again). is it normal?
A voltage drop like that would indicate a capacitive grounding which could be the battery itself or something in the car. Without knowing what kind of battery you were replacing, the only way to properly install the battery would have been by registering it which with most applications also codes for the battery as AGM/non-AGM.

Like other posters said, you only need to have the ignition on, so jump it, charger,etc.
Appreciate 0
      01-12-2021, 11:15 PM   #31
shield.t
New Member
United_States
0
Rep
6
Posts

Drives: BMW 328i
Join Date: Jan 2021
Location: CA

iTrader: (0)

Update:

I tried to use BimmerLink to register the new battery, failed.
Cleaned error codes and tried again, no luck.

I still cannot start the car. So, I disconnected the negative terminal of the battery, and connected it again. Now, I CAN START my car again. Still don't know why?
Appreciate 0
      01-13-2021, 01:49 AM   #32
Tambohamilton
Colonel
United Kingdom
862
Rep
2,115
Posts

Drives: E91 330d
Join Date: Apr 2019
Location: Wiltshire, UK

iTrader: (0)

My guess would be that the neg terminal had a dry connection, so reseating it has fixed that?
Appreciate 0
      01-13-2021, 11:38 AM   #33
shield.t
New Member
United_States
0
Rep
6
Posts

Drives: BMW 328i
Join Date: Jan 2021
Location: CA

iTrader: (0)

Quote:
Originally Posted by Tambohamilton View Post
My guess would be that the neg terminal had a dry connection, so reseating it has fixed that?
The neg terminal is clean and the contact looks fine. After disconnect/reconnect, the car starts again. But the battery registration failed again, BimmerLink app gave a generic "You cannot register this battery. Contact developer" error message again.
Appreciate 0
      01-13-2021, 12:30 PM   #34
shield.t
New Member
United_States
0
Rep
6
Posts

Drives: BMW 328i
Join Date: Jan 2021
Location: CA

iTrader: (0)

Update E90 battery registration using BimmerLink -

After replaced battery on 2011 328i, here is the clean list:
1) connect BimmerLink with Veepeak OBD2 adapter
2) Put the car key in and start ignition (not start engine), without foot on brake
3) clean up error memories by the app
4) run battery registration

Successfully done!
Appreciate 0
      01-13-2021, 02:26 PM   #35
fgpalmer71
Lieutenant
United_States
199
Rep
442
Posts

Drives: 2016 Genesis sedan 3.8 AWD
Join Date: Jun 2020
Location: indiana

iTrader: (0)

Quote:
Originally Posted by shield.t View Post
Update E90 battery registration using BimmerLink -

After replaced battery on 2011 328i, here is the clean list:
1) connect BimmerLink with Veepeak OBD2 adapter
2) Put the car key in and start ignition (not start engine), without foot on brake
3) clean up error memories by the app
4) run battery registration

Successfully done!
Appreciate 0
Reply

Bookmarks

Tags
battery

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:16 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST