E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > CIC/NBT FSC Generator - Windows/Linux/OSX



Reply
 
Thread Tools Search this Thread
      07-10-2018, 03:47 AM   #67
frankk
Registered
Estonia
0
Rep
2
Posts

Drives: BMW E90 2009 6MT ECO-M-Package
Join Date: Jul 2018
Location: Estonia

iTrader: (0)

Code is invalid

Hey everybody, I'm also pretty new here and pretty new about all these things, but I thought I would give it a shot, so my problem is that the code is invalid.
I got the 1b.hex file using glovebox usb slot, and when entering the code I got from the FSC generator the car just says that the code is invalid, no error from the program or anything. Would really appreciate some help
Appreciate 0
      07-10-2018, 03:58 AM   #68
txomin
New Member
2
Rep
5
Posts

Drives: BMW X4 F26 20d XDrive
Join Date: Jul 2018
Location: Italy

iTrader: (0)

Quote:
Originally Posted by Jagaer View Post
txomin

It is possible the sources I used to reference what is a "valid" VIN are out of date, but yours doesn't seem to be valid.

For BMW, the first digit should be the plant assembly number, which should be one of: A, B, C, D, E, F, G, J, K, L, M, N, P, V, W.

I'm not certain what plant is "0". If you have an X4, I'd expect it to be built in Spartanburg (until Trump tariffs force it to move), which is Plant Code "L" and "M".
@Jagaer
Iíll PM VIN info... if you want to check.
Thank you
Appreciate 0
      07-10-2018, 06:35 AM   #69
Jagaer
Private
Canada
68
Rep
74
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

Quote:
Originally Posted by frankk View Post
Hey everybody, I'm also pretty new here and pretty new about all these things, but I thought I would give it a shot, so my problem is that the code is invalid.
I got the 1b.hex file using glovebox usb slot, and when entering the code I got from the FSC generator the car just says that the code is invalid, no error from the program or anything. Would really appreciate some help
There have been a few people which have had issues with the Hex file retrieved using the USB port.

Infrequently the program used to cut the 319 byte "chunk" of the persistence file, does not grab the correct part.

The other issue is if you are using an emulator. Depending on how the emulator is activated, the VIN in the Hex file does not match the vehicle VIN. This is easily changed within the 1B file itself.
Appreciate 0
      07-10-2018, 06:38 AM   #70
frankk
Registered
Estonia
0
Rep
2
Posts

Drives: BMW E90 2009 6MT ECO-M-Package
Join Date: Jul 2018
Location: Estonia

iTrader: (0)

Quote:
Originally Posted by Jagaer View Post
There have been a few people which have had issues with the Hex file retrieved using the USB port.

Infrequently the program used to cut the 319 byte "chunk" of the persistence file, does not grab the correct part.

The other issue is if you are using an emulator. Depending on how the emulator is activated, the VIN in the Hex file does not match the vehicle VIN. This is easily changed within the 1B file itself.
Maybe grabbed the wrong part indeed, in case of that should I just retry doing it? Also how could I try to change the VIN inside the 1B file?
I'll add the file here just in case you could maybe help me out.
Attached Files
File Type: zip 1b.zip (426 Bytes, 38 views)

Last edited by frankk; 07-10-2018 at 06:39 AM. Reason: Forgot to add file
Appreciate 0
      07-10-2018, 09:10 AM   #71
txomin
New Member
2
Rep
5
Posts

Drives: BMW X4 F26 20d XDrive
Join Date: Jul 2018
Location: Italy

iTrader: (0)

Quote:
Originally Posted by Jagaer View Post
txomin

It is possible the sources I used to reference what is a "valid" VIN are out of date, but yours doesn't seem to be valid.

For BMW, the first digit should be the plant assembly number, which should be one of: A, B, C, D, E, F, G, J, K, L, M, N, P, V, W.

I'm not certain what plant is "0". If you have an X4, I'd expect it to be built in Spartanburg (until Trump tariffs force it to move), which is Plant Code "L" and "M".

Hi Jagaer,

This is my complete VIN:
https://www.etkbmw.com/bmw/EN/vin/de...10000L88505/EN

There is obviously some different standard other than the one you posted... let me try to found details about it.

My carís VIN pics:
https://www.dropbox.com/s/5spr5lewq9...arge.jpeg?dl=1
https://www.dropbox.com/s/azp07vofcm..._1800.JPG?dl=1




EDITED @1430UTC
Ok, I got an answer directly from my BMW dealer:
Looks like that my plant manufacter is ďLĒ wich in my case is the 12th VIN digit. This happens since the production plant letter for BMW is attached to the carís serial number with no leading zeroes.
Basically the first vehicles of the serie are the 00000L1, 00000L2, etc... eventually the plant identifier reaches the 11th place after the 99,999 vehicle (0L99999), from that point on the 11th digit corresponds to the plant.

Makes sense to me since my X4 was produced in Oct 2014, at the very early stages of the model production.

Last edited by txomin; 07-10-2018 at 10:32 AM.
Appreciate 1
Jagaer67.50

      07-21-2018, 05:03 AM   #72
Jagaer
Private
Canada
68
Rep
74
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

@txomin.

Thanks for the explanation, the generator has been updated to allow the '0' digit for the first character of the VIN
Appreciate 0
      07-24-2018, 02:20 AM   #73
aTasca
New Member
Romania
0
Rep
9
Posts

Drives: 2013 F11 525d xDrive
Join Date: Apr 2018
Location: Iasi, Romania

iTrader: (0)

invalid code

hi,

I have been using the generator for maps activation in 5-6 units now and all worked just fine.

Last I have used it (2014 F10 LCI with NBT), pulled the DE file with esys and enet cable, all looks fine, is 319 bytes long, looking inside I can see the VIN and the production date timestamp, all looks fine.

however when feeding it into the generator the resulted code is displayed as invalid - tried one-time and life-rime code, same thing.

any ideas on this?

thanks
Appreciate 0
      07-24-2018, 05:41 PM   #74
Jagaer
Private
Canada
68
Rep
74
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

Quote:
Originally Posted by frankk View Post
Maybe grabbed the wrong part indeed, in case of that should I just retry doing it? Also how could I try to change the VIN inside the 1B file?
I'll add the file here just in case you could maybe help me out.
Based on the 1B file you attached, I'm guessing you are using an emulator or script activation. (File starts with 123456 instead of 773487, and your VIN is 1234567)

The keys within the file appear to be correct, and are in the correct location.
Appreciate 0
      07-24-2018, 05:44 PM   #75
Jagaer
Private
Canada
68
Rep
74
Posts

Drives: 2011 E91 328xi 6MT
Join Date: Aug 2017
Location: Kingston, Ont

iTrader: (0)

Quote:
Originally Posted by aTasca View Post
I have been using the generator for maps activation in 5-6 units now and all worked just fine.

Last I have used it (2014 F10 LCI with NBT), pulled the DE file with esys and enet cable, all looks fine, is 319 bytes long, looking inside I can see the VIN and the production date timestamp, all looks fine.

however when feeding it into the generator the resulted code is displayed as invalid - tried one-time and life-rime code, same thing.

any ideas on this?
Everything seems to be correct, the only other thing I can think of is if the vehicle is from a different region.

The CIC/NBT needs to be "activated" for a region of the world, then maps are "activated" for that region.

If the car was originally from a different region (Turkey, Egypt...), attempting to activate Europe maps will fail.

Other than that, I do not know why it would not work...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:03 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST