E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Valvetronic code 2e0f



Reply
 
Thread Tools Search this Thread
      09-16-2018, 11:46 PM   #1
bsad0521
Enlisted Member
0
Rep
30
Posts

Drives: 2011 e90 335i
Join Date: Mar 2017
Location: Tampa, Fl

iTrader: (0)

Valvetronic code 2e0f

So Ive put this off for quite some time now, but I have had this 2e0f code (Valvetronic system: disabled, too frequent) and its the only thing keeping me from tuning the car. Havnt had any real issues like a CEL, just some rev hunting on cold starts and a little jerking when driving at low speeds. Just wanted to know if any of you guys have had experience with this code and how you fixed it. its just a little annoying because I dont want to tune if everything isnt in order first. As they say maintenance before mods.lol
Appreciate 0
      09-21-2018, 09:32 AM   #2
hassmaschine
Major General
United_States
2931
Rep
6,133
Posts

Drives: "NBO" 330i
Join Date: Jun 2014
Location: earth

iTrader: (0)

most likely your valvetronic motor position sensor has failed. It's running in 'open loop' with the valvetronic locked at full lift, and using the throttle instead to control the engine. on the N55 you need to replace the valvetronic motor itself.
Appreciate 0
      09-25-2018, 01:51 AM   #3
bsad0521
Enlisted Member
0
Rep
30
Posts

Drives: 2011 e90 335i
Join Date: Mar 2017
Location: Tampa, Fl

iTrader: (0)

thanks, I thought so. Wondering if it is doing any real damage driving around like that. Just havnt built up the courage to replace it myself as i have not yet taken off the valve cover before. lol Wish there was some video explaining exactly how to replace the motor.
Appreciate 0
      10-15-2019, 08:02 PM   #4
drumm8
Enlisted Member
2
Rep
44
Posts

Drives: e46 zhp
Join Date: Jul 2015
Location: Charlotte, NC

iTrader: (0)

Did you replace the motor? Did it get rid of the code?
Appreciate 0
      10-21-2019, 11:40 PM   #5
bsad0521
Enlisted Member
0
Rep
30
Posts

Drives: 2011 e90 335i
Join Date: Mar 2017
Location: Tampa, Fl

iTrader: (0)

Not yet. really haven't found the time. I have the motor and everything but I guess im just being lazy. are you having the same issues?
Appreciate 0
      11-04-2019, 08:10 PM   #6
drumm8
Enlisted Member
2
Rep
44
Posts

Drives: e46 zhp
Join Date: Jul 2015
Location: Charlotte, NC

iTrader: (0)

For others who may come across this thread... I was getting ONLY the 2E0F code, and I ran the calibration procedure in ISTAD. It was to find the max and min travel points. After running this, the code instantly went away and has not come back. Before this, I could not even clear the code. It would stay on even when I hit clear codes. Hopefully this helps someone else.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:41 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST