E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Steering lock problems, need some help!



Reply
 
Thread Tools Search this Thread
      12-13-2017, 08:32 PM   #1
The_Dealer
Enlisted Member
0
Rep
39
Posts

Drives: 2007 335i
Join Date: Dec 2017
Location: Mooresville, NC

iTrader: (0)

Steering lock problems, need some help!

My car is an 07 335i sedan. Long story short my car was fine until I had a no crank no start, BMW replaced the column. Ever since then I've had a random no crank no start in which the steering doesn't unlock. I'm a tech (non bmw) and believe I have narrowed down the issue, but want some input from you guys since I don't have much bmw experience.

This connector seems to be the problem

I wiggle it around a little bit and I can get the steering lock to stop/start working. This connector has the same wire colors as the connector on the steering lock/elv. I have an elv emulator that I'm going to install, will this connector still be an issue or will that part be bypassed?
Appreciate 0
      12-15-2017, 12:21 AM   #2
ctuna
Major General
633
Rep
7,730
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

There is a multipage thread in the maintenance subforum or DIY subforum
about this issue.
You will need to reset the software counter
as you only get so many trys where it goes
yellow . If it goes red it won't start at all.

http://www.e90post.com/forums/forumdisplay.php?f=16

http://www.e90post.com/forums/showthread.php?t=483387

Last edited by ctuna; 12-15-2017 at 12:34 AM.
Appreciate 0
      12-15-2017, 02:30 AM   #3
ptpending
Lieutenant Colonel
183
Rep
1,534
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (1)

this first thing you should do is to charge your battery
__________________
E91 2006. Retrofits:High beam assistant, Individual Audio, Autodim mirrors, CIC, Combox(USB and Bluetooth), Electric Sport Seats, Light package, Front PDC, Heated Steering Wheel, Happy Robot, Climate Comfort Windscreen, Blackline rear lights.
Appreciate 0
      12-18-2017, 07:49 PM   #4
The_Dealer
Enlisted Member
0
Rep
39
Posts

Drives: 2007 335i
Join Date: Dec 2017
Location: Mooresville, NC

iTrader: (0)

Battery is brand new, and I've already reset the Cas & elv. Car has brand new battery, new oem Cas, new oem column. I repaired the connector and still have a random no start. I can screw around and wiggle the wires and get it to eventually start. I ordered an elv emulator, I'm just hoping it's going to work. I don't see anything wrong with the wires, so I don't know if me jiggling wires is related when it eventually starts. Might just be luck
Appreciate 0
      12-18-2017, 07:54 PM   #5
ctuna
Major General
633
Rep
7,730
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Read somewhere that the CAS and DME have to be synced and
the Vin numbers have to matched in the firmware.
See coding subforums.
Appreciate 0
      12-18-2017, 08:19 PM   #6
The_Dealer
Enlisted Member
0
Rep
39
Posts

Drives: 2007 335i
Join Date: Dec 2017
Location: Mooresville, NC

iTrader: (0)

Quote:
Originally Posted by ctuna View Post
Read somewhere that the CAS and DME have to be synced and
the Vin numbers have to matched in the firmware.
See coding subforums.
They have been. The bmw dealership did the column and cas
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:03 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST