E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Africa > E90 320i n46 alternator hot when parked overnight and battery dead



Reply
 
Thread Tools Search this Thread
      09-18-2023, 06:55 AM   #1
mik786.zn@gmail.
Registered
1
Rep
1
Posts

Drives: bmw e90 320i 20011
Join Date: Sep 2023
Location: south africa

iTrader: (0)

Exclamation E90 320i n46 alternator hot when parked overnight and battery dead

Hi guys.
I'm new to the group, so take it easy on me, I tried searching for topics related to my issue, but I haven't come across anything as specific as what I'm experiencing.

I have 2011 e90 320i n46.had it for 4 years, doing around 229 000km.
I had a miss on number 1 cylinder, changed out the injector, it didn't make a difference, then bought a new coil pack, and it fixed the issue. but the next morning the car was dead, getting the code of "excessive battery drain".

I manage to jump start, and all was fine until next morning it was dead again.
I changed out the battery for a new one. left it overnight and same issue.
the time I changed out the injector, some fuel ran down the side of the engine toward the alternator side. I don't know if it got in. or maybe got into the starter motor.

so, I ran the car the entire day and left it overnight again, got up next morning. pop the hood and felt the alternator, it was hot, never start it up, so why is it hot?

the voltage when idle is always around 14.50v, and when car is turned off its sitting at 12.60, but then it drops an amp every 5 seconds.
then I usually jumped it, no warning lights come up.

I got a donor alternator, tried that out, next morning, battery dead again!!!.

just to note, I used my existing regulator on the donor alternator. could it be the regulator??

I disconnected the alternator cables from the alternator, left it overnight and great news, car unlocked in the morning (usually doesn't unlock with the fob, so I use the key in the keyhole, that's how dead it gets). no signs of battery drain, held a steady voltage.

can anyone advise what could be the problem, since I changed out the alternator and battery, the battery still persists.

is the starter getting power from the alternator, that it could be the starter that's making the alternator hot, so when I disconnect the alternator, the starter doesn't get power?

I don't think it could be the new coil pack or injector. just the alternator cables were disconnected only, and the entire vehicle had power to lock unlock, dash lights on and so on.

I read further that a battery reg is needed, but some guys in the area says it's not the problem. I haven't registered the battery as yet.

Please guide me on further steps to take.

Last edited by mik786.zn@gmail.; 09-18-2023 at 07:48 AM..
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:37 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST