E90Post
 


European Auto Source (EAS)
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Africa > 320i E90 2010 start Model Crank but Wont Start



Reply
 
Thread Tools Search this Thread
      05-04-2019, 05:54 AM   #1
Ta Words
Registered
0
Rep
1
Posts

Drives: BMW 320i E90 2010
Join Date: May 2019
Location: kimberly (South Africa)

iTrader: (0)

320i E90 2010 start Model Crank but Wont Start

Good Day
Im driving a 320i E90 2010 Start Model the last Vin NM43319
I was knocking off from work off last night, when i heard the humming sound that sounded like the petrol pump but just a bit louder while driving home, and this morning when i started it just idle for a split second and cut off now its just crank but wont start there is no sound from the fuel pump I even went so far to disconnect the pumps just to check and it did the same crank but not start I went and check all the fuses in the glove box all of them seems find
1.Can someone point out where the Relay for this pump
2.Do this car also have petrol filter like the E46
Thank you in advance,
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:34 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST