E90Post
 


European Auto Source (EAS)
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Switched cables when jumpstarting car



Reply
 
Thread Tools Search this Thread
      09-19-2019, 05:46 PM   #1
jamaicaLemons
New Member
2
Rep
5
Posts

Drives: BMW 335i E92
Join Date: Sep 2019
Location: SLC Utah

iTrader: (0)

Switched cables when jumpstarting car

So about a week ago, I was jump starting my friends car and I switched the red and black cables when connecting to my battery. I know, I'm stupid. But it was late at night and whatever I can't do anything about it now. Anyways, my car (07 335i) immediately shut off and wouldn't turn back on. Fast forward to now. I bought a new power redistribution box for on top of my battery and I can drive the car and use most of the electronics but I'm still having some problems. My abs light is on, my car thinks I'm out of gas (I should have half a tank unless it magically disappeared), my car thinks the ebrake is on all the time, I can't unlock/lock my car with the key fob but it works on the ignition, my windshield wipers don't work, and I have a check engine light but mhd can't connect to the dme.
If anyone knows of any possible solutions, that would be appreciated thanks. Also I checked the fuses everything looks fine. Sorry if I'm posting in the wrong place I'm new here.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:20 PM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST