E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > VRSF DP Fix Code



Reply
 
Thread Tools Search this Thread
      10-13-2018, 09:12 PM   #1
sänd_mönstä
New Member
United_States
0
Rep
14
Posts

Drives: '11 335xi
Join Date: Jun 2014
Location: PA/MD

iTrader: (0)

VRSF DP Fix Code

Hey guys,

I finished installing the VRSF DP fix on my 2011 n55 earlier today using the following DIY:

https://www.e90post.com/forums/showp...&postcount=303

The installation was a breeze, but the dp fix does not seem to be operating correctly. The blue LED on the device will blink to show that it is operational, but between every few blinks, it will stay solid for a few seconds and then resume blinking. Is this normal?

Also, the DME threw a code at the start of a drive cyle I performed earling this evening and later abandoned. The code was 2D1F: Oxygen sensor after catalytic converter, electrical: Short circuit to B+

FYI, I'm running MHD and have flashed to map 0.

Any help would be much appreciated!
Appreciate 0
      10-13-2018, 11:04 PM   #2
Divbetic
Private
United_States
14
Rep
52
Posts

Drives: '11 135i
Join Date: Feb 2018
Location: NorCal

iTrader: (0)

I've heard that if you drive for a day or two the code may disappear. Resetting the code will reset monitors with it. I'm actually in the process of making a plug and play connection for my VRSF fix but haven't tested yet.
__________________
2011 135i 6MT
MHD Stage 2, VRSF CP, VRSF DP, M Performance Exhaust
Appreciate 0
      Yesterday, 07:43 AM   #3
Bfurrow95
New Member
0
Rep
7
Posts

Drives: 2011 BMW 335I E92 Coupe
Join Date: Sep 2018
Location: Tucson

iTrader: (0)

I just did the same a week ago and haven't had any issues. Granted, I'm running JB4 and MHD. Make sure you remove the check from "OEM/Catted Downpipes". If that's fine then I'd check your wiring.
Appreciate 0
      Yesterday, 12:46 PM   #4
sänd_mönstä
New Member
United_States
0
Rep
14
Posts

Drives: '11 335xi
Join Date: Jun 2014
Location: PA/MD

iTrader: (0)

I did have the "OEM/CATTED DPS" option unchecked in MHD when flsshing map 0.

I double checked the connections today and everything seems to be wired correctly. For some readon my O2 har ess shows a purple wire (4th wire towards the bottom), not that the color of insulation should matter.

https://drive.google.com/file/d/1stC...w?usp=drivesdk

The video below shows the current blinking sequence of the dp fix and the code it is throwing:


Last edited by sänd_mönstä; Yesterday at 03:14 PM.
Appreciate 0
      Yesterday, 10:12 PM   #5
HOT335MSPORT
Lieutenant
HOT335MSPORT's Avatar
United_States
15
Rep
426
Posts

Drives: E92 335i, Ducati 996
Join Date: Jun 2011
Location: Hickory, NC

iTrader: (11)

Quote:
Originally Posted by sänd_mönstä View Post
Hey guys,

I finished installing the VRSF DP fix on my 2011 n55 earlier today using the following DIY:

https://www.e90post.com/forums/showp...&postcount=303

The installation was a breeze, but the dp fix does not seem to be operating correctly. The blue LED on the device will blink to show that it is operational, but between every few blinks, it will stay solid for a few seconds and then resume blinking. Is this normal?

Also, the DME threw a code at the start of a drive cyle I performed earling this evening and later abandoned. The code was 2D1F: Oxygen sensor after catalytic converter, electrical: Short circuit to B+

FYI, I'm running MHD and have flashed to map 0.

Any help would be much appreciated!
I got the same fault you got when I installed mine, after doing more research, I found that the +12 and ground wire on the O2 sensor are monitor by the DME. It's looking for a short on the sensor, so if you hooked the sim like the post above, you're basically shorting it out, I'm not sure how others got it to work that way.

Here's what I did, I extended the wires on O2 sim about 2 ft so I can keep it in the DME box, safe from heat and moisture. Tap to a switched +12 power(red/purple) in DME box (turns on when DME wakes up and off when sleep). Ground is also in there (black). Please double check with a meter to confirm. I leave mine O2 sim installed all the time, has not been a problem for me.



Then run the yellow and white wires through the wire loom, there is already a hole at the bottom where you can fish the wires through to the O2 sensor. I used your picture,

Appreciate 0
      Today, 03:23 AM   #6
Divbetic
Private
United_States
14
Rep
52
Posts

Drives: '11 135i
Join Date: Feb 2018
Location: NorCal

iTrader: (0)

Wired up my adapter today, will update after I test it out. Basically combined these two posts
https://www.e90post.com/forums/showp...&postcount=303
https://f30.bimmerpost.com/forums/sh...5&postcount=62
Attached Images
  
__________________
2011 135i 6MT
MHD Stage 2, VRSF CP, VRSF DP, M Performance Exhaust
Appreciate 0
      Today, 03:38 AM   #7
BourneJack
Enlisted Member
3
Rep
46
Posts

Drives: BME E90
Join Date: Jun 2018
Location: US

iTrader: (0)

Quote:
Originally Posted by sänd_mönstä View Post
I did have the "OEM/CATTED DPS" option unchecked in MHD when flsshing map 0.

I double checked the connections today and everything seems to be wired correctly. For some readon my O2 har ess shows a purple wire (4th wire towards the bottom), not that the color of insulation should matter.

https://drive.google.com/file/d/1stC...w?usp=drivesdk

The video below shows the current blinking sequence of the dp fix and the code it is throwing:

+1
Appreciate 0
      Today, 06:38 PM   #8
sänd_mönstä
New Member
United_States
0
Rep
14
Posts

Drives: '11 335xi
Join Date: Jun 2014
Location: PA/MD

iTrader: (0)

Quote:
Originally Posted by HOT335MSPORT View Post

Then run the yellow and white wires through the wire loom, there is already a hole at the bottom where you can fish the wires through to the O2 sensor. I used your picture,
Glad you found a workaround!

Which wire goes to which? Yellow to +12v source (red/purple) and White to ground (black) or vice versa?
Appreciate 0
      Today, 06:41 PM   #9
sänd_mönstä
New Member
United_States
0
Rep
14
Posts

Drives: '11 335xi
Join Date: Jun 2014
Location: PA/MD

iTrader: (0)

Quote:
Originally Posted by Divbetic View Post
Wired up my adapter today, will update after I test it out. Basically combined these two posts
https://www.e90post.com/forums/showp...&postcount=303
https://f30.bimmerpost.com/forums/sh...5&postcount=62
This plug and play rig up is awesome. Any chance you have part numbers for the plugs?
Appreciate 0
      Today, 07:25 PM   #10
Divbetic
Private
United_States
14
Rep
52
Posts

Drives: '11 135i
Join Date: Feb 2018
Location: NorCal

iTrader: (0)

Quote:
Originally Posted by sänd_mönstä View Post
This plug and play rig up is awesome. Any chance you have part numbers for the plugs?
n55 downstream o2 sensor: 11787589475
n55 sensor module 1: 12517614588
__________________
2011 135i 6MT
MHD Stage 2, VRSF CP, VRSF DP, M Performance Exhaust
Appreciate 0
      Today, 08:39 PM   #11
HOT335MSPORT
Lieutenant
HOT335MSPORT's Avatar
United_States
15
Rep
426
Posts

Drives: E92 335i, Ducati 996
Join Date: Jun 2011
Location: Hickory, NC

iTrader: (11)

Quote:
Originally Posted by sänd_mönstä View Post
Glad you found a workaround!

Which wire goes to which? Yellow to +12v source (red/purple) and White to ground (black) or vice versa?
no don't do that, you will fried you sim
red on o2 sim goes to red/purple, black on o2 sim goes to black in DME box, yellow and white on o2 sim gose to o2 sensor, like you have it. the only difference now is you are not using the +12 (purple) and ground (grey) on the o2 sensor
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:25 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST