E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Misfiring after replacement



Reply
 
Thread Tools Search this Thread
      03-12-2020, 07:41 PM   #1
335iCruzer
Registered
335iCruzer's Avatar
0
Rep
4
Posts

Drives: 2008 BMW 335i
Join Date: Mar 2020
Location: Killeen, Texas

iTrader: (0)

Misfiring after replacement

Hey guys I have a 2008 bmw 335i around 126k miles. My service engine light came on and it said, misfiring in 1 and 3 and several cylinders. The car was having rough idling and shaking when starting it up. I replaced the spark plugs and ignition coils and it ran smooth for a bit and then the shaking came back and my engine light came on. Read the codes with Carly and now it's saying 1,2,3 are misfiring. Any idea on what it could be?
Appreciate 0
      03-13-2020, 10:19 PM   #2
NinetyEight740
Major General
NinetyEight740's Avatar
United_States
210
Rep
5,682
Posts

Drives: 2 - 2013 535i msport
Join Date: Nov 2008
Location: Orange County California

iTrader: (2)

Garage List
2010 E91  [0.00]
Send a message via AIM to NinetyEight740
Any of the spark plugs black or wet when you removed them? If so, leaking injector.
Appreciate 0
      03-29-2020, 07:06 PM   #3
tello2020
New Member
tello2020's Avatar
United_States
0
Rep
25
Posts

Drives: 2007 bmw 335i
Join Date: Mar 2020
Location: california

iTrader: (0)

HI I have the same problem 2007 bmw 335i
misfiring cylinders 1 2 3 change spark plugs,switch coils and injectors, from bank 2.
new o2 sensor bank 1 before cat, any one had this problem before?
Appreciate 0
      03-29-2020, 07:40 PM   #4
335iCruzer
Registered
335iCruzer's Avatar
0
Rep
4
Posts

Drives: 2008 BMW 335i
Join Date: Mar 2020
Location: Killeen, Texas

iTrader: (0)

Quote:
Originally Posted by tello2020 View Post
HI I have the same problem 2007 bmw 335i
misfiring cylinders 1 2 3 change spark plugs,switch coils and injectors, from bank 2.
new o2 sensor bank 1 before cat, any one had this problem before?
Quote:
Originally Posted by tello2020 View Post
HI I have the same problem 2007 bmw 335i
misfiring cylinders 1 2 3 change spark plugs,switch coils and injectors, from bank 2.
new o2 sensor bank 1 before cat, any one had this problem before?
FIXED! Ended up replacing the fuel injectors! When I replaced them they were black or oily. Once I replaced it, my BMW stop shaking and having rough idle. Also had it walnut blasted because it was so much built up in the intake.
Appreciate 0
      03-29-2020, 07:53 PM   #5
tello2020
New Member
tello2020's Avatar
United_States
0
Rep
25
Posts

Drives: 2007 bmw 335i
Join Date: Mar 2020
Location: california

iTrader: (0)

Quote:
Originally Posted by 335iCruzer View Post
FIXED! Ended up replacing the fuel injectors! When I replaced them they were black or oily. Once I replaced it, my BMW stop shaking and having rough idle. Also had it walnut blasted because it was so much built up in the intake.

hello did you replacing all 6 injectors new or only 3 from bank 1?
what I did I switch injectors from bank 2 to bank 1 just to see if the codes change to bank 2 but still the same.
Appreciate 0
      03-29-2020, 07:58 PM   #6
335iCruzer
Registered
335iCruzer's Avatar
0
Rep
4
Posts

Drives: 2008 BMW 335i
Join Date: Mar 2020
Location: Killeen, Texas

iTrader: (0)

Quote:
Originally Posted by tello2020 View Post
Quote:
Originally Posted by 335iCruzer View Post
FIXED! Ended up replacing the fuel injectors! When I replaced them they were black or oily. Once I replaced it, my BMW stop shaking and having rough idle. Also had it walnut blasted because it was so much built up in the intake.

hello did you replacing all 6 injectors new or only 3 from bank 1?
what I did I switch injectors from bank 2 to bank 1 just to see if the codes change to bank 2 but still the same.
I replaced injectors 1-3 because that's where my problem was for misfiring.
Appreciate 0
      03-29-2020, 08:09 PM   #7
tello2020
New Member
tello2020's Avatar
United_States
0
Rep
25
Posts

Drives: 2007 bmw 335i
Join Date: Mar 2020
Location: california

iTrader: (0)

Quote:
Originally Posted by 335iCruzer View Post
I replaced injectors 1-3 because that's where my problem was for misfiring.
I thought that changing the injectors from bank 2 to bank 1 would jump
the check engine to cylinders 4 5 6 but no, am not sure if my problem are the injectors, you bought new injectors where you bought them.
Appreciate 0
      03-29-2020, 08:22 PM   #8
335iCruzer
Registered
335iCruzer's Avatar
0
Rep
4
Posts

Drives: 2008 BMW 335i
Join Date: Mar 2020
Location: Killeen, Texas

iTrader: (0)

Quote:
Originally Posted by tello2020 View Post
Quote:
Originally Posted by 335iCruzer View Post
I replaced injectors 1-3 because that's where my problem was for misfiring.
I thought that changing the injectors from bank 2 to bank 1 would jump
the check engine to cylinders 4 5 6 but no, am not sure if my problem are the injectors, you bought new injectors where you bought them.
Quote:
Originally Posted by tello2020 View Post
Quote:
Originally Posted by 335iCruzer View Post
I replaced injectors 1-3 because that's where my problem was for misfiring.
I thought that changing the injectors from bank 2 to bank 1 would jump
the check engine to cylinders 4 5 6 but no, am not sure if my problem are the injectors, you bought new injectors where you bought them.
So like your current issue my BMW was misfiring. I replaced the coils and spark plugs, and that fixed the misfiring for maybe a week. The rough idle came back and I got CEL light again. I then knew replacing those didn't fix the issue so I replaced the injectors and haven't had a issue since. I bought them off FCPEURO.COM lifetime warranty and if for some reason that doesn't fix your issue they have hassle free returns and everything is OEM.
Appreciate 0
      03-29-2020, 08:38 PM   #9
tello2020
New Member
tello2020's Avatar
United_States
0
Rep
25
Posts

Drives: 2007 bmw 335i
Join Date: Mar 2020
Location: california

iTrader: (0)

Quote:
Originally Posted by 335iCruzer View Post
So like your current issue my BMW was misfiring. I replaced the coils and spark plugs, and that fixed the misfiring for maybe a week. The rough idle came back and I got CEL light again. I then knew replacing those didn't fix the issue so I replaced the injectors and haven't had a issue since. I bought them off FCPEURO.COM lifetime warranty and if for some reason that doesn't fix your issue they have hassle free returns and everything is OEM.
I will try to change to new injectors
thank you.

Last edited by tello2020; 03-29-2020 at 09:00 PM..
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:55 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST