E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > N43 Fuel Pressure Issues



Reply
 
Thread Tools Search this Thread
      07-04-2022, 04:01 PM   #1
zEDo
New Member
zEDo's Avatar
0
Rep
7
Posts

Drives: E90 320i LCI
Join Date: May 2022
Location: Romania

iTrader: (0)

N43 Fuel Pressure Issues

Hi everyone,

So I'm down this mad rabbit hole of chasing a missing injector adaptation/lernbit on my 2011 e90 320i with n43b20 170ps.
Long story short I think I narrowed it down to the Fuel Preparation System.

First of all my Low Pressure circuit fluctuates a bit out of spec. I believe ISTA+ specs the jitter of the circuit to 5bar +/- 0.2 bar which is quite liberal from what I've read in most places. I believe Bimmerprofs specs tolerances in +/- 0.1bar. My jitter at it's worst is almost +/- 0.3 bar.

Secondly my High Pressure circuit/rail is stuck at 150bar all the time, sometimes it rises a bit, most I've seen it rise since I started tracking it is 170bar. Bimmerprofs specs the HP circuit to rise from 150bar to 200bar from 2000rpm onwards. The jitter is within spec, I've never seen it rise or fall more than 0.08 bar.

Third of all, when shutting off the engine, BOTH HP and LP segments rise in pressure continuously for about 8 minutes(HP rises from 150bar to 238bar and LP rises from 5bar to 5.6bar) and then the slowly decrease.

A couple more things worth mentioning are that 2 or 3 times in the past 6 months I've had the engine randomly shut off when coming to a normal dead stop. No fault codes registered, I turned the engine back on after without any issues. The other thing is that sometimes I feel a feint smell of gas when starting the car. No smoke coming from the back.

Any help is much appreciated.

Cheers.
Attached Images
 
Appreciate 0
      07-05-2022, 07:44 PM   #2
cheerio
Private First Class
cheerio's Avatar
Australia
117
Rep
138
Posts

Drives: 2008 E90 325i
Join Date: Mar 2021
Location: Melbourne

iTrader: (0)

You might have better luck posting in the N54 forum, as the N43 wasn’t sold in the US and many other parts of the world.
Appreciate 0
      07-06-2022, 09:17 AM   #3
0l0dom0l0
Second Lieutenant
47
Rep
239
Posts

Drives: BMW E92 330i
Join Date: Jun 2020
Location: Uk

iTrader: (0)

Replaced the low and high pressure sensors?
Appreciate 0
      07-12-2022, 04:27 AM   #4
zEDo
New Member
zEDo's Avatar
0
Rep
7
Posts

Drives: E90 320i LCI
Join Date: May 2022
Location: Romania

iTrader: (0)

Thanks for the tips.
I'm planning on replacing both sensors preventively to see if that solves the issue as it is cheaper than buying a pressure test kit.
I'll post the results once I replace them. If that doesn't work next I will replace the fuel pressure regulator/filter. Do you guys recommend any AM sensors or just to stick with OE?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:40 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST