E90Post
 


Extreme Powerhouse
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Key Fob Intermittent



Reply
 
Thread Tools Search this Thread
      11-11-2018, 12:33 AM   #1
lime
New Member
2
Rep
13
Posts

Drives: 335i
Join Date: May 2018
Location: New Zealand

iTrader: (0)

Key Fob Intermittent

2008 335i with Comfort Access

Starting recently the key fob seems to be working intermittently. I replaced the battery twice but to no avail. It appears to be all buttons on the fob that are affected.

I just did some testing by standing in different spots around the car locking and unlocking it many times in quick succession. It worked maybe 70% of the time, but a couple of times when it wouldn't work it took about 30-45 seconds for it to come right and start working again. Initially I thought it was mainly standing in front of the car that was giving issues but after doing that testing I'm not so sure, it seems now to be randomly anyplace around the car. I only have the one key for it so can't try another.

Any ideas?
Appreciate 0
      11-11-2018, 01:37 AM   #2
ctuna
Major General
707
Rep
8,098
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

It will be harder to get a key when you don't have any.
And you will be more stressed.

Order one from BMW.

keyfob repair
https://www.e90post.com/forums/showthread.php?t=1510527
keyfob guy
https://www.bimmerfest.com/forums/sh...d.php?t=903551
https://www.bimmerfest.com/forums/sh...d.php?t=874226
https://www.facebook.com/GcodingBMW
https://www.e90post.com/forums/showt...&highlight=key
Appreciate 0
      11-11-2018, 04:35 PM   #3
nate93
Enlisted Member
2
Rep
45
Posts

Drives: 2011 E93
Join Date: Dec 2017
Location: Houston, Texas

iTrader: (0)

Quote:
Originally Posted by lime View Post
2008 335i with Comfort Access

Starting recently the key fob seems to be working intermittently. I replaced the battery twice but to no avail. It appears to be all buttons on the fob that are affected.

I just did some testing by standing in different spots around the car locking and unlocking it many times in quick succession. It worked maybe 70% of the time, but a couple of times when it wouldn't work it took about 30-45 seconds for it to come right and start working again. Initially I thought it was mainly standing in front of the car that was giving issues but after doing that testing I'm not so sure, it seems now to be randomly anyplace around the car. I only have the one key for it so can't try another.

Any ideas?

I had similar issue back when I first bought the car. Test this and report back, try standing really close to your car, if the remote works %100, and then it stops working as you are moving away from the car then let me know. If that is the case. Then you need to replace the FBD module.

The module is placed at different location depending on your model, I have an E93, the module is in the rear mirror, so I replaced that and my remote has been working perfectly ever since. So let me know and I can help locate where your FBD module is.
Appreciate 0
      Today, 08:13 AM   #4
lime
New Member
2
Rep
13
Posts

Drives: 335i
Join Date: May 2018
Location: New Zealand

iTrader: (0)

Quote:
Originally Posted by nate93 View Post
I had similar issue back when I first bought the car. Test this and report back, try standing really close to your car, if the remote works %100, and then it stops working as you are moving away from the car then let me know. If that is the case. Then you need to replace the FBD module.

The module is placed at different location depending on your model, I have an E93, the module is in the rear mirror, so I replaced that and my remote has been working perfectly ever since. So let me know and I can help locate where your FBD module is.
Thanks for the idea, for about 10 seconds I thought this was the problem, but then it started doing it randomly again from anywhere around the car and any distance. I did note however that if I do big bursts of locking and unlocking it will just stop reacting to any input for 10-30 seconds. Maybe that's a symptom, or more likely just a feature to stop accidental remote commands?

I'm starting to think it might be the remote, but it's hard to test without a spare. Is there any cheap way of testing this? Local price on a spare key is >$600
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:23 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST