E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > VTG Cannot Communicate



Reply
 
Thread Tools Search this Thread
      07-22-2018, 10:49 AM   #1
JCP0521
New Member
0
Rep
8
Posts

Drives: 2006 BMW 325xi
Join Date: Jul 2018
Location: Levittown, Pa

iTrader: (0)

Just purchased a 2006 BMW 325xi and have the common ABS, 4 x 4, Brake lLght displaying on my dash, Seller said it just needed a steering angle sensor., I removed it and cleaned off the disc carefully and replaced it. I scanned it with an Autel MaxiDas scanner and found the steering angle sensor to be working correctly, it displays the correct degree and zeros out when the wheel is perfectly straight, all 4 wheel speed sensors are reporting correctly According to the live data while driving, just replaced the transfer case actuator motor today and when I hook up the scanner I am unable to connect to the VTG Module. I had the same issue before and after the fixes I mentioned. I checked all fuses also which were fine.
I did order a new brake reservoir as it was reading Not OK , but the fluid was full, but it was reading OK when the float was at the bottom, seems weird that it displayed the opposite results.
Any idea what the multi dash light issue may be, Do I need to replace the VTG control module since I am unable to communicate with it, and I've tried several times and keep getting the same error code

Last edited by JCP0521; 07-22-2018 at 11:14 AM.
Appreciate 0
      07-22-2018, 08:00 PM   #2
nsjames
First Lieutenant
129
Rep
399
Posts

Drives: 08 328xi Touring
Join Date: May 2017
Location: ohio

iTrader: (0)

I would start with inspecting the wiring before I tossed new modules at it.

what kind of condition is the battery in?
Appreciate 0
      07-22-2018, 08:16 PM   #3
JCP0521
New Member
0
Rep
8
Posts

Drives: 2006 BMW 325xi
Join Date: Jul 2018
Location: Levittown, Pa

iTrader: (0)

I checked a lot of live data with my scanner and the battery is good, wheel sensors display good, steering angle sensor shows it's reading correctly, I'm able to activate the ABS pump motor, all the cruise control button show depressed when I press them, removed the control unit under the passenger side floor and it looks like it was replaced as there was a bolt missing from the cover, I unplugged both connections, they look brand new. Tried to reconnect the scanner and still could not read VTG
Appreciate 0
      07-24-2018, 10:09 PM   #4
nsjames
First Lieutenant
129
Rep
399
Posts

Drives: 08 328xi Touring
Join Date: May 2017
Location: ohio

iTrader: (0)

then it's looking more like failure.

did you ohm out the can bus wires to the module? You should get 120 ohms IIRC. You'll have to check newtis for sure.
if not, wiring issue.
Appreciate 0
      07-24-2018, 10:12 PM   #5
JCP0521
New Member
0
Rep
8
Posts

Drives: 2006 BMW 325xi
Join Date: Jul 2018
Location: Levittown, Pa

iTrader: (0)

Ok I'll do that. I have an odd issue, I ordered a new brake reservoir cap with sensor As the previous one was reading not OK on the scanner I replaced it today and the new one reads not OK on the scanner but if I remove it from the reservoir and let the float drop to the bottom then it reads OK. It's like the computer is reading it in opposite
The wiring looks fine I just can't make any sense of it
Appreciate 0
      07-31-2018, 06:40 PM   #6
JCP0521
New Member
0
Rep
8
Posts

Drives: 2006 BMW 325xi
Join Date: Jul 2018
Location: Levittown, Pa

iTrader: (0)

Just an update to my original post, I bought a used transfer case module from eBay for $125 from the same year / make and model BMW, plugged it in and all my lights went out. What a relief. Hope this helps someone else!!!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:10 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST