E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Cosmetic and Lighting Modifications (exterior/interior) > Replaced LCI tail light but turn signal still bad



Reply
 
Thread Tools Search this Thread
      05-11-2018, 05:27 PM   #1
LeYoshi
Private First Class
LeYoshi's Avatar
10
Rep
115
Posts

Drives: 2011 BMW 335i E92
Join Date: Nov 2016
Location: Dallas, Tx

iTrader: (0)

Replaced LCI tail light but turn signal still bad

Hello everyone,

I've seen posts about a bad read turn signal everywhere on this forum and I now also have this issue.

My rear passenger side turn signal (LED Board) is out and I've been looking for a solution for awhile now and still haven't found a decent answer. I ordered a new rear tail light and installed it, however I STILL HAVE THE SAME ISSUE.

I read somewhere that there is no fuse for the rear tail lights, can anyone confirm that?
Can this be a result of a bad module?
Could anyone point me in the right direction to finding a fix for this BS?
Attached Images
 
Appreciate 0
      05-11-2018, 11:07 PM   #2
6ixSpd
Save the manuals!
6ixSpd's Avatar
Canada
2543
Rep
4,275
Posts

Drives: '12 M3 6MT, '09 328i 6MT
Join Date: Feb 2016
Location: 416

iTrader: (1)

How long has it been out? You may have tripped the short circuit counter on that turn signal which needs to be reset via Tool32. If that happened, the car shuts down that circuit entirely which could explain why it's not turning on even with the new tail light assembly.
__________________
'12 M3 6MT Alpine White + Fox Red Extended | '09 328i 6MT Space Gray + Saddle Brown

Appreciate 0
      05-12-2018, 12:33 PM   #3
LeYoshi
Private First Class
LeYoshi's Avatar
10
Rep
115
Posts

Drives: 2011 BMW 335i E92
Join Date: Nov 2016
Location: Dallas, Tx

iTrader: (0)

Quote:
Originally Posted by 6ixSpd View Post
How long has it been out? You may have tripped the short circuit counter on that turn signal which needs to be reset via Tool32. If that happened, the car shuts down that circuit entirely which could explain why it's not turning on even with the new tail light assembly.
It went out about a month ago, am I able to take it to my local BMW shop to have them diagnose it through tool32?
Appreciate 0
      08-07-2018, 12:13 AM   #4
allstar335is
Private
2
Rep
50
Posts

Drives: 335is
Join Date: Feb 2015
Location: toronto

iTrader: (0)

Quote:
Originally Posted by LeYoshi View Post
Hello everyone,

I've seen posts about a bad read turn signal everywhere on this forum and I now also have this issue.

My rear passenger side turn signal (LED Board) is out and I've been looking for a solution for awhile now and still haven't found a decent answer. I ordered a new rear tail light and installed it, however I STILL HAVE THE SAME ISSUE.

I read somewhere that there is no fuse for the rear tail lights, can anyone confirm that?
Can this be a result of a bad module?
Could anyone point me in the right direction to finding a fix for this BS?


Is the old tail
Light for sale?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:16 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST