E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY Powered seat retrofit (WIP)



Reply
 
Thread Tools Search this Thread
      07-23-2018, 01:24 PM   #353
ptpending
Lieutenant Colonel
190
Rep
1,649
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (1)

you can get left (LHD) driver control panel from e92
__________________
E91 2006. Retrofits:High beam assistant, Individual Audio, Autodim mirrors, CIC, Combox(USB and Bluetooth), Electric Sport Seats, Light package, Front PDC, Heated Steering Wheel, Happy Robot, Climate Comfort Windscreen, Blackline rear lights.
Appreciate 0
      07-23-2018, 02:15 PM   #354
dextuar
Enlisted Member
1
Rep
38
Posts

Drives: BMW E90
Join Date: Jun 2016
Location: Sofia, Bulgaria

iTrader: (0)

Yes, the only problem is there is nowhere I can find the LHD for the passenger seat and I guess there is no way how I can modify the current module with memory so that it stays on the passenger seat

This is what I actually need.


Appreciate 0
      07-24-2018, 03:23 PM   #355
pennybond
Registered
0
Rep
1
Posts

Drives: 1984 528e
Join Date: Jul 2018
Location: Portland, OR

iTrader: (0)

Retro Fit in 1984 528e

Hello,

I recently purchased a set of E90 Sport, power, lumbar, seat heating seats and wanted to install these in my '84 528e. Will I be able to get the seat heating working as my car obviously has no CANBUS or way to generate a PWM signal to the seat heating modules. I have found E90 seat heating switches on Ebay but it looks like the PWM signal is generated in the Juction box? (also do not have.)


Thanks!

(I have gotten all the other power features to work, however!)
Appreciate 0
      08-20-2018, 08:39 PM   #356
Bmachine
New Member
0
Rep
8
Posts

Drives: '73 BMW 3.0cs
Join Date: Jun 2018
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by pennybond View Post
Hello,

I recently purchased a set of E90 Sport, power, lumbar, seat heating seats and wanted to install these in my '84 528e. Will I be able to get the seat heating working as my car obviously has no CANBUS or way to generate a PWM signal to the seat heating modules. I have found E90 seat heating switches on Ebay but it looks like the PWM signal is generated in the Juction box? (also do not have.)


Thanks!

(I have gotten all the other power features to work, however!)
How did you get all the other power features to work without the BUS?
Appreciate 0
      08-25-2018, 09:14 PM   #357
Luizbaum
New Member
Brazil
0
Rep
17
Posts

Drives: E90 325i LCI
Join Date: Apr 2018
Location: Brazil

iTrader: (0)

hello friends, I read the whole topic so that I could definitely understand, and even then I'm still kind of lost, there are many variations. well i have a 325i 2011 partially electric and no memory seats and i bought the all-electric sport seats from a 130i 2010, so I understood that the memory function is necessary that the k-can is connected correctly on pins 2 and 3, I am sure ? and the lumbar adjustments I have to go through the gallows from pin 4 to 7 and from 8 to 13 right?
Appreciate 0
      08-26-2018, 05:46 PM   #358
Luizbaum
New Member
Brazil
0
Rep
17
Posts

Drives: E90 325i LCI
Join Date: Apr 2018
Location: Brazil

iTrader: (0)

Hello friends, today I went to disassemble the connector of my car, to see which pins are missing, well, I turned off the battery so that there were no airbag errors, I removed the yellow plug I took a photo, and I connected again, when I turned on the car, it appeared error airbag, what could I have done wrong? the error that appears is 0093AE. and whenever I clear the fault, it returns. sorry for my english,
I'm trying to be as clean as I can
Appreciate 0
      08-26-2018, 06:49 PM   #359
Luizbaum
New Member
Brazil
0
Rep
17
Posts

Drives: E90 325i LCI
Join Date: Apr 2018
Location: Brazil

iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
Great thread. Seriously, I read it twice to make sure I understood most of it.
I am yet to read all the attachments in the first post.
So far I am planning to install sports memory seats with heating.
I have few questions;
1- What is seat side and car side? In Uk, we use driver side (O/S) and passenger side (N/S). So what are these seat and car sides?
2- What if you do not have heating? I guess I've to read heating seat retrofit to find out where to direct the +ve and -ve wires in fuse box and how?
3- I will be connecting K-Can of driver side seat. And on passenger side, I need to connect PWD (first blue / white wire) of passenger side to junction box?
4- What connector is this?





And I hope somebody will answer these before I start experimenting this.

(P.S: I am moving from ordinary SE seats to Sports heated electrical seats with memory.)

apparently this white cable is from the airbag in my car, a 325i lci 2011. now things have become difficult for me, since already bought seats of another car, a 2009 and they do not have this connector.
Appreciate 0
      08-26-2018, 06:57 PM   #360
Luizbaum
New Member
Brazil
0
Rep
17
Posts

Drives: E90 325i LCI
Join Date: Apr 2018
Location: Brazil

iTrader: (0)

my connector with the white two-way plug






here the connectors of the seats I bought




I still do not know what to do.
Appreciate 0
      09-07-2018, 10:22 AM   #361
Movhan
Registered
Denmark
0
Rep
2
Posts

Drives: BMW E90 320D LCI
Join Date: Mar 2018
Location: Denmark

iTrader: (0)

Hello everyone. Thanks for this fantastic thread, it is very useful.
I switched from completely manual seats to full electric with seat heating and memory. I followed this thread all the way and in the end everything worked. After a few minutes the passenger seat stopped working and i thing it is because of pin 1 and 5. are they necessary? where should i connect them? Isn't there any other easy way to connect them than the junction box?
Appreciate 0
      09-12-2018, 06:10 AM   #362
DavesZed
Enlisted Member
United Kingdom
14
Rep
49
Posts

Drives: BMW E89 23i, 2011
Join Date: Nov 2015
Location: Grantham, UK

iTrader: (0)

Exclamation

Quote:
Originally Posted by Movhan View Post
Hello everyone. Thanks for this fantastic thread, it is very useful.
I switched from completely manual seats to full electric with seat heating and memory. I followed this thread all the way and in the end everything worked. After a few minutes the passenger seat stopped working and i thing it is because of pin 1 and 5. are they necessary? where should i connect them? Isn't there any other easy way to connect them than the junction box?
When you say they stopped working, what was you doing at the time?
I ask because I had exactly the same on mine. I originally had just heated seats and I decided to jumper the power lead to power both the seat heating and motors from the single input.
Then my wife decided that she likes the heated seat so tried out the new motorised seat at the same time and it failed with her almost fully forward (she wasn't impressed as we were about 20 miles from home at the time!!). But it only had the 15a fuse instead of the 30a it would have had if it had come from the factory. I replaced it with a 30a fuse (wire grade is the same, well in mine it is!) and it works perfectly.
So to sum up, the seat heater and motor control cannot be operated at the same time if it is only powered through a 15a fuse, it needs to be a 30a circuit.
Just a thought.
__________________
Dave
2011, 23i, Grey with Red leather.... relatively basic (getting less and less basic with every new retrofit)!
Appreciate 0
      09-21-2018, 10:26 PM   #363
gregolas
New Member
3
Rep
17
Posts

Drives: BMW 335d
Join Date: Mar 2018
Location: Seattle

iTrader: (0)

EDIT: I had to add the PWM wire for the passenger seat. ALL is working now!


Alright, I am stumped. I have read through all of the thread 7-8 times at least and I still can't get my passenger seat to fire.

I installed a set of heated, memory M3 seats in my 2011 M Sport (has power seat/bolsters, memory, no heat). I added the PWM wire for the passenger seat into the #1 slot to 38 on x14270, and bridged the power accordingly so everything is wired per the guide here. Driver seat works fine and heats quickly, but I get a code A6E1 on the JBBF for the passenger seat heating.

I have added the $494 to the VO in the CAS, FRM, IHK, and JBBF.

I cannot find the SHFA_PWM code in the JBBF TRC file from NCS, and have pulled other modules trying to search for it (with no luck).

The ONLY thing I can think of at this point is the passenger seat module is bad. I get the seat button on the passenger side to turn on, but the seat won't heat. If I turn it off by hitting the button it gets down to one light and then automatically turns the light off without continuing to press the button.

It will also light one light (low setting) if I try to activate it again, instead of all three (high setting).

If anyone has any ideas on this or if there is another place to code please let me know. I have been going at this all week with incremental progress.

Last edited by gregolas; Yesterday at 05:49 PM.
Appreciate 0
      09-25-2018, 03:30 AM   #364
Movhan
Registered
Denmark
0
Rep
2
Posts

Drives: BMW E90 320D LCI
Join Date: Mar 2018
Location: Denmark

iTrader: (0)

Quote:
Originally Posted by DavesZed View Post
When you say they stopped working, what was you doing at the time?
I ask because I had exactly the same on mine. I originally had just heated seats and I decided to jumper the power lead to power both the seat heating and motors from the single input.
Then my wife decided that she likes the heated seat so tried out the new motorised seat at the same time and it failed with her almost fully forward (she wasn't impressed as we were about 20 miles from home at the time!!). But it only had the 15a fuse instead of the 30a it would have had if it had come from the factory. I replaced it with a 30a fuse (wire grade is the same, well in mine it is!) and it works perfectly.
So to sum up, the seat heater and motor control cannot be operated at the same time if it is only powered through a 15a fuse, it needs to be a 30a circuit.
Just a thought.

Hi. I found out that the ground wire was cut and didn't have any connection. I replaced it and i worked fine but still no lumber or heating. Next thing i'll do is connect pin 1 to pin 38 in junction box x14270 and pin 5 to fuse box F10 with 5A fuse.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:55 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST