E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Known resolution for the "sticky brake" problem?



Reply
 
Thread Tools Search this Thread
      04-22-2008, 06:38 AM   #1
Notorious
Scrumtralecent
3
Rep
97
Posts

Drives: 335i
Join Date: May 2007
Location: West Coast Canada

iTrader: (0)

Known resolution for the "sticky brake" problem?

Is there a known fix for the sticky brake problem in the E9x? In the past i've read that a Progman update would fix it, but there doesn't seem to be anything offical about that. Any insight?
Appreciate 0
      04-22-2008, 09:16 AM   #2
F32Fleet
Major General
F32Fleet's Avatar
United_States
937
Rep
7,047
Posts

Drives: 2015 435i
Join Date: May 2005
Location: Southeastern US

iTrader: (0)

Never heard of such. There was a "problem" w/comfort stop around the time of the initial launch, and I haven't even heard anything about that in almost 2 yrs.
Appreciate 0
      04-22-2008, 09:29 AM   #3
Notorious
Scrumtralecent
3
Rep
97
Posts

Drives: 335i
Join Date: May 2007
Location: West Coast Canada

iTrader: (0)

Quote:
Originally Posted by Socom View Post
Never heard of such. There was a "problem" w/comfort stop around the time of the initial launch, and I haven't even heard anything about that in almost 2 yrs.
Never heard of the problem or the fix?

I've seen numerous people complain about it on these forums, and for those that don't know, im reffering to the issue of the brakes not immediately releasing when your foot is lifted from the pedal from a stop, giving a "sticking" sensation before releasing and lurching forward. I've seen it most commonly reffered to as "sticky brakes" here on E90post.
Appreciate 0
      04-22-2008, 09:32 AM   #4
stefman
.::fel8me::.
stefman's Avatar
Canada
5
Rep
453
Posts

Drives: 335i Black Sapphire Coral Red
Join Date: Apr 2007
Location: Singapore

iTrader: (0)

I have sticky brakes and it suck! Any solution?
__________________
E92 335i ordered April 28, 2007.....delivered 24 January 2008

Worth the wait
Appreciate 0
      04-22-2008, 09:46 AM   #5
Tag
Brigadier General
Tag's Avatar
United_States
3404
Rep
4,414
Posts

Drives: bimmer
Join Date: Jan 2007
Location: CHICAGO

iTrader: (2)

I got PROGMAN ver. 27 a while back which helped alleviate the sticky brakes. Its not as bad as before, but it's still there. I don't know if its been completely fixed in the latest PROGMAN
Appreciate 0
      04-22-2008, 02:27 PM   #6
Streetfish
Second Lieutenant
United_States
3
Rep
297
Posts

Drives: 2011 535i xdrive
Join Date: Mar 2008
Location: NJ

iTrader: (0)

this is a feature of the car - its called break assist
__________________
2008 328i Coupe
Monaco Blue / Black Leatherette / Dark Burl
Sport Package/ Power Seats / Heated Seats / Park Distance Control
Appreciate 0
      04-22-2008, 03:47 PM   #7
Tag
Brigadier General
Tag's Avatar
United_States
3404
Rep
4,414
Posts

Drives: bimmer
Join Date: Jan 2007
Location: CHICAGO

iTrader: (2)

Quote:
Originally Posted by Streetfish View Post
this is a feature of the car - its called break assist
Great in theory, poor in practice. It should be called brake desist.
Appreciate 0
      04-22-2008, 03:50 PM   #8
Streetfish
Second Lieutenant
United_States
3
Rep
297
Posts

Drives: 2011 535i xdrive
Join Date: Mar 2008
Location: NJ

iTrader: (0)

perhaps it should only engage when on a hill and only for MT cars.
__________________
2008 328i Coupe
Monaco Blue / Black Leatherette / Dark Burl
Sport Package/ Power Seats / Heated Seats / Park Distance Control
Appreciate 0
      04-22-2008, 04:02 PM   #9
f30er
Captain
United_States
48
Rep
949
Posts

Drives: F30 335i
Join Date: Jan 2007
Location: OTP

iTrader: (6)

Garage List
2007 E92 335i  [3.00]
I also used to have the problem. The dealer wouldn't even upgrade my Progman although it supposedly fixes the problem. About a month ago, I had my battery disconnected while taking out the airbag for the paddle shifter mod, and then a day or two later, I also reset my transmission. And now, it doesn't do it anymore! Just try disconnecting the battery for a little while, and then reset the transmission if it's an auto and see what happens.....
Appreciate 0
      04-22-2008, 04:41 PM   #10
AHM99
Private
United_States
3
Rep
58
Posts

Drives: 335i - E90
Join Date: Mar 2008
Location: Westminster, MD

iTrader: (1)

Quote:
Originally Posted by tag824 View Post
I got PROGMAN ver. 27 a while back which helped alleviate the sticky brakes. Its not as bad as before, but it's still there. I don't know if its been completely fixed in the latest PROGMAN
same way as you.
BMW reflashed ECU and problem went away, but not completely, there is hint of it once in while.
Appreciate 0
      04-22-2008, 04:48 PM   #11
rrandyy
Captain
13
Rep
800
Posts

Drives: E92 328
Join Date: Sep 2006
Location: California

iTrader: (0)

Yeah, the issue is still there...
Appreciate 0
      04-22-2008, 05:03 PM   #12
Revlis
Now With 33% MORE Sarcasm Free!
Revlis's Avatar
United_States
-12
Rep
3,443
Posts

Drives: 335is
Join Date: Feb 2007
Location: Seattle Area, WA

iTrader: (0)

Yeah, Never heard of it... Brake assist does what it's supposed to do, sometimes it engages when I think I am pretty level otherwise it's mostly transparent.
__________________

'13 TiAg over Coral, 335is | DCT | Prem | L7 | Nav/Idrive | CA | 19" "-------"

A BMW is Just a Car, it doesn't make you smart, handsome, cool, or wealthy. Get over it.
Appreciate 0
      04-22-2008, 05:16 PM   #13
Tag
Brigadier General
Tag's Avatar
United_States
3404
Rep
4,414
Posts

Drives: bimmer
Join Date: Jan 2007
Location: CHICAGO

iTrader: (2)

Quote:
Originally Posted by Revlis View Post
Yeah, Never heard of it... Brake assist does what it's supposed to do, sometimes it engages when I think I am pretty level otherwise it's mostly transparent.
Stick or Auto?
Appreciate 0
      04-22-2008, 05:17 PM   #14
Revlis
Now With 33% MORE Sarcasm Free!
Revlis's Avatar
United_States
-12
Rep
3,443
Posts

Drives: 335is
Join Date: Feb 2007
Location: Seattle Area, WA

iTrader: (0)

Quote:
Originally Posted by tag824 View Post
Stick or Auto?
Manual.
__________________

'13 TiAg over Coral, 335is | DCT | Prem | L7 | Nav/Idrive | CA | 19" "-------"

A BMW is Just a Car, it doesn't make you smart, handsome, cool, or wealthy. Get over it.
Appreciate 0
      04-22-2008, 05:22 PM   #15
Tag
Brigadier General
Tag's Avatar
United_States
3404
Rep
4,414
Posts

Drives: bimmer
Join Date: Jan 2007
Location: CHICAGO

iTrader: (2)

It seems this issue is more prevalent in cars with an auto trans
Appreciate 0
      04-22-2008, 05:45 PM   #16
f30er
Captain
United_States
48
Rep
949
Posts

Drives: F30 335i
Join Date: Jan 2007
Location: OTP

iTrader: (6)

Garage List
2007 E92 335i  [3.00]
Quote:
Originally Posted by Revlis View Post
Yeah, Never heard of it... Brake assist does what it's supposed to do, sometimes it engages when I think I am pretty level otherwise it's mostly transparent.
Easiest way to describe it is say you're coming up on a red light and you start slowing down....right when you're going ~2-3 mph, the light turns green....so you take your foot off the brake, and onto the gas (not stomping on it, just normal light pressure)....this is where it gets weird, the car doesn't do anything at first, then, it sort of "jumps" forward.....feeling almost as if either the brake assist wasn't letting go of the brakes, or, the auto transmission downshifted into 1st for a split second before going back to normal......

It may even be a combination of both which would explain why resetting the tranny & ecu seem to make the problem go away(for now).
Appreciate 0
      04-22-2008, 06:01 PM   #17
Revlis
Now With 33% MORE Sarcasm Free!
Revlis's Avatar
United_States
-12
Rep
3,443
Posts

Drives: 335is
Join Date: Feb 2007
Location: Seattle Area, WA

iTrader: (0)

Quote:
Originally Posted by e92er View Post
Easiest way to describe it is say you're coming up on a red light and you start slowing down....right when you're going ~2-3 mph, the light turns green....so you take your foot off the brake, and onto the gas (not stomping on it, just normal light pressure)....this is where it gets weird, the car doesn't do anything at first, then, it sort of "jumps" forward.....feeling almost as if either the brake assist wasn't letting go of the brakes, or, the auto transmission downshifted into 1st for a split second before going back to normal......

It may even be a combination of both which would explain why resetting the tranny & ecu seem to make the problem go away(for now).
Pretty Good Description...
__________________

'13 TiAg over Coral, 335is | DCT | Prem | L7 | Nav/Idrive | CA | 19" "-------"

A BMW is Just a Car, it doesn't make you smart, handsome, cool, or wealthy. Get over it.
Appreciate 0
      04-22-2008, 06:25 PM   #18
thegeneral101
Colonel
United_States
54
Rep
2,305
Posts

Drives: '15 Z06,'13 750Li,'11 Raptor
Join Date: Nov 2006
Location: Miami/Michigan

iTrader: (0)

Quote:
Originally Posted by tag824 View Post
It seems this issue is more prevalent in cars with an auto trans
wow, i have been on this board for a LONG time and just now find this thread! I have been having the sticky break problem in my auto E92. like when I let up off the brake to move from a stop it takes a second or two for it to move and I always thought there was something wrong with the brakes and thats why its would stick....guess this is a common issue....
__________________
Appreciate 0
      04-22-2008, 06:26 PM   #19
Notorious
Scrumtralecent
3
Rep
97
Posts

Drives: 335i
Join Date: May 2007
Location: West Coast Canada

iTrader: (0)

Quote:
Originally Posted by e92er View Post
Easiest way to describe it is say you're coming up on a red light and you start slowing down....right when you're going ~2-3 mph, the light turns green....so you take your foot off the brake, and onto the gas (not stomping on it, just normal light pressure)....this is where it gets weird, the car doesn't do anything at first, then, it sort of "jumps" forward.....feeling almost as if either the brake assist wasn't letting go of the brakes, or, the auto transmission downshifted into 1st for a split second before going back to normal......

It may even be a combination of both which would explain why resetting the tranny & ecu seem to make the problem go away(for now).
Hmm, i read in another thread many people saying the trans reset was a myth... I may give it a go, along with the battery disconnect. I also have the Auto.

Has anyone talked to thier dealership about this problem?
Appreciate 0
      04-22-2008, 07:08 PM   #20
thegeneral101
Colonel
United_States
54
Rep
2,305
Posts

Drives: '15 Z06,'13 750Li,'11 Raptor
Join Date: Nov 2006
Location: Miami/Michigan

iTrader: (0)

Quote:
Originally Posted by Notorious View Post
Hmm, i read in another thread many people saying the trans reset was a myth... I may give it a go, along with the battery disconnect. I also have the Auto.

Has anyone talked to thier dealership about this problem?
yeah I talked to the dealership and they said it was the brake assist
__________________
Appreciate 0
      04-22-2008, 08:26 PM   #21
f30er
Captain
United_States
48
Rep
949
Posts

Drives: F30 335i
Join Date: Jan 2007
Location: OTP

iTrader: (6)

Garage List
2007 E92 335i  [3.00]
Quote:
Originally Posted by Notorious View Post
Has anyone talked to thier dealership about this problem?
They couldn't replicate the problem and so there's nothing they could do...took a tech for a drive, he said i was giving it too much gas and that I needed to learn how to go easy on my car
Appreciate 0
      04-22-2008, 08:44 PM   #22
smithrh
Lieutenant
9
Rep
482
Posts

Drives: 2000 328, 2006 330
Join Date: Jul 2005
Location: Chicago Burbs

iTrader: (0)

Supposedly there's a TSB for this problem - but I haven't actually seen it.

I did bitch at my CA and SA enough that they put a good person on it, they "applied the TSB" and sure enough, the problem went away... temporarily.

Supposedly this has something to do with the torque converter, but I'm not sure what I believe anymore. All I can say is that it's negatively impacting my opinion of BMW every damn time I drive the car, and I'm not at all sure I want to buy another BMW at this point. I have been close to pulling the trigger on a 335i, but I can't until this gets permanently fixed, which I'm starting to doubt will ever happen.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:59 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST