E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Electrical Malfunction and various related issues



Reply
 
Thread Tools Search this Thread
      09-08-2014, 03:00 PM   #1
lwrs10
New Member
4
Rep
5
Posts

Drives: '08 335i
Join Date: Jul 2014
Location: United States

iTrader: (0)

Electrical Malfunction and various related issues

Hello, hope someone might be able to help me out.


Just bought my car less than a month ago. 2008 335i sedan, premium package, with idrive and nav. 3 days ago, the gauge cluster started freaking out, and idrive kept saying "electrical system malfunction". It seems to be temp related, as in the cooler it is outside the worse it is.

Since I am out of town right now I have no choice but to continue driving it. But....on the way home last night the engine shut off multiple times, as well as I lost the brakes completely twice while the engine was still running. I had to stop with the emergency brake.

I have scanned it with an ELM27 bluetooth OBD2 scanner and the Ivini app on my phone, and it has 62 codes. I reset all codes and it stopped acting up as bad, but is still popping up every 10 minutes or so with the electrical malfunction.

Today I took half the car apart and checked every power wire from the battery for corrosion and voltage drop with a meter, as well as every ground I could find. This includes under the hood, in the trunk, and center console/dash grounds. I even re-seated every connector I could find under the dash. I also re-seated every fuse in the car as well as the electrical distribution box under the hood where the ECM is. I also measured voltage drop in every circuit from the fuse box.

I did not find anything wrong, and nothing helped. Battery is a nice 12.5-13 volts after sitting overnight, and while running is a steady 14.4-14.6v. I have even connected my multimeter to the input of the fusebox while driving and did not see any voltage issues as it goes "haywire".

All the codes were ECU failures, can bus errors, failure to connect to module this/that, etc.

Here is a list of codes:

Fault Report - BMWhat - Version: 13.03

ID1: 36a20556-9ac1-4525-b15e-3845327810c7-86bID2: f8421777-0edb-4ae7-883b-c29d55b2e6ef-be2

INFO: 0C0EC9B8A8988B836552433029F

Base: E90

Faults: 62

ECUs: 20

Model: 335 i N 54 B 30 A

Battery: 11.0V

Normal communication

Normal connection

Date: 2014-09-07 12:04:00

CBT.

Version: 17

Device: >HTC< >cingular_us< >HTC One X+<

Motor Control:

Engine / Motor

Fehler: Power Management / Power management, standby power control / Power-management power failure / Power-Management, Closed-Circuit-ueberwachung / Power management idle current of injury

Code: 2DED

Fehler: Message (cluster state) / Message Error PT CAN / Message (cluster status)

Code: CDA8

Fehler: Message (terminal status, 130) / Message (terminal status) / Message (final, 130)

Code: CDA0

Fehler: Control terminal 15 / Valvetronic actuator motor

Code: 2DC3

Fehler: Message (outdoor temperature) / Message (outside temperature)

Code: CD94

Fehler: Message (air conditioning demand) / Message Error PT CAN / message fault code

Code: CDA9

Fehler: :Motorabstellzeit, plausibility / ignition timing adjustment / engine turn-off time

Code: 2F84

Fehler: :Motorabstellzeit, plausibility / engine turn-off time

Code: 2F81

Fehler: :Motorabstellzeit, plausibility / engine turn-off time

Code: 2F7F

ABS / DSC / Brake:

Dynamische Stabilitaets Kontrolle / DSC

Fehler: Instrument cluster missing km data PT-CAN / F CAN fault / CAN message Combination / CAN error message

Code: D359

Fehler: Chassis number message timeout PT-CAN / CAN error message / PT CAN fault

Code: D361

Fehler: Gateway Terminal 1 status message PT-CAN / PT CAN fault / CAN message Combination / CAN error message

Code: D35A

Fehler: Instrument cluster 1 outdoor temperature PT-CAN / PT CAN fault / EGS CAN message / CAN error message

Code: D358

Fehler: Instrument cluster 3 PT-CAN / PT CAN fault / CAN message / CAN error message

Code: D363

Airbag:

Airbag

Fehler: General Bus Wiring error / General Bus cable fault

Code: C944

Fehler: speed signal is missing / Capacity of control energy / speed signal missing / Speed Speed signal missing

Code: 93FB

Transmission Control:

Transmission / Getriebe GS 19

Fehler: :SMG 1

Code: CF35

Transmission / Getriebesteuerung

ECU not present/no response from ECU

Instrument cluster:

Instrument cluster / Kombiinstrument

Fehler: CAN signal fault DSC

Code: A3B9

Fehler: CAN signal fault / CAN ID failure

Code: A3B6

Fehler: unknown failure

Code: A3BC

Fehler: CAN signal fault engine idle / CAN ID failure

Code: A3AE

Fehler: CAN signal fault indicator

Code: A3B1

Fehler: CAN signal fault transmission / CAN ID failure

Code: A3AA

Fehler: CAN signal fault gateway / CAN ID failure

Code: A3BD

Fehler: ID failure

Code: A550

Fehler: CAN LOW ERROR

Code: E104

Fehler: K-Can Bus off

Code: E107

Central info display / Zentrales Display

Fehler: Communication CAN Low / Line fault detection K-CAN

Code: E5C4

Fehler: Communication Bus error / Errors out of the bus K-CAN

Code: E5C7

Light/Rain Control:

High-beam / Fernlichtassistent

ECU not present/no response from ECU

Heating / AC:

Air conditioning / Klimaanlage

ECU OK, no Fault Code

Immobilizer System:

CAS

Fehler: Interlock PLOCK error

Code: A0B6

Fehler: Central control timeout

Code: D904

Fehler: Signal detection error rate

Code: A0B5

Fehler: Signal detection error rate

Code: A118

Fehler: brake light

Code: A0B0

Fehler: Input P N signal fault from EGS

Code: A0B1

Fehler: CAN bus_off

Code: D907

Park distance control:

Park Distance Control / PDC

ECU not present/no response from ECU

Cruise Control:

Active cruise control / Aktive Geschwindigkeitsregelung

ECU not present/no response from ECU

Sunroof / Roof:

Sunroof / Schiebedach

ECU not present/no response from ECU

Roof / Dach

ECU not present/no response from ECU

Audio/Navi/Communication:

Phone / Telefon

Fehler: sorry, unknown fault

Code: A37D

Fehler: Ring break diagnosis error / unknown fault

Code: D690

Tuner Antenna / Antenne

ECU OK, no Fault Code

Hybrid Radio USA

ECU not present/no response from ECU

Digital Satellite-Tuner USA

ECU not present/no response from ECU

Navigation

ECU not present/no response from ECU

CD-Changer / Wechsler

ECU not present/no response from ECU

Audio-System

ECU OK, no Fault Code

Video

ECU not present/no response from ECU

DAB

ECU not present/no response from ECU

Seats:

Seats / Sitze

Fehler: Bus cable fault / CAN-Low, physical bus error

Code: E444

Fehler: Controllers, bus-off

Code: E447

Seats / Sitze

ECU not present/no response from ECU

Systems:

Junction Box Passenger / Beifahrer

Fehler: :K-CAN communikation / PT-CAN Controller

Code: C908

Fehler: K-CAN communication / K-CAN communikation / K-CAN Controller

Code: C907

Fehler: :K-Can failure / Terminal status timeout

Code: C91E

Fehler: PT CAN failure / K-Can failure

Code: C914

Fehler: Internal error of the sensor - K-LIN 6 xAUC sensor / Short circuit to positive or open circuit (AUC)

Code: A6CF

Fehler: PT-CAN communication / PT-CAN communikation

Code: C90B

Fuel pump / Kraftstoffpumpe

ECU OK, no Fault Code

Tire pressure control / Reifendruck Kontrolle

Fehler: CAN error-Low / CAN low error

Code: D104

Fehler: Controller error / error controller

Code: D107

Fehler: Timeout error when receiving / remote programming error timeout while receiving

Code: D13E

Passive Go System

Fehler: Power failure / K CAN LOW LINE

Code: D2C4

Fehler: CAN controller error

Code: D2C7

Car Communication Computer CCC

Fehler: Line fault detection K-CAN / High / Low-line error CAN / Bus Error / CAN Bus failure

Code: E184

Fehler: Communication errors K-CAN / unknown failure / Bus OFF error CAN / unkown failure K-CAN

Code: E187

Fehler: Message failure / unknown failure / unknown fault

Code: E18D

Fehler: Message failure

Code: E18F

MASK

ECU OK, no Fault Code

Car Communication

ECU OK, no Fault Code

Anti-theft alarm system:

Interior protection / Innenraumschutz

ECU not present/no response from ECU

Theft alarm / Diebstahl Warnanlage

ECU not present/no response from ECU

Chassis:

Air suspension / Luftfederung

ECU not present/no response from ECU

Body:

Automatisches Front Steering

ECU not present/no response from ECU

Trailer / Anhaenger

ECU not present/no response from ECU

Fussraummodul /FRM

Fehler: K-CAN Controller / unkown failure / K CAN failure

Code: E587

Fehler: Light switch 1

Code: 9CAF

Fehler: Brake light switch faulty

Code: 9CAC

Fehler: :unkown failure

Code: E599

Fehler: :unkown failure

Code: E597

Fehler: :steering angle timeout

Code: E594

Fehler: unknown failure / K-CAN-Bus cable fault / Central control timeout

Code: E584

Dynamic manager / Dynamik-Manager

ECU not present/no response from ECU


I hope someone has some ideas i can try, as I cannot be without a car at the moment since i am 1000 miles from home for work.
Appreciate 0
      09-08-2014, 04:52 PM   #2
jwzimm
Colonel
jwzimm's Avatar
United_States
609
Rep
2,779
Posts

Drives: '16 M3
Join Date: Jun 2011
Location: Renton, WA

iTrader: (17)

Get your battery load tested. Being as old as your car is it is very likely that it is on it's way out. All the computers in these cars very much dislike problems with power delivery. Add to it that you have such a wide variety of faults the battery is likely the culprit.
__________________
2008 Honda S2000 - Current
2016 F80 M3 - SOLD!!
2011 e92 X-Drive Coupe - SOLD!!
Appreciate 0
      09-08-2014, 05:01 PM   #3
mathematics
Captain
mathematics's Avatar
United_States
54
Rep
998
Posts

Drives: 08 328i e93 alpine white
Join Date: May 2009
Location: Queens, NY

iTrader: (0)

first result showed 11.0 volts? i'd definitely check your battery.
__________________
iPhone 6 Plus (iTunes library/iTunes radio/Waze, etc) to Airport Express via AirPlay. Toslink out of Airport Express to Helix P-Six DSP. PHD AF 1.C tweeters, PHD FB 4.1 midranges. Jehnert Door Cards and mid-bass'.
Appreciate 0
      09-08-2014, 06:35 PM   #4
lwrs10
New Member
4
Rep
5
Posts

Drives: '08 335i
Join Date: Jul 2014
Location: United States

iTrader: (0)

The battery voltage was well over 12.5v, and at the odb port i measured 12.3v. Not sure why it says 11.
Appreciate 0
      09-08-2014, 07:49 PM   #5
jwzimm
Colonel
jwzimm's Avatar
United_States
609
Rep
2,779
Posts

Drives: '16 M3
Join Date: Jun 2011
Location: Renton, WA

iTrader: (17)

Voltage is only part of the equation. If the battery cannot support the current demand then it will crap out. Get it tested.
__________________
2008 Honda S2000 - Current
2016 F80 M3 - SOLD!!
2011 e92 X-Drive Coupe - SOLD!!
Appreciate 0
      09-09-2014, 04:50 AM   #6
ptpending
Lieutenant Colonel
184
Rep
1,560
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (1)

you may have following well known problems
1)main positive connection fusebox failure
2)battery not fixed in battery compartment
3) alternator regulator failure
4) external positive cable connector water corrosion in rear right wheel arch (under plastic arch cover)
5)incorrect battery charging program encoded or incorrect battery type, or battery replacemnt without registration
__________________
E91 2006. Retrofits:High beam assistant, Individual Audio, Autodim mirrors, CIC, Combox(USB and Bluetooth), Electric Sport Seats, Light package, Front PDC, Heated Steering Wheel, Happy Robot, Climate Comfort Windscreen, Blackline rear lights.
Appreciate 0
      09-10-2014, 01:04 PM   #7
Tegs4tugs
First Lieutenant
Tegs4tugs's Avatar
United_States
7
Rep
390
Posts

Drives: BMW E90 33?i | 90 Integra B20
Join Date: Apr 2008
Location: Westchester County, NY

iTrader: (1)

Battery would be my first guess as I have seen a lot of weird things happen with a low battery or a bad terminal connection. if that is the original battery its usually around that time to change it and keep in mind batteries usually gets worst in cooler temperature. It doesn't matter what voltage you get its the amount of power it can provide when under certain loads.
__________________

|33?i e90|Platinum Silver black leather w aluminum trim|6spd|Sport|Premium|Mtec v3|Rockford Fosgate System|
|2015 Lexus IS250 AWD|Pearl White w Tan int|Premium|Navi|
|2000 integra DC4|Silver Gray int|5spd|B20 Motor|
Appreciate 0
      09-11-2014, 08:25 PM   #8
lwrs10
New Member
4
Rep
5
Posts

Drives: '08 335i
Join Date: Jul 2014
Location: United States

iTrader: (0)

I gave up and took it to a dealer. It took them 4 days to find the problem.....but I figured it would not be easy.

It turned out to be a chafed K-can bus wire behind the HVAC controls in the dash. It was shorting to ground on a bracket. The service advisor said it's not the first one he has seen and it's quite common. I thought I bought a car that was supposed to be better quality than most. Less than a month of ownership and this wire, gas door latch broke, underseat woofers quit, and a couple other things has me thinking it's time to sell it.
Appreciate 0
      08-07-2017, 10:46 PM   #9
AWDBooSTIn90
Nomore
AWDBooSTIn90's Avatar
United_States
91
Rep
719
Posts

Drives: 335i Coupe 6MT N54
Join Date: Feb 2014
Location: Long Island

iTrader: (1)

Do you know what the dealer had to do to reset the K-Can Bus Line? I believe i have the same issue. I found the short on the K-Can wires for the CIC CID connector. It was one of the K-CAN wire(s) shorted to power & ground.

Its a 4 wire connection for the CID (I-drive Screen)..
(+12VDC, -12VDC, K-CAN-High, & K-CAN-Low)

I fixed the issue, but now I have no Gauges, BC info, no Gong's, No power door locks.

The engine does start but its definitely in some kind of limp mode. The Tach doesnt work, all gauges dont work. However, the headlights work, the dome lights come on when you open the door, the power seats work.

As soon as the issue started when i reinstalled the Idrive screen, must of twisted the wires and one pinned wire came out of the oem connector & was touching the other 3 wires... The gauges went out, BC screen went blank, HVAC screen went blank, AND the wipers went on Full Speed by themselves. I had to pull the wiper relay to shut them off.

I do hear a "relay click" sound coming from what ive found out is the JBE. Some sort of computer controlled/comm controlled fuse/relay box for a lot of different things.

I checked every single fuse in that fuse box and theyre all good.

I also had to pull the fuel pump fuse b/c it would prime the fuel pump every 15-30 seconds and i figured thats probably not good for the fuel pump or the car.

It seems like the car wont go to sleep, bc it would just does this until the battery died. The battery is about 2yrs old and i registered it after installing using INPA.

Any suggestions? I need to hook up my laptop and see if there's any codes or something bc this is very strange to me.

I already looked into the IBS on the negative terminal. Im getting contuinty between the ground post of the battery and the chassis. As well as the positive side, im getting 12vdc on all battery cables coming out of the battery top mount fuse block, as well as on both terminals under the hood.

Like i said the engine starts right up, but i have nothing else. The radio does work bc if i just click the voulume knob to turn it on, i can hear the static go up/down with the volume knob...

Did i ruin the JBE? I also heard some people talking about the FRM (nfrm) and the CAS...

My car is a 2007 E92 335i 6mt. (09/2006) So it does not fall under the IBS recall. Idk why. Is it a different setup? From pics it seems they did change it slightly in 03/2007. Which is the earliest build date E92 "3-series coupe," the IBS/Battery Cable Recall pertains too.

Idk where to go from here... I will pull some codes if i can TN or tmrw afternoon. But i have a bad feeling it won't be that easy. I was expecting to find a blown fuse and be done. Why did they complicate the JBE so much, and if so it should of been for the important stuff and not every little thing in the interior/car..

Thanks
Anthony
Appreciate 0
      03-05-2018, 12:49 PM   #10
Jeyoller
New Member
5
Rep
26
Posts

Drives: E90 335i 2011
Join Date: Feb 2015
Location: Northern Virginia

iTrader: (0)

Quote:
Originally Posted by AWDBooSTIn90 View Post
Do you know what the dealer had to do to reset the K-Can Bus Line? I believe i have the same issue. I found the short on the K-Can wires for the CIC CID connector. It was one of the K-CAN wire(s) shorted to power & ground.

Its a 4 wire connection for the CID (I-drive Screen)..
(+12VDC, -12VDC, K-CAN-High, & K-CAN-Low)

I fixed the issue, but now I have no Gauges, BC info, no Gong's, No power door locks.

The engine does start but its definitely in some kind of limp mode. The Tach doesnt work, all gauges dont work. However, the headlights work, the dome lights come on when you open the door, the power seats work.

As soon as the issue started when i reinstalled the Idrive screen, must of twisted the wires and one pinned wire came out of the oem connector & was touching the other 3 wires... The gauges went out, BC screen went blank, HVAC screen went blank, AND the wipers went on Full Speed by themselves. I had to pull the wiper relay to shut them off.

I do hear a "relay click" sound coming from what ive found out is the JBE. Some sort of computer controlled/comm controlled fuse/relay box for a lot of different things.

I checked every single fuse in that fuse box and theyre all good.

I also had to pull the fuel pump fuse b/c it would prime the fuel pump every 15-30 seconds and i figured thats probably not good for the fuel pump or the car.

It seems like the car wont go to sleep, bc it would just does this until the battery died. The battery is about 2yrs old and i registered it after installing using INPA.

Any suggestions? I need to hook up my laptop and see if there's any codes or something bc this is very strange to me.

I already looked into the IBS on the negative terminal. Im getting contuinty between the ground post of the battery and the chassis. As well as the positive side, im getting 12vdc on all battery cables coming out of the battery top mount fuse block, as well as on both terminals under the hood.

Like i said the engine starts right up, but i have nothing else. The radio does work bc if i just click the voulume knob to turn it on, i can hear the static go up/down with the volume knob...

Did i ruin the JBE? I also heard some people talking about the FRM (nfrm) and the CAS...

My car is a 2007 E92 335i 6mt. (09/2006) So it does not fall under the IBS recall. Idk why. Is it a different setup? From pics it seems they did change it slightly in 03/2007. Which is the earliest build date E92 "3-series coupe," the IBS/Battery Cable Recall pertains too.

Idk where to go from here... I will pull some codes if i can TN or tmrw afternoon. But i have a bad feeling it won't be that easy. I was expecting to find a blown fuse and be done. Why did they complicate the JBE so much, and if so it should of been for the important stuff and not every little thing in the interior/car..

Thanks
Anthony


Were you able to get this fixed m8?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:37 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST