E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Low Boost/Boost Target in MHD datalogs



Reply
 
Thread Tools Search this Thread
      03-01-2021, 04:19 PM   #1
JoshApple
Enlisted Member
JoshApple's Avatar
United_States
2
Rep
45
Posts

Drives: 2007 335i coupe
Join Date: Jul 2019
Location: Fenton Michigan

iTrader: (0)

Low Boost/Boost Target in MHD datalogs

Hello my name is Josh Appleberg and I have an 07 335i with 117k miles. I've been playing around with MHD datalogging and have been coming to this problem every time. When I do a datalog from 3k-6k rpms in 3rd gear, my boost target and boost are around 6-8 every single time. I took it to a shop a while back to get my car looked over after I changed the turbos and they said they were able to get it to 20psi when they logged it. I'm not sure why I'm not able to replicate that with my own logs. Was wondering if anybody had any ideas as to why this is happening. How does my log look otherwise? Specifically with fuel pressure as I have had some fuel related codes recently.

Ill post a pic of a log that I did today, March 1st, and also ill attach the link to the the datazap page if it works

Any insight would be greatly appreciated as I am new to datalogging

P.S. No Boost related fault codes at all

https://datazap.me/u/japple7/march-1?log=0&data=3-4-21

Mod/parts:
Vargas Stage 1 upgrade w/ Upgraded billet wheel
Silicone inlets
DCI
FMIC
BOV
Upgraded charge pipe
Attached Images
 
Appreciate 0
      03-01-2021, 04:38 PM   #2
Bimmer_Bro
First Lieutenant
Bimmer_Bro's Avatar
Canada
107
Rep
355
Posts

Drives: 2010 BMW 335xi LCI
Join Date: Dec 2019
Location: Calgary Alberta Canada

iTrader: (0)

Quote:
Originally Posted by JoshApple View Post
Hello my name is Josh Appleberg and I have an 07 335i with 117k miles. I've been playing around with MHD datalogging and have been coming to this problem every time. When I do a datalog from 3k-6k rpms in 3rd gear, my boost target and boost are around 6-8 every single time. I took it to a shop a while back to get my car looked over after I changed the turbos and they said they were able to get it to 20psi when they logged it. I'm not sure why I'm not able to replicate that with my own logs. Was wondering if anybody had any ideas as to why this is happening. How does my log look otherwise? Specifically with fuel pressure as I have had some fuel related codes recently.

Ill post a pic of a log that I did today, March 1st, and also ill attach the link to the the datazap page if it works

Any insight would be greatly appreciated as I am new to datalogging

P.S. No Boost related fault codes at all

https://datazap.me/u/japple7/march-1?log=0&data=3-4-21

Mod/parts:
Vargas Stage 1 upgrade w/ Upgraded billet wheel
Silicone inlets
DCI
FMIC
BOV
Upgraded charge pipe
What tune are you running? You are exactly on target for what the ecu is asking for.
__________________
Instagram : @Bimmer_bro
Appreciate 0
      03-01-2021, 05:16 PM   #3
Dave92N54
Second Lieutenant
Dave92N54's Avatar
United_States
92
Rep
240
Posts

Drives: 09 E92 335i 6MT
Join Date: Nov 2020
Location: Westminster, Maryland

iTrader: (0)

Garage List
2009 BMW 335i  [0.00]
6-8 is perfectly normal for a stock tune. If they were logging 20+, it either had a custom tune, or was overboosting. Not even MHD stage 2+ targets 20psi. That's quite a bit.
__________________
Current: 09 E92 335i 6MT, Alpine White
Appreciate 0
      03-01-2021, 05:54 PM   #4
JoshApple
Enlisted Member
JoshApple's Avatar
United_States
2
Rep
45
Posts

Drives: 2007 335i coupe
Join Date: Jul 2019
Location: Fenton Michigan

iTrader: (0)

Quote:
Originally Posted by Dave92N54 View Post
6-8 is perfectly normal for a stock tune. If they were logging 20+, it either had a custom tune, or was overboosting. Not even MHD stage 2+ targets 20psi. That's quite a bit.
Okay that makes much more sense. Wasn't sure what the stock target was. Now that you mention that, I don't have a tune at the moment but plan to get one in the near future. Kind of crazy why's being left on the table with stock tune/boost target.

Any word on fuel pressure readings?
Appreciate 0
      03-01-2021, 07:04 PM   #5
Bimmer_Bro
First Lieutenant
Bimmer_Bro's Avatar
Canada
107
Rep
355
Posts

Drives: 2010 BMW 335xi LCI
Join Date: Dec 2019
Location: Calgary Alberta Canada

iTrader: (0)

Quote:
Originally Posted by JoshApple View Post
Quote:
Originally Posted by Dave92N54 View Post
6-8 is perfectly normal for a stock tune. If they were logging 20+, it either had a custom tune, or was overboosting. Not even MHD stage 2+ targets 20psi. That's quite a bit.
Okay that makes much more sense. Wasn't sure what the stock target was. Now that you mention that, I don't have a tune at the moment but plan to get one in the near future. Kind of crazy why's being left on the table with stock tune/boost target.

Any word on fuel pressure readings?
Since you have silicone turbo inlets you will want to get a custom tune when the time comes. The MHD off the shelf tunes do not account for having turbo inlets. That being said, some users haven't had an issue.
I'm no expert but your low pressure fuel pump
Might be getting a bit weak. Seems to dip into the 60s during your pull.
__________________
Instagram : @Bimmer_bro
Appreciate 0
      03-01-2021, 10:32 PM   #6
Saif2018
Lieutenant Colonel
330
Rep
1,621
Posts

Drives: E90 335i
Join Date: Jan 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by Bimmer_Bro View Post
Since you have silicone turbo inlets you will want to get a custom tune when the time comes. The MHD off the shelf tunes do not account for having turbo inlets. That being said, some users haven't had an issue.
I'm no expert but your low pressure fuel pump
Might be getting a bit weak. Seems to dip into the 60s during your pull.
+1

OP needs custom tune to take good advantage of build, wouldn't be a bad idea to upgrade lpfp, although if it doesn't drop into the 50's it should be fine.
Appreciate 0
      03-01-2021, 11:15 PM   #7
JoshApple
Enlisted Member
JoshApple's Avatar
United_States
2
Rep
45
Posts

Drives: 2007 335i coupe
Join Date: Jul 2019
Location: Fenton Michigan

iTrader: (0)

Quote:
Originally Posted by Saif2018 View Post
+1

OP needs custom tune to take good advantage of build, wouldn't be a bad idea to upgrade lpfp, although if it doesn't drop into the 50's it should be fine.
I guess it's worth mentioning that I have reason to believe that the low pressure fuel pump is definitely not working properly to some extent.

First, I have a gas misreading on my dash. Already replaced fuel pressure regulator on driver side and have read that there are two separate gas reading floaters on each side and I believe the LPFP one must be broken or something.

Second, my car leaks gas after I fill it up completely for probably the first 25-50 miles. Had the shop look at it and they concluded it is most likely coming from lock ring on LPFP or around that area (they weren't very specific).

Third, I'm not certain that this is related, but, when I cruise at about 90 mph, if I decide to let off the gas to slightly decelerate, my car goes wack and starts like stuttering or hesitating. Rpms will have micro fluctuations that cause my car to feel like it's kind of jumping back and forth. Very odd but could possibly be lack of fuel from LPFP?
Appreciate 0
      03-02-2021, 12:30 PM   #8
Dave92N54
Second Lieutenant
Dave92N54's Avatar
United_States
92
Rep
240
Posts

Drives: 09 E92 335i 6MT
Join Date: Nov 2020
Location: Westminster, Maryland

iTrader: (0)

Garage List
2009 BMW 335i  [0.00]
Quote:
Originally Posted by JoshApple View Post
Quote:
Originally Posted by Saif2018 View Post
+1

OP needs custom tune to take good advantage of build, wouldn't be a bad idea to upgrade lpfp, although if it doesn't drop into the 50's it should be fine.
I guess it's worth mentioning that I have reason to believe that the low pressure fuel pump is definitely not working properly to some extent.

First, I have a gas misreading on my dash. Already replaced fuel pressure regulator on driver side and have read that there are two separate gas reading floaters on each side and I believe the LPFP one must be broken or something.

Second, my car leaks gas after I fill it up completely for probably the first 25-50 miles. Had the shop look at it and they concluded it is most likely coming from lock ring on LPFP or around that area (they weren't very specific).

Third, I'm not certain that this is related, but, when I cruise at about 90 mph, if I decide to let off the gas to slightly decelerate, my car goes wack and starts like stuttering or hesitating. Rpms will have micro fluctuations that cause my car to feel like it's kind of jumping back and forth. Very odd but could possibly be lack of fuel from LPFP?
Well first address the leak. I actually recently came across a thread on here about probably what you're experiencing. Check if you've rubbed a hole in your filler neck, I believe for most it occurs in the rear passenger wheel well. Any kind of a leak would cause some issues. If you have a leak and it's still not dropping below 60psi i'd find it hard to believe the pump is bad. As for the gas level, the floater could just be stuck.

Edit: wait they said from the lock ring on the pump? So it's leaking inside the vehicle??

Edit2: Decided to look at your log myself. Everything looks pretty good although your stft are pretty high. At -20% you're pulling a lot of fuel. What injectors do you have?
__________________
Current: 09 E92 335i 6MT, Alpine White
Appreciate 0
      03-02-2021, 12:49 PM   #9
stewbets
Captain
317
Rep
619
Posts

Drives: '08 335xi, '04 545i
Join Date: Sep 2019
Location: Dayton, OH

iTrader: (0)

Quote:
Originally Posted by JoshApple View Post
I guess it's worth mentioning that I have reason to believe that the low pressure fuel pump is definitely not working properly to some extent.

First, I have a gas misreading on my dash. Already replaced fuel pressure regulator on driver side and have read that there are two separate gas reading floaters on each side and I believe the LPFP one must be broken or something.

Second, my car leaks gas after I fill it up completely for probably the first 25-50 miles. Had the shop look at it and they concluded it is most likely coming from lock ring on LPFP or around that area (they weren't very specific).

Third, I'm not certain that this is related, but, when I cruise at about 90 mph, if I decide to let off the gas to slightly decelerate, my car goes wack and starts like stuttering or hesitating. Rpms will have micro fluctuations that cause my car to feel like it's kind of jumping back and forth. Very odd but could possibly be lack of fuel from LPFP?
I don't think there's anything wrong with the LPFP itself. There could very well be a float issue. There's only one and it's on the LPFP. The HPFP also looks good. Your fuel trims are a little concerning though. They go from way positive to way negative throughout the pull. Can you also log you LTFT's to see where they're at? It would also be a good idea to get a log of this stuttering that takes place on deceleration. It doesn't seem like it would be fuel pump related. If your gas tank was leaking from the lock ring, you would have a very strong smell in your car.
__________________
2008 335xi 6MT - eBay FMIC, DP's & CP - VRSF Inlets - SSR DCI's - Walbro 450 LPFP - TURTLE BOOST GAUGE - RFP e85 Tune
Appreciate 0
      03-02-2021, 03:05 PM   #10
iqraceworks
Colonel
iqraceworks's Avatar
803
Rep
2,310
Posts

Drives: 2007 335i
Join Date: Aug 2019
Location: Missouri

iTrader: (0)

Quote:
Originally Posted by Dave92N54 View Post
6-8 is perfectly normal for a stock tune. If they were logging 20+, it either had a custom tune, or was overboosting. Not even MHD stage 2+ targets 20psi. That's quite a bit.
I'm pretty sure my MHD V5 Stage 2+ E40 tune targets 21psi, and then starts to taper off as the rpms climb........I'd love to put the car on a dyno and see how much power it's making. That tune is night and day more powerful vs any of the stage 2+ 93 tunes.
Appreciate 0
      03-03-2021, 01:44 AM   #11
JoshApple
Enlisted Member
JoshApple's Avatar
United_States
2
Rep
45
Posts

Drives: 2007 335i coupe
Join Date: Jul 2019
Location: Fenton Michigan

iTrader: (0)

Quote:
Originally Posted by Dave92N54 View Post
Quote:
Originally Posted by JoshApple View Post
Quote:
Originally Posted by Saif2018 View Post
+1

OP needs custom tune to take good advantage of build, wouldn't be a bad idea to upgrade lpfp, although if it doesn't drop into the 50's it should be fine.
I guess it's worth mentioning that I have reason to believe that the low pressure fuel pump is definitely not working properly to some extent.

First, I have a gas misreading on my dash. Already replaced fuel pressure regulator on driver side and have read that there are two separate gas reading floaters on each side and I believe the LPFP one must be broken or something.

Second, my car leaks gas after I fill it up completely for probably the first 25-50 miles. Had the shop look at it and they concluded it is most likely coming from lock ring on LPFP or around that area (they weren't very specific).

Third, I'm not certain that this is related, but, when I cruise at about 90 mph, if I decide to let off the gas to slightly decelerate, my car goes wack and starts like stuttering or hesitating. Rpms will have micro fluctuations that cause my car to feel like it's kind of jumping back and forth. Very odd but could possibly be lack of fuel from LPFP?
Well first address the leak. I actually recently came across a thread on here about probably what you're experiencing. Check if you've rubbed a hole in your filler neck, I believe for most it occurs in the rear passenger wheel well. Any kind of a leak would cause some issues. If you have a leak and it's still not dropping below 60psi i'd find it hard to believe the pump is bad. As for the gas level, the floater could just be stuck.

Edit: wait they said from the lock ring on the pump? So it's leaking inside the vehicle??

Edit2: Decided to look at your log myself. Everything looks pretty good although your stft are pretty high. At -20% you're pulling a lot of fuel. What injectors do you have?
I will check out the leak and post some photos if I can of where it's coming from. I will also check under rear passenger seat and see if I can see any visible leaks there. The shop wasn't very specific but that's what they said. Somewhere around the lock ring. Car stinks up my entire garage with a strong gas smell after I fill up as well.

I have index 12s, I changed them soon after I got my car becuase the others were giving up. Coded them properly myself and haven't had problems with them since.

Just read up about those fuel trims and I'm pretty new to it but it definitely sounds concerning. What are the possible causes or consequences of those fuel trims?

WORTH NOTING

I did have a problem in the past with fuel or oil being sent into my exhaust and caused all my cats to just become toast. Changed downpipes when I changed my turbos and the cats in the downpipes were completely gone. As for the secondary cats in the midpipe, I'm not entirely sure of the condition of them. Most likely are also gone, or partially gone. Could any of this play into those fuel trim problems?

I will make sure to post another log including LTFT and some other metrics and see.

EDIT: Also have had code 2A16 (fuel tank ventilation system and purge air system - micro-leak) pretty consistently for a while now just haven't gotten into fixing it yet.

Thanks a lot
Appreciate 0
      03-03-2021, 01:46 AM   #12
JoshApple
Enlisted Member
JoshApple's Avatar
United_States
2
Rep
45
Posts

Drives: 2007 335i coupe
Join Date: Jul 2019
Location: Fenton Michigan

iTrader: (0)

Quote:
Originally Posted by stewbets View Post
Quote:
Originally Posted by JoshApple View Post
I guess it's worth mentioning that I have reason to believe that the low pressure fuel pump is definitely not working properly to some extent.

First, I have a gas misreading on my dash. Already replaced fuel pressure regulator on driver side and have read that there are two separate gas reading floaters on each side and I believe the LPFP one must be broken or something.

Second, my car leaks gas after I fill it up completely for probably the first 25-50 miles. Had the shop look at it and they concluded it is most likely coming from lock ring on LPFP or around that area (they weren't very specific).

Third, I'm not certain that this is related, but, when I cruise at about 90 mph, if I decide to let off the gas to slightly decelerate, my car goes wack and starts like stuttering or hesitating. Rpms will have micro fluctuations that cause my car to feel like it's kind of jumping back and forth. Very odd but could possibly be lack of fuel from LPFP?
I don't think there's anything wrong with the LPFP itself. There could very well be a float issue. There's only one and it's on the LPFP. The HPFP also looks good. Your fuel trims are a little concerning though. They go from way positive to way negative throughout the pull. Can you also log you LTFT's to see where they're at? It would also be a good idea to get a log of this stuttering that takes place on deceleration. It doesn't seem like it would be fuel pump related. If your gas tank was leaking from the lock ring, you would have a very strong smell in your car.
Check the reply I posted for Dave's comment. I will try to log again tomorrow and maybe even try to get a log of the stuttering as well.

Most of my other details I explained in my reply to Dave.

Thanks a lot
Appreciate 0
      03-04-2021, 09:15 PM   #13
JoshApple
Enlisted Member
JoshApple's Avatar
United_States
2
Rep
45
Posts

Drives: 2007 335i coupe
Join Date: Jul 2019
Location: Fenton Michigan

iTrader: (0)

Updated Logs: LTFT Included, 90 Decel and WOT

stewbets
Dave92N54

Here are some updated logs that include more relevant details.

1- First attempt 90 Deceleration to capture stuttering

https://datazap.me/u/japple7/first-9...?log=0&data=21

2- Second attempt 90 Deceleration to capture stuttering

https://datazap.me/u/japple7/2nd-90-decel?log=0&data=21

3- WOT w/ LTFT

https://datazap.me/u/japple7/wot-log...?log=0&data=21



Filled up my tank and couldn't see it leaking this time around.

Will attach the pictures I took around LPFP Lock Ring. It is wet but from not sure from where. Some weird crud material in the housing area.
Attached Images
         
Appreciate 0
      03-04-2021, 11:04 PM   #14
Tyc0
Second Lieutenant
51
Rep
279
Posts

Drives: BMW e92 335i
Join Date: Sep 2019
Location: Oregon

iTrader: (0)

I'd bet your lock ring has rusted away. Is it possible someone touched your lpfp and in the process got the floater caught all while somehow ruining the lock ring causing it to leak ? Just a guess
Appreciate 0
      03-05-2021, 07:50 AM   #15
stewbets
Captain
317
Rep
619
Posts

Drives: '08 335xi, '04 545i
Join Date: Sep 2019
Location: Dayton, OH

iTrader: (0)

Quote:
Originally Posted by JoshApple View Post
I will check out the leak and post some photos if I can of where it's coming from. I will also check under rear passenger seat and see if I can see any visible leaks there. The shop wasn't very specific but that's what they said. Somewhere around the lock ring. Car stinks up my entire garage with a strong gas smell after I fill up as well.

I have index 12s, I changed them soon after I got my car becuase the others were giving up. Coded them properly myself and haven't had problems with them since.

Just read up about those fuel trims and I'm pretty new to it but it definitely sounds concerning. What are the possible causes or consequences of those fuel trims?

WORTH NOTING

I did have a problem in the past with fuel or oil being sent into my exhaust and caused all my cats to just become toast. Changed downpipes when I changed my turbos and the cats in the downpipes were completely gone. As for the secondary cats in the midpipe, I'm not entirely sure of the condition of them. Most likely are also gone, or partially gone. Could any of this play into those fuel trim problems?

I will make sure to post another log including LTFT and some other metrics and see.

EDIT: Also have had code 2A16 (fuel tank ventilation system and purge air system - micro-leak) pretty consistently for a while now just haven't gotten into fixing it yet.

Thanks a lot
How long has it been since you changed out your injectors? Your STFT's and LTFT's are mirroring each other, maxed out in opposite directions, so I'd reset the trim adaptations and give them a fresh start. I don't see any issues with either of your fuel pumps. Your 2A16 code is consistent with your leaking lock ring. What I would do is drive it till you have less than 1/4 tank and then pound off that lock ring, inspect the LPFP float and put on a new lock ring. Do you know if the O2 sensors have been replaced? I wouldn't be surprised if whatever destroyed your cats also damaged the sensors and they're not reporting accurately. This could be the cause of your stuttering.
__________________
2008 335xi 6MT - eBay FMIC, DP's & CP - VRSF Inlets - SSR DCI's - Walbro 450 LPFP - TURTLE BOOST GAUGE - RFP e85 Tune
Appreciate 0
      03-05-2021, 12:07 PM   #16
JoshApple
Enlisted Member
JoshApple's Avatar
United_States
2
Rep
45
Posts

Drives: 2007 335i coupe
Join Date: Jul 2019
Location: Fenton Michigan

iTrader: (0)

Quote:
Originally Posted by stewbets View Post
Quote:
Originally Posted by JoshApple View Post
I will check out the leak and post some photos if I can of where it's coming from. I will also check under rear passenger seat and see if I can see any visible leaks there. The shop wasn't very specific but that's what they said. Somewhere around the lock ring. Car stinks up my entire garage with a strong gas smell after I fill up as well.

I have index 12s, I changed them soon after I got my car becuase the others were giving up. Coded them properly myself and haven't had problems with them since.

Just read up about those fuel trims and I'm pretty new to it but it definitely sounds concerning. What are the possible causes or consequences of those fuel trims?

WORTH NOTING

I did have a problem in the past with fuel or oil being sent into my exhaust and caused all my cats to just become toast. Changed downpipes when I changed my turbos and the cats in the downpipes were completely gone. As for the secondary cats in the midpipe, I'm not entirely sure of the condition of them. Most likely are also gone, or partially gone. Could any of this play into those fuel trim problems?

I will make sure to post another log including LTFT and some other metrics and see.

EDIT: Also have had code 2A16 (fuel tank ventilation system and purge air system - micro-leak) pretty consistently for a while now just haven't gotten into fixing it yet.

Thanks a lot
How long has it been since you changed out your injectors? Your STFT's and LTFT's are mirroring each other, maxed out in opposite directions, so I'd reset the trim adaptations and give them a fresh start. I don't see any issues with either of your fuel pumps. Your 2A16 code is consistent with your leaking lock ring. What I would do is drive it till you have less than 1/4 tank and then pound off that lock ring, inspect the LPFP float and put on a new lock ring. Do you know if the O2 sensors have been replaced? I wouldn't be surprised if whatever destroyed your cats also damaged the sensors and they're not reporting accurately. This could be the cause of your stuttering.
I replaced injectors soon after I bought the car and made them all index 12's, I would guess somewhere around Aug-Sep 2019. I will give that a shot and see what happens.

When I changed my turbos, one of the pre-cat o2's was literally fried. I'll attach the picture I took of it but I replaced it. The other one seemed to be fine and I was tight on cash at that time so I just replaced the visually compromised one.

Edit: So to answer your question, I have replaced the one pictured being one of the Precat ones. The other 3 have not been replaced.

Is it possible to reset fuel trim adaptations in MHD? If not I can hook up INPA and do it that way.

Thanks for all the help I appreciate it!!

stewbets
Attached Images
 
Appreciate 0
      03-05-2021, 01:14 PM   #17
stewbets
Captain
317
Rep
619
Posts

Drives: '08 335xi, '04 545i
Join Date: Sep 2019
Location: Dayton, OH

iTrader: (0)

Goodness, that IS fried! I think there's reason to believe the others may also be compromised. I was hesitant about replacing my O2 sensors for a while, but it made a huge difference. I wasn't getting codes for them either. And yes, you can reset trims with MHD. Just select both lambda options from the adaptations menu.
__________________
2008 335xi 6MT - eBay FMIC, DP's & CP - VRSF Inlets - SSR DCI's - Walbro 450 LPFP - TURTLE BOOST GAUGE - RFP e85 Tune
Appreciate 1
      03-05-2021, 01:44 PM   #18
Dave92N54
Second Lieutenant
Dave92N54's Avatar
United_States
92
Rep
240
Posts

Drives: 09 E92 335i 6MT
Join Date: Nov 2020
Location: Westminster, Maryland

iTrader: (0)

Garage List
2009 BMW 335i  [0.00]
To me that leak looks like it's coming from the hose with the 90 degree elbow, not the actual lock ring. It looks like the leak is landing in top of it, not coming out from under.

If you have the MHD flasher module you can reset adaptations, otherwise INPA.
__________________
Current: 09 E92 335i 6MT, Alpine White
Appreciate 1
stewbets316.50

      03-05-2021, 01:47 PM   #19
stewbets
Captain
317
Rep
619
Posts

Drives: '08 335xi, '04 545i
Join Date: Sep 2019
Location: Dayton, OH

iTrader: (0)

Quote:
Originally Posted by Dave92N54 View Post
To me that leak looks like it's coming from the hose with the 90 degree elbow, not the actual lock ring. It looks like the leak is landing in top of it, not coming out from under.

If you have the MHD flasher module you can reset adaptations, otherwise INPA.
Good call, I can see that now.
__________________
2008 335xi 6MT - eBay FMIC, DP's & CP - VRSF Inlets - SSR DCI's - Walbro 450 LPFP - TURTLE BOOST GAUGE - RFP e85 Tune
Appreciate 0
      03-05-2021, 03:49 PM   #20
JoshApple
Enlisted Member
JoshApple's Avatar
United_States
2
Rep
45
Posts

Drives: 2007 335i coupe
Join Date: Jul 2019
Location: Fenton Michigan

iTrader: (0)

@Dave92N54
stewbets

Lolol yeah I said the same thing when I saw that thing. Will reset adaptations and see how that feels. Should definitely look into replacing atleast the other Pre-Cat 02.

I thought the same thing when I saw it but I was playing with that hose and didn't seem to see any visual leak from it anywhere. Jiggled it around and felt underneath it and was fine. Will keep watching it
Appreciate 1
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:06 AM.




e90post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST